Wenzhe Zhou has posted comments on this change. ( 
http://gerrit.cloudera.org:8080/19384 )

Change subject: KUDU-1945: Support non unique primary key for Java client
......................................................................


Patch Set 10:

(2 comments)

The build failure was due to the dependency on the server side change 
https://gerrit.cloudera.org/#/c/19097/. The code change is dependent on the 
additional fields added to src/kudu/common/common.proto by that patch.

http://gerrit.cloudera.org:8080/#/c/19384/10/java/kudu-client/src/main/java/org/apache/kudu/ColumnSchema.java
File java/kudu-client/src/main/java/org/apache/kudu/ColumnSchema.java:

http://gerrit.cloudera.org:8080/#/c/19384/10/java/kudu-client/src/main/java/org/apache/kudu/ColumnSchema.java@397
PS10, Line 397:     /**
              :      * Sets if the column is auto-incrementing column. False by 
default.
              :      * @param autoIncrementing a boolean that indicates if the 
column is
              :      * an auto-incrementing column
              :      * @return this instance
              :      */
              :     public ColumnSchemaBuilder autoIncrementing(boolean 
autoIncrementing) {
              :       this.autoIncrementing = autoIncrementing;
              :       return this;
              :     }
> BTW, did you explore an alternative here: add a new helper class AutoIncrem
That's good suggestion. It will reduce the error.


http://gerrit.cloudera.org:8080/#/c/19384/10/java/kudu-client/src/main/java/org/apache/kudu/Schema.java
File java/kudu-client/src/main/java/org/apache/kudu/Schema.java:

http://gerrit.cloudera.org:8080/#/c/19384/10/java/kudu-client/src/main/java/org/apache/kudu/Schema.java@125
PS10, Line 125: findKey
> nit: maybe, rename this into 'isKeyFound' for better readability?
Done



--
To view, visit http://gerrit.cloudera.org:8080/19384
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: I7e2501d6b3d66f6466959e4f3f1ed0f5e08dfe5c
Gerrit-Change-Number: 19384
Gerrit-PatchSet: 10
Gerrit-Owner: Wenzhe Zhou <wz...@cloudera.com>
Gerrit-Reviewer: Abhishek Chennaka <achenn...@cloudera.com>
Gerrit-Reviewer: Alexey Serbin <ale...@apache.org>
Gerrit-Reviewer: Kudu Jenkins (120)
Gerrit-Reviewer: Kurt Deschler <kdesc...@cloudera.com>
Gerrit-Reviewer: Marton Greber <greber...@gmail.com>
Gerrit-Reviewer: Wenzhe Zhou <wz...@cloudera.com>
Gerrit-Comment-Date: Wed, 04 Jan 2023 06:57:37 +0000
Gerrit-HasComments: Yes

Reply via email to