Marton Greber has posted comments on this change. ( 
http://gerrit.cloudera.org:8080/24518 )

Change subject: [java] Replace deprecated APIs to silence build warnings
......................................................................


Patch Set 3:

(2 comments)

http://gerrit.cloudera.org:8080/#/c/24518/3/java/kudu-hive/src/test/java/org/apache/kudu/hive/metastore/TestKuduMetastorePlugin.java
File 
java/kudu-hive/src/test/java/org/apache/kudu/hive/metastore/TestKuduMetastorePlugin.java:

http://gerrit.cloudera.org:8080/#/c/24518/3/java/kudu-hive/src/test/java/org/apache/kudu/hive/metastore/TestKuduMetastorePlugin.java@64
PS3, Line 64:   @SuppressWarnings("deprecation")
nit: The helper name `getTable` shadows the semantic of what it wraps. A name 
like `fetchTable` or keeping the inline call with a method-level 
`@SuppressWarnings` would be more discoverable for future readers - but this is 
fine too since it centralizes the suppression.


http://gerrit.cloudera.org:8080/#/c/24518/3/java/kudu-test-utils/src/main/java/org/apache/kudu/test/cluster/FakeDNS.java
File 
java/kudu-test-utils/src/main/java/org/apache/kudu/test/cluster/FakeDNS.java:

http://gerrit.cloudera.org:8080/#/c/24518/3/java/kudu-test-utils/src/main/java/org/apache/kudu/test/cluster/FakeDNS.java@154
PS3, Line 154:         Throwable cause = e.getCause();
q: The old `Throwables.propagateIfPossible(e.getCause(), 
UnknownHostException.class)` would also propagate `RuntimeException` and 
`Error` unwrapped - the new code wraps those in `AssertionError` instead. This 
is likely fine since the fallback name service shouldn't throw those in 
practice and it's a test utility, but it's a subtle semantic change. The commit 
message says "No behavioral change" - worth a note that this is intentionally 
simplified, or adding `if (cause instanceof RuntimeException) throw 
(RuntimeException) cause; if (cause instanceof Error) throw (Error) cause;` to 
preserve full equivalence.



--
To view, visit http://gerrit.cloudera.org:8080/24518
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: master
Gerrit-MessageType: comment
Gerrit-Change-Id: Ia10fdbca3733d9b16caf8d4c0ad00e2234092d39
Gerrit-Change-Number: 24518
Gerrit-PatchSet: 3
Gerrit-Owner: Zoltan Chovan <[email protected]>
Gerrit-Reviewer: Kudu Jenkins (120)
Gerrit-Reviewer: Marton Greber <[email protected]>
Gerrit-Comment-Date: Mon, 29 Jun 2026 16:18:50 +0000
Gerrit-HasComments: Yes

Reply via email to