Alexey Serbin has posted comments on this change. ( 
http://gerrit.cloudera.org:8080/20814 )

Change subject: Add blog post about Prometheus/Grafana
......................................................................


Patch Set 2: Code-Review+1

(3 comments)

Thank you for revving the patch!

http://gerrit.cloudera.org:8080/#/c/20814/1/_posts/2023-12-18-kudu-prometheus-grafana.md
File _posts/2023-12-18-kudu-prometheus-grafana.md:

http://gerrit.cloudera.org:8080/#/c/20814/1/_posts/2023-12-18-kudu-prometheus-grafana.md@24
PS1, Line 24:
> I agree with Alexey that we should document the current capability limits i
I posted my original comment on PS1 in January 2024.  As of July 2026 the 
tablet-level metrics are now available in Prometheus format since KUDU-3563 had 
been implemented and then refined with KUDU-3692.

IIUC, with KUDU-3563 and KUDU-3692 implemented, tablet-level metrics are 
available in Prometheus format.  The --prometheus_use_entity_labels flag 
controls the way they are represented in the output.  Please correct me if I'm 
wrong.

In this context, I'd also consider informing the reader that 
--prometheus_use_entity_labels stays 'false' by default due to backward 
compatibility reasons, and it's necessary to tweak the flag to allow for 
natural aggregation of the metrics.


http://gerrit.cloudera.org:8080/#/c/20814/2/_posts/2026-07-03-kudu-prometheus-grafana.md
File _posts/2026-07-03-kudu-prometheus-grafana.md:

http://gerrit.cloudera.org:8080/#/c/20814/2/_posts/2026-07-03-kudu-prometheus-grafana.md@20
PS2, Line 20: web UI
web server


http://gerrit.cloudera.org:8080/#/c/20814/2/_posts/2026-07-03-kudu-prometheus-grafana.md@21
PS2, Line 21: aggregation
Does it make sense to mention tweaking --prometheus_use_entity_labels flag to 
enable various levels of aggregation for the exposed metrics?  I'd also think 
of mentioning that the current default value of --prometheus_use_entity_labels 
is chosen to preserve backwards compatibility with the legacy naming scheme of 
the Kudu's metrics in Prometheus format.

I guess it's also worth it recommending to set --prometheus_use_entity_labels=1 
when starting from scratch, i.e. if there aren't any components that expect the 
legacy format of the Kudu's metrics exposed in Prometheus format.



--
To view, visit http://gerrit.cloudera.org:8080/20814
To unsubscribe, visit http://gerrit.cloudera.org:8080/settings

Gerrit-Project: kudu
Gerrit-Branch: gh-pages
Gerrit-MessageType: comment
Gerrit-Change-Id: I85878378f883b2cc1f8136bde2c9f0db7ceccd8f
Gerrit-Change-Number: 20814
Gerrit-PatchSet: 2
Gerrit-Owner: Marton Greber <[email protected]>
Gerrit-Reviewer: Alexey Serbin <[email protected]>
Gerrit-Reviewer: Attila Bukor <[email protected]>
Gerrit-Reviewer: Gabriella Lotz <[email protected]>
Gerrit-Reviewer: Marton Greber <[email protected]>
Gerrit-Reviewer: Yan-Daojiang <[email protected]>
Gerrit-Reviewer: Zoltan Chovan <[email protected]>
Gerrit-Comment-Date: Mon, 06 Jul 2026 22:34:30 +0000
Gerrit-HasComments: Yes

Reply via email to