-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/34426/#review84445
-----------------------------------------------------------



src/linux/routing/queueing/fq_codel.hpp
<https://reviews.apache.org/r/34426/#comment135709>

    It doesn't return false, it returns a Handle.



src/linux/routing/queueing/fq_codel.hpp
<https://reviews.apache.org/r/34426/#comment135711>

    Please reorder the parameters, move 'parent' before 'handle', this reads 
better.



src/linux/routing/queueing/fq_codel.cpp
<https://reviews.apache.org/r/34426/#comment135712>

    Ditto



src/linux/routing/queueing/ingress.hpp
<https://reviews.apache.org/r/34426/#comment135708>

    The comment needs to update, since now the return value is Handle.



src/linux/routing/queueing/ingress.cpp
<https://reviews.apache.org/r/34426/#comment135715>

    Please print the link name in error message.



src/linux/routing/queueing/internal.hpp
<https://reviews.apache.org/r/34426/#comment135717>

    Ditto



src/linux/routing/queueing/internal.hpp
<https://reviews.apache.org/r/34426/#comment135710>

    Ditto



src/slave/containerizer/isolators/network/port_mapping.cpp
<https://reviews.apache.org/r/34426/#comment135713>

    s/the filter handles/the ingress qdisc handle/ ?



src/slave/containerizer/isolators/network/port_mapping.cpp
<https://reviews.apache.org/r/34426/#comment135718>

    Ditto



src/tests/port_mapping_tests.cpp
<https://reviews.apache.org/r/34426/#comment135725>

    s/eth0IngressQdisc/eth0IngressHandle/



src/tests/port_mapping_tests.cpp
<https://reviews.apache.org/r/34426/#comment135726>

    Ditto



src/tests/routing_tests.cpp
<https://reviews.apache.org/r/34426/#comment135719>

    vethHandle is a bad name, it reads like a handle of veth. Please rename it 
to 'egressHandle'.


- Cong Wang


On May 19, 2015, 7:55 p.m., Paul Brett wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/34426/
> -----------------------------------------------------------
> 
> (Updated May 19, 2015, 7:55 p.m.)
> 
> 
> Review request for mesos, Chi Zhang, Ian Downes, Jie Yu, and Cong Wang.
> 
> 
> Bugs: MESOS-2665
>     https://issues.apache.org/jira/browse/MESOS-2665
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Extend the Traffic Control queueing models to allow dynamically allocated 
> Handles, extend API to allow searching by handle (or parent).
> 
> 
> Diffs
> -----
> 
>   src/linux/routing/queueing/fq_codel.hpp 
> 4f67ab7d64afea96a07dfcf36769a9c667749a00 
>   src/linux/routing/queueing/fq_codel.cpp 
> 02ad8df7814c0e549a9ca9aef39777684e6abdcb 
>   src/linux/routing/queueing/ingress.hpp 
> b323a7f6daed828327d6d9e9740df81582e0ba2b 
>   src/linux/routing/queueing/ingress.cpp 
> 47c73376097d70819defdee31a6d1e446df6b8ba 
>   src/linux/routing/queueing/internal.hpp 
> 7c6c4d3d960b9a4bf44dcf482212317522353d69 
>   src/slave/containerizer/isolators/network/port_mapping.cpp 
> 49e983edab598e2ac487bb488fdd12840a9e7dfc 
>   src/tests/port_mapping_tests.cpp b8c2db6d0a02f79d38a21c227575299880980502 
>   src/tests/routing_tests.cpp 6bf5e63aecf2dee36fb8cf3575c0bd2625d29dfa 
> 
> Diff: https://reviews.apache.org/r/34426/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Paul Brett
> 
>

Reply via email to