> On Aug. 4, 2015, 3:21 a.m., Adam B wrote:
> > LGTM. I like the idea of not setting the executorId=taskId in the actual 
> > TaskInfo/Task, since that could confuse other logic downstream that expects 
> > the executor/executorId to be empty for command executors. However, since 
> > this is exposed in state.json, there might be external tools/scripts that 
> > expect the same. Now they can just check if executorId==taskId, assuming 
> > there are no custom executors using the same naming scheme. Could you 
> > please add a note to docs/upgrades.md mentioning the API change, in case 
> > anybody does depend on the old behavior?
> > Does this actually solve the problem of: "The webui is broken for command 
> > executors because the master does not know the executor ID for the tasks 
> > using a command executor."?
> > @bmahler do you have any further thoughts/questions on this simple change?

Can we at least add comment in the slave code where we set the executor id for 
command executor, that the master is now assuming the slave uses the task id as 
the executor id?


- Ben


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/36814/#review93995
-----------------------------------------------------------


On Aug. 4, 2015, 9:33 a.m., haosdent huang wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/36814/
> -----------------------------------------------------------
> 
> (Updated Aug. 4, 2015, 9:33 a.m.)
> 
> 
> Review request for mesos, Adam B, Ben Mahler, and Michael Park.
> 
> 
> Bugs: MESOS-527
>     https://issues.apache.org/jira/browse/MESOS-527
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Fill executor_id in state.json when task is run in CommandExecutor.
> 
> 
> Diffs
> -----
> 
>   src/common/http.cpp a74c51d9392d0b0a67d51a0143eb314cfca11245 
>   src/tests/common/http_tests.cpp 38d062b2b4062e0a2fc912bad0cc2d73339eb66e 
> 
> Diff: https://reviews.apache.org/r/36814/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> haosdent huang
> 
>

Reply via email to