-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/54097/#review157158
-----------------------------------------------------------


Fix it, then Ship it!





3rdparty/stout/include/stout/flags/flags.hpp (line 302)
<https://reviews.apache.org/r/54097/#comment227589>

    The name `exportEnvironment` is misleading. It makes me think this function 
is actually going to export flags as environment variables in the current 
environment.
    
    What it's actually doing is taking the flags and building a string based 
key/value map out of them.
    
    I would rename this function to something like `buildEnvironment` or even 
`buildKeyValueMap` instead of `export*`.


- Kevin Klues


On Nov. 27, 2016, 7:47 a.m., Jie Yu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/54097/
> -----------------------------------------------------------
> 
> (Updated Nov. 27, 2016, 7:47 a.m.)
> 
> 
> Review request for mesos, Gilbert Song and Kevin Klues.
> 
> 
> Bugs: MESOS-6648
>     https://issues.apache.org/jira/browse/MESOS-6648
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> This patch added a method to FlagsBase to export the flags as a map of
> environment variables. This simplifies the logic when the caller wants
> to pass flags as environment variables to the subprocess.
> 
> 
> Diffs
> -----
> 
>   3rdparty/stout/include/stout/flags/flags.hpp 
> 06aac13836fbe7f1d970476f073a48e9f4bdb168 
>   3rdparty/stout/tests/flags_tests.cpp 
> 9ee538bd0afa3fb3b6debc6eda010552d9062ad7 
> 
> Diff: https://reviews.apache.org/r/54097/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Jie Yu
> 
>

Reply via email to