On Thursday, August 07, 2008, at 02:50PM, "Ralf S. Engelschall" <[EMAIL 
PROTECTED]> wrote:
>On Thu, Aug 07, 2008, Alexey Tourbin wrote:
>
>> [...]
>> >     - jbj: replace <stdint.h> with private typedefs.
>>
>> Why private typedefs are any better?
>
>For instance because the private ones are available everywhere while
>the <stdint.h> ones require at least a C99 environment which in turn
>unnecessarily increases the entry barrier for a bootstrapping tool like
>RPM when it comes to non-Linux platforms.
>

That's part of the issue.

The real issue is that developers who see "uint32_t" end up seeing
    1) unsigned
    2) integer
    3) 32 bits
    4) data type

What developers do _NOT_ see is what was present with "int_32"
data types
     An integer from a Header.

Successful private data types should be named according to semantic
usage, not implementation attributes.

rpmTag is s successful private data type.

rpmuint32_t and rpmuint8_t are just scaffholding to get <stdint.h>
out of the way while I get better data types (like rpmiob) into rpm's API
instead.

I really couldn't care less what an integer or an octet is called. But
this is like the 4th or 5th time I've been forced to rename rpm integers
and octets ...

73 de Jeff
>                                       Ralf S. Engelschall
>                                       [EMAIL PROTECTED]
>                                       www.engelschall.com
>
>______________________________________________________________________
>RPM Package Manager                                    http://rpm5.org
>Developer Communication List                        rpm-devel@rpm5.org
>
>
______________________________________________________________________
RPM Package Manager                                    http://rpm5.org
Developer Communication List                        rpm-devel@rpm5.org

Reply via email to