On 27.10.2008 12:15, Chris Nolan wrote:
Thorsten Leemhuis wrote:
Please don't use the term "-kmod-common" in the package name; just
call it "broadcom-hybrid-wl" and add
Provides: broadcom-hybrid-wl-kmod-common = %{version}-%{release}
Thinking about it some more: Maybe the best scheme for both packages
might be:
"kmod-wl" for the kmod package
"broadcom-hybrid-wl" for the second "userland" package (which then
needs to provide wl-kmod-common = %{version}-%{release})
Opinions?
As an end user I find that slightly confusing to have so many different
permutations. I would find it less confusing to do your original way and
drop the "hybrid" altogether:
"kmod-wl" for the kmod package
"broadcom-wl" for the "userland" package
Sounds good.
which provides broadcom-wl-common = %{version}-%{release}
That nevertheless needs to provide "wl-kmod-common =
%{version}-%{release}" to satisfy the dep that automatically (by the
dark magic from kmodtool) gets added to each kmod package; but the user
normally won't see that.
> [...]
Cu
knurd