I agree that this is not worth the effort. 

A good way to look at it is "I am sure this code is html_safe, so I can 
unescape it." 

Otherwise "non_escapify_html" sounds pretty rails-y.

:-P



On Friday, February 6, 2015 at 8:15:38 AM UTC-8, Rafael Mendonça França 
wrote:
>
> In our opinion this is will cause an unnecessary amount of work to people 
> upgrading their applications. We want to avoid adding breaking 
> changes/deprecation if we can.
>
> On Fri Feb 06 2015 at 2:10:33 PM Ufuk Kayserilioglu <uf...@paralaus.com 
> <javascript:>> wrote:
>
>> Rafael,
>>
>> I do agree with you; however, the same argument could be made for 
>> renaming it as well. If it is a private implementation concern and nobody 
>> should be using it, then there should be no problems with a rename to make 
>> sure that the name is scary enough to stop people from using it and/or 
>> break applications that are using it.
>>
>> --
>> Ufuk Kayserilioglu
>>
>>
>> On 6 February 2015 at 17:50:24, Rafael Mendonça França (
>> rafael...@gmail.com <javascript:>) wrote:
>>  Renaming this method is not an option.
>>
>> The main reason is: it should not be used by end users. It is an 
>> implementation detail of the framework and although it is exposed to the 
>> users we don't recommend to use it directly. 
>>
>> So when Andrew said "we should rename it to something even longer so 
>> that people don't use it" it was a joke, but just a half joke. We really 
>> don't want to people to use it.
>>
>>  Almost 90% of the cases that people use `html_safe` what they really 
>> wanted is `sanitize`. Also, some day HTML escaping implementation could 
>> change `html_safe` be completely gone.
>>
>>  This is why we have the `raw` method, to expose a public API to disable 
>> the HTML escaping without exposing the implementation detail.
>>  
>>  So I don't think we should rename an "internal" method to make it 
>> explicit to end users.
>>
>> On Fri Feb 06 2015 at 1:41:36 PM Ufuk Kayserilioglu <uf...@paralaus.com 
>> <javascript:>> wrote:
>>
>>>  IMHO, the target audience is largely an irrelevant concern. The more 
>>> important concept is making users fall into the "pit 
>>> <http://blog.codinghorror.com/falling-into-the-pit-of-success/> of 
>>> success <http://blogs.msdn.com/b/brada/archive/2003/10/02/50420.aspx>". 
>>> In that light, the proposed renaming makes sense.
>>>  
>>>  Don't forget, the clearer the intention of the method the better it is 
>>> for both novice and experienced programmers.
>>>
>>> --
>>> Ufuk Kayserilioglu
>>>
>>>  
>>> On 6 February 2015 at 17:24:17, Nicolas Cavigneaux (ni...@bounga.org 
>>> <javascript:>) wrote:
>>>  
>>> Le 6 févr. 2015 à 16:21, Jason Fleetwood-Boldt a écrit :
>>>
>>> >
>>> > Is Rails' API coded for the neophyte or the experienced dev?
>>> >
>>> > The eternal question.
>>>
>>> For people who know how to read basic, essential doc and well documented 
>>> stuff?
>>>
>>> --
>>> Nicolas Cavigneaux
>>> www.bounga.org
>>> www.cavigneaux.net
>>>
>>>
>>>
>>>
>>>
>>> --
>>> You received this message because you are subscribed to the Google 
>>> Groups "Ruby on Rails: Core" group.
>>> To unsubscribe from this group and stop receiving emails from it, send 
>>> an email to rubyonrails-co...@googlegroups.com <javascript:>.
>>> To post to this group, send email to rubyonra...@googlegroups.com 
>>> <javascript:>.
>>> Visit this group at http://groups.google.com/group/rubyonrails-core.
>>> For more options, visit https://groups.google.com/d/optout.
>>>  --
>>> You received this message because you are subscribed to the Google 
>>> Groups "Ruby on Rails: Core" group.
>>> To unsubscribe from this group and stop receiving emails from it, send 
>>> an email to rubyonrails-co...@googlegroups.com <javascript:>.
>>> To post to this group, send email to rubyonra...@googlegroups.com 
>>> <javascript:>.
>>> Visit this group at http://groups.google.com/group/rubyonrails-core.
>>> For more options, visit https://groups.google.com/d/optout.
>>>
>>  --
>> You received this message because you are subscribed to the Google Groups 
>> "Ruby on Rails: Core" group.
>> To unsubscribe from this group and stop receiving emails from it, send an 
>> email to rubyonrails-co...@googlegroups.com <javascript:>.
>> To post to this group, send email to rubyonra...@googlegroups.com 
>> <javascript:>.
>> Visit this group at http://groups.google.com/group/rubyonrails-core.
>> For more options, visit https://groups.google.com/d/optout.
>>
>

-- 
You received this message because you are subscribed to the Google Groups "Ruby 
on Rails: Core" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to rubyonrails-core+unsubscr...@googlegroups.com.
To post to this group, send email to rubyonrails-core@googlegroups.com.
Visit this group at http://groups.google.com/group/rubyonrails-core.
For more options, visit https://groups.google.com/d/optout.

Reply via email to