> In the view code, say it is > > <% @stories.each do |s| %> > <%= "<div>#{h s.inspect}</div>" %> > <% end %> > > it would be breaking the code into 3 <% %> and <%= %> > > is there a way to just have one <% %> or <%= %> so as to keep the code > more flowing together?
The above is pretty standard (I'd indent it though). You can change the %> to -%> to kill off new lines in the output. In the above case you could do this... <%= @stories.map {|s| content_tag(:div, h(s.inspect)) }.join %> Not sure that's more readable or not... I'll do that sometimes for things like 'li' entries. -philip -- You received this message because you are subscribed to the Google Groups "Ruby on Rails: Talk" group. To post to this group, send email to rubyonrails-t...@googlegroups.com. To unsubscribe from this group, send email to rubyonrails-talk+unsubscr...@googlegroups.com. For more options, visit this group at http://groups.google.com/group/rubyonrails-talk?hl=en.