On Wed, Apr 10, 2013 at 11:20 PM, Brian Anderson <bander...@mozilla.com>wrote:

>  On 04/10/2013 05:25 PM, Erick Tryzelaar wrote:
>


> Which in my opinion is hard to read. Then there's the question of what
> happens if even after wrapping the line pushes us past the 100 character
> limit?
>
>  For my bikeshed, I have started using the basic rule that if I can't fit
> a statement on one line, I wrap and indent 4 spaces after a '<', '(', or
> '{':
>
>      fn simple_vars<
>         T:Copy + Eq + InferStr + SimplyUnifiable,
>         V:Copy + Eq + Vid + ToStr + UnifyVid<Option<T>>
>     >(
>         &mut self,
>         +a_is_expected: bool,
>         +a_id: V,
>         +b_id: V
>     ) -> ures {
>
>
> I like this style as well. It wasn't so popular in a straw vote.
>
>
Java style in these situations (function parameters, if/while conditions,
etc.) is to indent 8 spaces. I think it actually works pretty well in that
it makes it clear that it's a continuation of the previous line while also
setting it apart from the lines inside the block.
_______________________________________________
Rust-dev mailing list
Rust-dev@mozilla.org
https://mail.mozilla.org/listinfo/rust-dev

Reply via email to