Dear William,

> FreeAlgebraElement was written in 2005, and nobody has worked on it since.
> Maybe now it is your turn.

Or my student's :). That was my intention ! The obvious question is now the
naming convention. It seems to me that we should stick as close as possible to
polynomials:

sage: ring = ZZ['x1,x2']
sage: x1 = ring.gens()[0]         # why x1 is not defined ???
sage: truc = x1^8 + 2*x1^4 + 2
sage: truc
x1^8 + 2*x1^4 + 2
sage: type(truc)
<type 
'sage.rings.polynomial.multi_polynomial_libsingular.MPolynomial_libsingular'>
sage: truc.dict()
{(0, 0): 2, (4, 0): 2, (8, 0): 1}
sage: truc.coefficients()
[1, 2, 2]
sage: truc.monomials()
[x1^8, x1^4, 1]

Should we stick to this interface ?

Cheers,

Florent

--~--~---------~--~----~------------~-------~--~----~
To post to this group, send email to sage-devel@googlegroups.com
To unsubscribe from this group, send email to 
sage-devel-unsubscr...@googlegroups.com
For more options, visit this group at http://groups.google.com/group/sage-devel
URLs: http://www.sagemath.org
-~----------~----~----~----~------~----~------~--~---

Reply via email to