Re: [PATCH v4 0/5] am/rebase: share read_author_script()
Hi Junio On 01/11/2018 03:01, Junio C Hamano wrote: Phillip Wood writes: From: Phillip Wood Sorry for the confusion with v3, here are the updated patches. Thanks to Junio for the feedback on v2. I've updated patch 4 based on those comments, the rest are unchanged. The mistake of overwriting -1 (i.e. earlier we detected dup) with the third instance of the same originates at [2/5], so updating [4/5] without fixing it at its source would mean [4/5] is not a pure code movement to make it available to libgit users---it instead hides a (not so important) bugfix in it. Facepalm. Thanks for clearing up my mess, what you've got in pu looks fine to me. Thanks Phillip v1 cover letter: This is a follow up to pw/rebase-i-author-script-fix, it reduces code duplication and improves rebase's parsing of the author script. After this I'll do another series to share the code to write the author script. Phillip Wood (5): am: don't die in read_author_script() am: improve author-script error reporting am: rename read_author_script() add read_author_script() to libgit sequencer: use read_author_script() builtin/am.c | 60 ++-- sequencer.c | 192 --- sequencer.h | 3 + 3 files changed, 128 insertions(+), 127 deletions(-)
Re: [PATCH v4 0/5] am/rebase: share read_author_script()
Phillip Wood writes: > From: Phillip Wood > > Sorry for the confusion with v3, here are the updated patches. > > Thanks to Junio for the feedback on v2. I've updated patch 4 based on > those comments, the rest are unchanged. The mistake of overwriting -1 (i.e. earlier we detected dup) with the third instance of the same originates at [2/5], so updating [4/5] without fixing it at its source would mean [4/5] is not a pure code movement to make it available to libgit users---it instead hides a (not so important) bugfix in it. > > v1 cover letter: > > This is a follow up to pw/rebase-i-author-script-fix, it reduces code > duplication and improves rebase's parsing of the author script. After > this I'll do another series to share the code to write the author > script. > > > Phillip Wood (5): > am: don't die in read_author_script() > am: improve author-script error reporting > am: rename read_author_script() > add read_author_script() to libgit > sequencer: use read_author_script() > > builtin/am.c | 60 ++-- > sequencer.c | 192 --- > sequencer.h | 3 + > 3 files changed, 128 insertions(+), 127 deletions(-)