Re: [GIT PULL] Crypto Update for 5.9
The pull request you sent on Mon, 3 Aug 2020 14:40:24 +1000: > git://git.kernel.org/pub/scm/linux/kernel/git/herbert/crypto-2.6.git linus has been merged into torvalds/linux.git: https://git.kernel.org/torvalds/c/ab5c60b79ab6cc50b39bbb21b2f9fb55af900b84 Thank you! -- Deet-doot-dot, I am a bot. https://korg.wiki.kernel.org/userdoc/prtracker
[GIT PULL] Crypto Update for 5.9
Hi Linus: API: - Add support for allocating transforms on a specific NUMA Node. - Introduce the flag CRYPTO_ALG_ALLOCATES_MEMORY for storage users. Algorithms: - Drop PMULL based ghash on arm64. - Fixes for building with clang on x86. - Add sha256 helper that does the digest in one go. - Add SP800-56A rev 3 validation checks to dh. Drivers: - Permit users to specify NUMA node in hisilicon/zip. - Add support for i.MX6 in imx-rngc. - Add sa2ul crypto driver. - Add BA431 hwrng driver. - Add Ingenic JZ4780 and X1000 hwrng driver. - Spread IRQ affinity in inside-secure and marvell/cesa. There may be a conflict with the tip tree because of the removal of arch/x86/include/asm/inst.h. This file was previously only used by the Crypto API and just as we stopped using it the tip tree started using it. So taking the version from the tip tree should do the trick. There is also a conflit witht the jc_docs tree due to unrelated changes to the same file. The resolution should be straightforward. The following changes since commit e04ec0de61c1eb9693179093e83ab8ca68a30d08: padata: upgrade smp_mb__after_atomic to smp_mb in padata_do_serial (2020-06-18 17:09:54 +1000) are available in the Git repository at: git://git.kernel.org/pub/scm/linux/kernel/git/herbert/crypto-2.6.git linus for you to fetch changes up to 3cbfe80737c18ac6e635421ab676716a393d3074: crypto: sa2ul - Fix inconsistent IS_ERR and PTR_ERR (2020-07-31 18:25:29 +1000) Alexander A. Klimov (2): hwrng: ks-sa - Replace HTTP links with HTTPS ones crypto: Replace HTTP links with HTTPS ones Andrei Botila (1): crypto: caam/qi2 - add support for dpseci_reset() Andrey Smirnov (1): crypto: caam - add clock info for VFxxx SoCs Ard Biesheuvel (20): crypto: arm64/ghash - drop PMULL based shash crypto: arm64/gcm - disentangle ghash and gcm setkey() routines crypto: arm64/gcm - use variably sized key struct crypto: arm64/gcm - use inline helper to suppress indirect calls crypto: arm/ghash - use variably sized key struct crypto: amlogic-gxl - default to build as module crypto: amlogic-gxl - permit async skcipher as fallback crypto: omap-aes - permit asynchronous skcipher as fallback crypto: sun4i - permit asynchronous skcipher as fallback crypto: sun8i-ce - permit asynchronous skcipher as fallback crypto: sun8i-ss - permit asynchronous skcipher as fallback crypto: ccp - permit asynchronous skcipher as fallback crypto: chelsio - permit asynchronous skcipher as fallback crypto: mxs-dcp - permit asynchronous skcipher as fallback crypto: picoxcell - permit asynchronous skcipher as fallback crypto: qce - permit asynchronous skcipher as fallback crypto: sahara - permit asynchronous skcipher as fallback crypto: mediatek - use AES library for GCM key derivation crypto: x86/chacha-sse3 - use unaligned loads for state array crypto: xts - Replace memcpy() invocation with simple assignment Arnd Bergmann (1): crypto: x86/crc32c - fix building with clang ias Barry Song (2): crypto: api - permit users to specify numa node of acomp hardware crypto: hisilicon/zip - permit users to specify NUMA node Christophe JAILLET (2): crypto: chelsio - Avoid some code duplication crypto: chelsio - Fix some pr_xxx messages Colin Ian King (4): crypto: caam/qi2 - remove redundant assignment to ret crypto: ccp - remove redundant assignment to variable ret crypto: img-hash - remove redundant initialization of variable err hwrng: core - remove redundant initialization of variable ret Dan Carpenter (1): crypto: hisilicon - allow smaller reads in debugfs Dan Douglass (1): crypto: caam/jr - remove incorrect reference to caam_jr_register() Daniel Jordan (6): padata: remove start function padata: remove stop function padata: inline single call of pd_setup_cpumasks() padata: remove effective cpumasks from the instance padata: fold padata_alloc_possible() into padata_alloc() padata: remove padata_parallel_queue Dinghao Liu (1): crypto: sun8i-ce - Fix runtime PM imbalance in sun8i_ce_cipher_init Eric Biggers (14): crc-t10dif: use fallback in initial state crc-t10dif: clean up some more things crypto: sparc - rename sha256 to sha256_alg crypto: lib/sha256 - add sha256() function efi: use sha256() instead of open coding mptcp: use sha256() instead of open coding ASoC: cros_ec_codec: use sha256() instead of open coding crypto: geniv - remove unneeded arguments from aead_geniv_alloc() crypto: seqiv - remove seqiv_create() crypto: algapi - use common mechanism for inheriting flags crypto: algapi - add NEED_FALLBACK to INHERITED_FLAGS crypto: algapi - introduce the flag CRYPTO_ALG_ALLOCATES_MEMORY crypt