Re: [PATCH 0/2] sched: Introduce rcuwait

2017-01-10 Thread Davidlohr Bueso

On Tue, 10 Jan 2017, Oleg Nesterov wrote:


Well, speaking of naming, rcuwait_trywake() doesn't look good to me,
rcuwait_wake_up() looks better, "try" is misleading imo. But this is
cosmetic/subjective too.


I actually added the 'try' on second thought -- in that for the particular
pcpu-rwsem user, obviously most of the time the wakeup will not actually
occur. But yeah, I'd have no problem just naming it rcuwait_wake_up().


Reviewed-by: Oleg Nesterov 


Thanks!


Re: [PATCH 0/2] sched: Introduce rcuwait

2017-01-10 Thread Davidlohr Bueso

On Tue, 10 Jan 2017, Oleg Nesterov wrote:


Well, speaking of naming, rcuwait_trywake() doesn't look good to me,
rcuwait_wake_up() looks better, "try" is misleading imo. But this is
cosmetic/subjective too.


I actually added the 'try' on second thought -- in that for the particular
pcpu-rwsem user, obviously most of the time the wakeup will not actually
occur. But yeah, I'd have no problem just naming it rcuwait_wake_up().


Reviewed-by: Oleg Nesterov 


Thanks!


Re: [PATCH 0/2] sched: Introduce rcuwait

2017-01-10 Thread Oleg Nesterov
On 01/09, Davidlohr Bueso wrote:
>
> Gents, any further thoughts on this?

Both look correct to me, and I think this allows us to make more
optimizations in percpu-rwsem.c.


I am not sure about the naming... Yes, it relies on rcu but this is
just implementation detail. But this is cosmetic and I can't suggest
something better than rcuwait.

Well, speaking of naming, rcuwait_trywake() doesn't look good to me,
rcuwait_wake_up() looks better, "try" is misleading imo. But this is
cosmetic/subjective too.


Reviewed-by: Oleg Nesterov 



Re: [PATCH 0/2] sched: Introduce rcuwait

2017-01-10 Thread Oleg Nesterov
On 01/09, Davidlohr Bueso wrote:
>
> Gents, any further thoughts on this?

Both look correct to me, and I think this allows us to make more
optimizations in percpu-rwsem.c.


I am not sure about the naming... Yes, it relies on rcu but this is
just implementation detail. But this is cosmetic and I can't suggest
something better than rcuwait.

Well, speaking of naming, rcuwait_trywake() doesn't look good to me,
rcuwait_wake_up() looks better, "try" is misleading imo. But this is
cosmetic/subjective too.


Reviewed-by: Oleg Nesterov 



Re: [PATCH 0/2] sched: Introduce rcuwait

2017-01-09 Thread Davidlohr Bueso

Gents, any further thoughts on this?

Thanks,
Davidlohr


Re: [PATCH 0/2] sched: Introduce rcuwait

2017-01-09 Thread Davidlohr Bueso

Gents, any further thoughts on this?

Thanks,
Davidlohr


[PATCH 0/2] sched: Introduce rcuwait

2016-12-22 Thread Davidlohr Bueso
Hi,

Here's an updated version of the pcpu rwsem writer wait/wake changes
with the abstractions wanted by Oleg. Patch 1 adds rcuwait (for a lack
of better name), and patch 2 trivially makes use of it. 

Has survived torture testing, which is actually very handy in this case
particularly dealing with equal amount of reader and writer threads.

Thanks.

Davidlohr Bueso (2):
  sched: Introduce rcuwait machinery
  locking/percpu-rwsem: Replace waitqueue with rcuwait

 include/linux/percpu-rwsem.h  |  8 +++---
 include/linux/rcuwait.h   | 63 +++
 kernel/exit.c | 29 
 kernel/locking/percpu-rwsem.c |  7 +++--
 4 files changed, 99 insertions(+), 8 deletions(-)
 create mode 100644 include/linux/rcuwait.h

-- 
2.6.6



[PATCH 0/2] sched: Introduce rcuwait

2016-12-22 Thread Davidlohr Bueso
Hi,

Here's an updated version of the pcpu rwsem writer wait/wake changes
with the abstractions wanted by Oleg. Patch 1 adds rcuwait (for a lack
of better name), and patch 2 trivially makes use of it. 

Has survived torture testing, which is actually very handy in this case
particularly dealing with equal amount of reader and writer threads.

Thanks.

Davidlohr Bueso (2):
  sched: Introduce rcuwait machinery
  locking/percpu-rwsem: Replace waitqueue with rcuwait

 include/linux/percpu-rwsem.h  |  8 +++---
 include/linux/rcuwait.h   | 63 +++
 kernel/exit.c | 29 
 kernel/locking/percpu-rwsem.c |  7 +++--
 4 files changed, 99 insertions(+), 8 deletions(-)
 create mode 100644 include/linux/rcuwait.h

-- 
2.6.6