Re: [PATCH] ARM: shmobile: rcar-gen2: Fix deadlock in regulator quirk

2017-07-27 Thread Simon Horman
On Wed, Jul 12, 2017 at 04:45:20PM +0200, Geert Uytterhoeven wrote:
> Simon Horman reported that Koelsch and Lager hang during boot, and
> bisected this to commit 1c3c5eab171590f8 ("sched/core: Enable
> might_sleep() and smp_processor_id() checks early").
> 
> The da9063/da9210 regulator quirk for R-Car Gen2 boards uses a bus
> notifier, and unregisters the notifier when it is no longer needed.
> However, a notifier must not be unregistered from within the call chain.
> 
> This bug went unnoticed, as blocking_notifier_chain_unregister() didn't
> take the semaphore during early boot.  The aforementioned commit changed
> that behavior, leading to a deadlock.
> 
> Fix this by removing the call to bus_unregister_notifier(), and keeping
> local completion state instead.
> 
> Reported-by: Simon Horman 
> Fixes: 663fbb52159cca6f ("ARM: shmobile: R-Car Gen2: Add da9063/da9210 
> regulator quirk")
> Signed-off-by: Geert Uytterhoeven 

Sorry for the delay, I have applied this as a fix for v4.13.


Re: [PATCH] ARM: dts: iwg20m: Correct indentation of mmcif0 properties

2017-07-27 Thread Simon Horman
On Mon, Jul 17, 2017 at 12:44:45PM +, Chris Paterson wrote:
> Hello Geert,
> 
> > From: Geert Uytterhoeven [mailto:geert+rene...@glider.be]
> > Sent: 17 July 2017 13:07
> > 
> > Fixes: 4658c4b789d8e2ae ("ARM: dts: iwg20m: Add MMCIF0 support")
> > Signed-off-by: Geert Uytterhoeven 
> 
> Thanks for this, I'm not sure how we all missed it before!
> 
> Reviewed-by: Chris Paterson 

Thanks, applied for v4.14.


Re: [PATCH 1/6] ARM: multi_v7_defconfig: Cleanup from non-existing options

2017-07-27 Thread Simon Horman
On Mon, Jul 17, 2017 at 06:37:16PM +0200, Krzysztof Kozlowski wrote:
> On Mon, Jul 17, 2017 at 09:28:09AM +0200, Geert Uytterhoeven wrote:
> > Hi Krzysztof,
> > 
> > On Mon, Jul 17, 2017 at 7:49 AM, Krzysztof Kozlowski  
> > wrote:
> > > Remove options which do not exist anymore:
> > 
> > 
> > 
> > >  - DRM_RCAR_HDMI was merged to generic DRM bridge and is obsolete since
> > >commit 5c602531feb3 ("drm: rcar-du: Replace manual bridge
> > >implementation with DRM bridge");
> > >
> > >  - SND_SOC_RSRC_CARD was replaced by SND_SIMPLE_SCU_CARD in commit
> > >d12c6216c4a5 ("ASoC: rsrc-card: rename rsrc-card to simple-scu-card
> > >phase3");
> > 
> > These have already be fixed in the defconfig-for-v4.14 branch Simon Horman's
> > tree (git://git.kernel.org/pub/scm/linux/kernel/git/horms/renesas.git).
> > They're not yet in -next as v4.13-rc1 wasn't released at that time, and
> > Simon is noew on holidays.
> 
> I'll rebase then on top of his branch.

FYI, I have rebased that branch on top of v4.13-rc1 now that it has been
released (and I am back from holidays). I intend to push the updated branch
soon.


Re: [GIT PULL] Second Round of Renesas ARM Based SoC Fixes for v4.13

2017-07-27 Thread Simon Horman
On Thu, Jul 27, 2017 at 12:52:47PM +0200, Arnd Bergmann wrote:
> On Fri, Jul 14, 2017 at 10:04 AM, Simon Horman
>  wrote:
> > Hi Olof, Hi Kevin, Hi Arnd,
> >
> > Please consider these second round of Renesas ARM based SoC fixes for v4.13.
> >
> > This pull request is based on the previous round of
> > such requests, tagged as renesas-fixes-for-v4.13,
> > which I have already sent a pull-request for.
> > That pull request provides the same fix as this pull one
> > but for the Salvator rather than ULCB boards.
> 
> Pulled into fixes.
> 
> > On a personal note, I will be on holidays from the 17th - 26th July.
> > I apologise in advance for any inconvenience that may cause.
> 
> No worries. Sorry for not getting to this before you returned.

No problem, thanks for taking this fix.


Re: [PATCH] ARM: shmobile: Remove ARCH_SHMOBILE_MULTI

2017-07-27 Thread Simon Horman
On Mon, Jul 17, 2017 at 03:23:54PM +0200, Geert Uytterhoeven wrote:
> The migration from ARCH_SHMOBILE_MULTI to ARCH_RENESAS has been
> completed in v4.12 by commit 9ed2d4bc5c0c244d ("ARM: dts: renesas:
> Switch from ARCH_SHMOBILE_MULTI to ARCH_RENESAS"), so the
> ARCH_SHMOBILE_MULTI symbol can be removed.
> 
> Signed-off-by: Geert Uytterhoeven 

Thanks, applied for v4.14.


Re: [PATCH] soc: Convert to using %pOF instead of full_name

2017-07-27 Thread Simon Horman
On Tue, Jul 18, 2017 at 04:43:29PM -0500, Rob Herring wrote:
> Now that we have a custom printf format specifier, convert users of
> full_name to use %pOF instead. This is preparation to remove storing
> of the full path string for each node.
> 
> Signed-off-by: Rob Herring 
> Cc: Scott Wood 
> Cc: Qiang Zhao 
> Cc: Matthias Brugger 
> Cc: Simon Horman 
> Cc: Magnus Damm 
> Cc: Kukjin Kim 
> Cc: Krzysztof Kozlowski 
> Cc: Javier Martinez Canillas 
> Cc: linuxppc-...@lists.ozlabs.org
> Cc: linux-arm-ker...@lists.infradead.org
> Cc: linux-media...@lists.infradead.org
> Cc: linux-renesas-soc@vger.kernel.org
> Cc: linux-samsung-...@vger.kernel.org
> ---
>  drivers/soc/fsl/qbman/bman_ccsr.c| 10 +-
>  drivers/soc/fsl/qbman/bman_portal.c  |  8 +++-
>  drivers/soc/fsl/qbman/qman_ccsr.c| 12 ++--
>  drivers/soc/fsl/qbman/qman_portal.c  | 11 ---
>  drivers/soc/fsl/qe/gpio.c|  4 ++--
>  drivers/soc/mediatek/mtk-pmic-wrap.c |  4 ++--
>  drivers/soc/renesas/rcar-rst.c   |  4 ++--
>  drivers/soc/renesas/rcar-sysc.c  |  6 +++---
>  drivers/soc/samsung/pm_domains.c |  8 
>  9 files changed, 31 insertions(+), 36 deletions(-)

Renesas portions:

Acked-by: Simon Horman 


Re: [PATCH] ARM: shmobile: rcar-gen2: Correct arch timer frequency on RZ/G1E

2017-07-27 Thread Simon Horman
On Tue, Jul 18, 2017 at 03:29:17PM +0200, Geert Uytterhoeven wrote:
> According to the datasheet, the frequency of the ARM architecture timer
> on RZ/G1E depends on the frequency of the ZS clock, just like on R-Car
> E2 and V2H.
> 
> Signed-off-by: Geert Uytterhoeven 
> ---
> Untested due to lack of hardware.
> 
> v2:
>   - Rebased to avoid dependencies.

Thanks. I have applied this for v4.14.


Re: [PATCH] ARM: shmobile: rcar-gen2: Correct arch timer frequency on RZ/G1E

2017-07-27 Thread Simon Horman
On Tue, Jul 18, 2017 at 01:59:58PM +, Biju Das wrote:
> It looks good to me.
> 
> Regards,
> Biju

Thanks for your review. A few comments on it to keep in mind for next time:

* Please don't top-post
* Please consider providing a more formal tag, e.g. Reviewed-by


Re: [PATCH 0/3] arm64: dts: renesas: r8a7795: salvator-xs: enable usb 2.0 channel 3

2017-07-27 Thread Simon Horman
On Wed, Jul 26, 2017 at 08:30:57PM +0900, Yoshihiro Shimoda wrote:
> This patch is based on the renesas-drivers.git /
> renesas-drivers-2017-07-18-v4.13-rc1 tag and
> "pinctrl: sh-pfc: r8a7795: add usb2.0 on R-Car H3 ES2.0" patch set and
> "arm64: dts: renesas: r8a7795: add usb2.0 for R-Car H3 ES2.0" patch set.
> 
> Yoshihiro Shimoda (3):
>   arm64: dts: renesas: r8a7795: salvator-xs: enable usb2_phy ch3
>   arm64: dts: renesas: r8a7795: salvator-xs: enable USB 2.0 channel 3
>   arm64: dts: renesas: r8a7795: salvator-xs: enable HSUSB channel 3

Hi Shimoda-san,

I am marking these patches as deferred pending an Ack from Geert
on the pfc changes. I assume that will not happen until after he comes
back from holiday's. Let me know if that is going to be a problem.


Re: [PATCH 0/5] arm64: dts: renesas: r8a7795: add usb2.0 for R-Car H3 ES2.0

2017-07-27 Thread Simon Horman
On Wed, Jul 26, 2017 at 08:29:35PM +0900, Yoshihiro Shimoda wrote:
> This patch is based on the renesas-drivers.git /
> renesas-drivers-2017-07-18-v4.13-rc1 tag.
> 
> Kazuya Mizuguchi (1):
>   arm64: dts: renesas: r8a7795: Add usb companion property in EHCI
> 
> Yoshihiro Shimoda (4):
>   arm64: dts: renesas: r8a7795: add usb2_phy ch3 device node
>   arm64: dts: renesas: r8a7795: add usb2.0 host ch3 device nodes
>   arm64: dts: renesas: r8a7795: add usb-dmac ch2 and ch3 device nodes
>   arm64: dts: renesas: r8a7795: add hsusb ch3 device node

Thanks Shimoda-san,

I have applied these for v4.14.


Re: [PATCH 0/4] arm64: dts: renesas: Add Support for R-Car D3 and Draak

2017-07-27 Thread Simon Horman
On Thu, Jul 20, 2017 at 02:54:33PM +0200, Geert Uytterhoeven wrote:
>   Hi Simon, Magnus,
> 
> This patch series adds minimal support for the R-Car D3 SoC and the
> Draak development board, allowing to boot from a ramdisk using a serial
> console.
> 
>   - The first two patches add DT sources for R-Car D3 and Draak.
> Due to the use of hardcoded constants, they have no further (build)
> dependencies (obviously there is a runtime dependency).
>   - The last two patches replace the hardcoded constants by symbols from
> DT binding headers, and thus depend on those headers.  Hence it
> should be postponed to v4.15.
> 
> For proper operation, this depends on the 3 series I have just sent:
>   - [PATCH 0/3] arm64: renesas: Base R-Car D3 support,

I have applied the above patchset for v4.14.

>   - [PATCH 0/4] soc: renesas: Add R-Car D3 support,

And this one too.

>   - [PATCH 0/4] clk: renesas: Add R-Car D3 support.

And this one seems to have been acked, so I assume you will
apply it once you are back from holidays.

So I have applied the first two patches for v4.14.
Please repost the remaining two after v4.13-rc6 at which time I should
be able to queue them up for v4.15.

> For testing, an integration branch containing all dependencies (and a
> few DT binding updates I do not want to send before "ARM: shmobile:
> Document R-Car D3 SoC DT bindings" has been accepted) is available in
> the topic/r8a77995-integration branch of the git repository at
> https://git.kernel.org/cgit/linux/kernel/git/geert/renesas-drivers.git.
> 
> Thanks for your comments!
> 
> Geert Uytterhoeven (4):
>   arm64: dts: renesas: Add Renesas R8A77995 SoC support
>   arm64: dts: renesas: Add Renesas Draak board support
>   arm64: dts: renesas: r8a77995: Use r8a7795-sysc binding definitions
>   arm64: dts: renesas: r8a77995: Use r8a7795-cpg-mssr binding
> definitions
> 
>  arch/arm64/boot/dts/renesas/Makefile   |   1 +
>  arch/arm64/boot/dts/renesas/r8a77995-draak.dts |  46 
>  arch/arm64/boot/dts/renesas/r8a77995.dtsi  | 151 
> +
>  3 files changed, 198 insertions(+)
>  create mode 100644 arch/arm64/boot/dts/renesas/r8a77995-draak.dts
>  create mode 100644 arch/arm64/boot/dts/renesas/r8a77995.dtsi
> 
> -- 
> 2.7.4
> 
> Gr{oetje,eeting}s,
> 
>   Geert
> 
> --
> Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- 
> ge...@linux-m68k.org
> 
> In personal conversations with technical people, I call myself a hacker. But
> when I'm talking to journalists I just say "programmer" or something like 
> that.
>   -- Linus Torvalds
> 


Re: [PATCH] ARM: Convert to using %pOF instead of full_name

2017-07-27 Thread Paul Walmsley
On Tue, 18 Jul 2017, Rob Herring wrote:

> Now that we have a custom printf format specifier, convert users of
> full_name to use %pOF instead. This is preparation to remove storing
> of the full path string for each node.

Acked-by: Paul Walmsley   # for mach-omap2/omap-hwmod.c

- Paul


Re: [PATCH 0/3] arm64: renesas: Base R-Car D3 support

2017-07-27 Thread Simon Horman
On Thu, Jul 20, 2017 at 02:28:58PM +0200, Geert Uytterhoeven wrote:
>   Hi Simon, Magnus, Rob, Mark, Catalin, Will,
> 
> This patch series adds base support for the Renesas R-Car D3 SoC and the
> Renesas Draak development board.
> 
> It documents SoC and board specific DT compatible values, and adds a
> Kconfig symbol.
> 
> Thanks!
> 
> Geert Uytterhoeven (3):
>   ARM: shmobile: Document R-Car D3 SoC DT bindings
>   ARM: shmobile: Document Renesas Draak board DT bindings
>   arm64: renesas: Add Renesas R8A77995 Kconfig support

Thanks, applied for v4.14.


Re: [PATCH 0/4] soc: renesas: Add R-Car D3 support

2017-07-27 Thread Simon Horman
On Thu, Jul 20, 2017 at 02:34:50PM +0200, Geert Uytterhoeven wrote:
>   Hi Simon, Magnus,
> 
> This patch series adds R-Car D3 support to the Renesas-specific SoC
> drivers:
>   - SoC identification,
>   - System controller,
>   - Reset controller.
> 
> Thanks!
> 
> Geert Uytterhoeven (4):
>   soc: renesas: Identify R-Car D3
>   soc: renesas: Add r8a77995 SYSC PM Domain Binding Definitions
>   soc: renesas: rcar-sysc: Add support for R-Car D3 power areas
>   soc: renesas: rcar-rst: Add support for R-Car D3

Thanks, applied for v4.14.


Re: [PATCH 0/4] dts: rskrza1: Add pin configurations

2017-07-27 Thread Simon Horman
On Thu, Jul 20, 2017 at 01:20:15PM -0500, Chris Brandt wrote:
> Now that the RZ/A1 pin control driver has appeared in 4.13-rc1, it
> is safe to now add pin configurations for RZ/A1 boards.
> 
> 
> Chris Brandt (4):
>   arm: dts: rskrza1: Add SCIF2 pin group
>   arm: dts: rskrza1: Add Ethernet pin group
>   arm: dts: rskrza1: Add SDHI1 pin group
>   arm: dts: rskrza1: Add LED0 pin support
> 
>  arch/arm/boot/dts/r7s72100-rskrza1.dts | 61 
> ++

Thanks, applied for v4.14.


Re: [PATCH v6 00/8] Renesas RZ/A1 pin and gpio controller

2017-07-27 Thread Simon Horman
On Wed, Jun 28, 2017 at 07:36:15PM +0200, Geert Uytterhoeven wrote:
> Hi Linus,
> 
> On Mon, Jun 26, 2017 at 10:45 AM, Geert Uytterhoeven
>  wrote:
> > On Thu, Jun 22, 2017 at 4:54 PM, Jacopo Mondi  
> > wrote:
> >>this is 6th round of RZ/A1 pin controller patch series.
> >>
> >> Where did we stop: discussion from pin controller driver shifted toward two
> >> new generic pin configuration properties I added to the previous series
> >> (bi-directional and output-enable).
> >>
> >> After a really long discussion, we decided to go for handling internally 
> >> all
> >> bi-directional use cases, making the generic property not a requirement 
> >> for the
> >> series. Interestingly, we recently found out the number of pins actually
> >> requiring this flag is less (~half) than what reported by the processor 
> >> manual,
> >> so we could have handled these internally from day one :(
> >>
> >> We also now manage internally pins requiring IO direction specified in 
> >> software
> >> even when configured in alternate function mode (SWIO mode). Most of them 
> >> are
> >> handled by the driver, some of them have to come from DTS as the user can 
> >> freely
> >> select if they have to be inputs or outputs. For those pins, and after 
> >> another
> >> discussion involving NXP developers, we decided to use input-enable and
> >> output-enable properties. I have just sent a patch to add output-enable to 
> >> the
> >> generic pin configuration properties, but it is currently under discussion.
> >>
> >> However, none of the pins currently configured by mainline DTS require 
> >> those
> >> properties to be specified, so I have dropped in this driver any 
> >> dependency on
> >> output-enable property, and I'm using instead the already in place
> >> PIN_CONFIG_OUTPUT one. Once output-enable will eventually be accepted, we 
> >> can
> >> update the driver to make use of it, but since there are no use cases for 
> >> that
> >> at the moment, it makes not too much sense holding this series back for 
> >> that.
> >>
> >> The total memory occupation we were so worried about of bi-directional and 
> >> swio
> >> pin tables is now around 100 bytes, because of how the number of pins 
> >> actually
> >> needing those flags has  reduced and because of how we have arranged the
> >> tables using bitfield structures (credits to Geert here).
> >>
> >> Having cleared out dependencies on new pin configuration properties and 
> >> having
> >> made configuration flags a driver specific issue, I hope this version can 
> >> be
> >> accepted and land in forthcoming pull request for Renesas PFC updates from
> >> Geert, pending some feedback from the linux-gpio community.
> >
> > If this is OK for you, I'd like to include the first 3 patches (plus a small
> > fix I received offline from Chris Brandt[*]) in my final pull request of
> > sh-pfc for v4.13 (which I have been postponing in anticipation of this 
> > driver).
> 
> And so I did. Queued in sh-pfc-for-v4.13, pull request sent.

I have applied up the dts changes on top of v4.13-rc1.


Re: [PATCH v2] ARM: Convert to using %pOF instead of full_name

2017-07-27 Thread Simon Horman
On Fri, Jul 21, 2017 at 02:28:32PM -0500, Rob Herring wrote:
> Now that we have a custom printf format specifier, convert users of
> full_name to use %pOF instead. This is preparation to remove storing
> of the full path string for each node.
> 
> Signed-off-by: Rob Herring 
> Acked-by: Krzysztof Kozlowski 
> Acked-by: Heiko Stuebner 
> Reviewed-by: Geert Uytterhoeven 
> Acked-by: Gregory CLEMENT 
> Cc: Russell King 
> Cc: Kukjin Kim 
> Cc: Javier Martinez Canillas 
> Cc: Shawn Guo 
> Cc: Sascha Hauer 
> Cc: Fabio Estevam 
> Cc: Jason Cooper 
> Cc: Andrew Lunn 
> Cc: Sebastian Hesselbarth 
> Cc: Tony Lindgren 
> Cc: "BenoƮt Cousson" 
> Cc: Paul Walmsley 
> Cc: Simon Horman 
> Cc: Magnus Damm 
> Cc: linux-arm-ker...@lists.infradead.org
> Cc: linux-samsung-...@vger.kernel.org
> Cc: linux-o...@vger.kernel.org
> Cc: linux-rockc...@lists.infradead.org
> Cc: linux-renesas-soc@vger.kernel.org
> ---
> v2:
> - Merge several 2 line prints to single line.
> - Add acks
> 
>  arch/arm/kernel/cpuidle.c| 4 ++--
>  arch/arm/kernel/devtree.c| 5 ++---
>  arch/arm/kernel/topology.c   | 3 +--
>  arch/arm/mach-exynos/suspend.c   | 7 +++
>  arch/arm/mach-imx/gpc.c  | 4 ++--
>  arch/arm/mach-mvebu/kirkwood.c   | 3 +--
>  arch/arm/mach-omap2/omap-wakeupgen.c | 4 ++--
>  arch/arm/mach-omap2/omap_hwmod.c | 4 ++--
>  arch/arm/mach-rockchip/platsmp.c | 4 ++--
>  arch/arm/mach-shmobile/pm-rmobile.c  | 7 +++
>  10 files changed, 20 insertions(+), 25 deletions(-)

mach-shmobile portion:

Acked-by: Simon Horman 



Re: [GIT PULL] Renesas ARM Based SoC Fixes for v4.13

2017-07-27 Thread Simon Horman
On Thu, Jul 27, 2017 at 12:49:40PM +0200, Arnd Bergmann wrote:
> On Fri, Jun 30, 2017 at 11:16 AM, Simon Horman
>  wrote:
> > Hi Olof, Hi Kevin, Hi Arnd,
> >
> > Please consider this Renesas ARM based SoC fix for v4.13.
> >
> > This pull request is based on
> > "[GIT PULL] Second Round of Renesas ARM64 Based SoC DT Updates for v4.13",
> > tagged as renesas-arm64-dt2-for-v4.13, which you have already pulled.
> >
> > It is my understanding that the problem fixed was introduced
> > earlier in the v4.13 development cycle. So I don't think consideration
> > needs to be given to merging for to v4.12 or back-porting to -stable.
> 
> Pulled into 'fixes' now, sorry for the delay.

Thanks!


Re: [GIT PULL] Second Round of Renesas ARM Based SoC Fixes for v4.13

2017-07-27 Thread Arnd Bergmann
On Fri, Jul 14, 2017 at 10:04 AM, Simon Horman
 wrote:
> Hi Olof, Hi Kevin, Hi Arnd,
>
> Please consider these second round of Renesas ARM based SoC fixes for v4.13.
>
> This pull request is based on the previous round of
> such requests, tagged as renesas-fixes-for-v4.13,
> which I have already sent a pull-request for.
> That pull request provides the same fix as this pull one
> but for the Salvator rather than ULCB boards.

Pulled into fixes.

> On a personal note, I will be on holidays from the 17th - 26th July.
> I apologise in advance for any inconvenience that may cause.

No worries. Sorry for not getting to this before you returned.

  Arnd


Re: [GIT PULL] Renesas ARM Based SoC Fixes for v4.13

2017-07-27 Thread Arnd Bergmann
On Fri, Jun 30, 2017 at 11:16 AM, Simon Horman
 wrote:
> Hi Olof, Hi Kevin, Hi Arnd,
>
> Please consider this Renesas ARM based SoC fix for v4.13.
>
> This pull request is based on
> "[GIT PULL] Second Round of Renesas ARM64 Based SoC DT Updates for v4.13",
> tagged as renesas-arm64-dt2-for-v4.13, which you have already pulled.
>
> It is my understanding that the problem fixed was introduced
> earlier in the v4.13 development cycle. So I don't think consideration
> needs to be given to merging for to v4.12 or back-porting to -stable.

Pulled into 'fixes' now, sorry for the delay.

  Arnd