Re: [PATCH v5 12/29] dm: core: Add basic ACPI support

2020-04-09 Thread Simon Glass
Hi Andy,

On Thu, 9 Apr 2020 at 03:02, Andy Shevchenko  wrote:
>
> On Thu, Apr 9, 2020 at 2:01 AM Simon Glass  wrote:
> >
> > ACPI (Advanced Configuration and Power Interface) is a standard for
> > specifying information about a platform. It is a little like device
> > tree but the bindings are part of the specification and it supports an
> > interpreted bytecode language.
> >
> > Driver model does not use ACPI for U-Boot's configuration, but it is
> > convenient to have it support generation of ACPI tables for passing to
> > Linux, etc.
> >
> > As a starting point, add an optional set of ACPI operations to each
> > device. Initially only a single operation is available, to obtain the
> > ACPI name for the device. More operations are added later.
> >
> > Enable ACPI for sandbox to ensure build coverage and so that we can add
> > tests.
>
> > +int acpi_copy_name(char *out_name, const char *name)
> > +{
> > +   strncpy(out_name, name, ACPI_NAME_MAX);
>
> _LEN.
>
> The idea as I tried to explain that name can have only 4 bytes at the
> end of the page. I dunno what U-Boot does if you access out of the
> boundaries to the page which is not mapped to MMU (in OSes it will be
> page fault). Does U-Boot map all pages to MMU?
>
> In any case, the code above has this subtle issue. We may live with
> it, but since it's a generic kinda function, better to be pedantic
> about it.

OK I will change it. The documentation is pretty clear on how to use
this function, but I suppose people might not read it.

Regards,
Simon


Re: [PATCH v5 12/29] dm: core: Add basic ACPI support

2020-04-09 Thread Andy Shevchenko
On Thu, Apr 9, 2020 at 2:01 AM Simon Glass  wrote:
>
> ACPI (Advanced Configuration and Power Interface) is a standard for
> specifying information about a platform. It is a little like device
> tree but the bindings are part of the specification and it supports an
> interpreted bytecode language.
>
> Driver model does not use ACPI for U-Boot's configuration, but it is
> convenient to have it support generation of ACPI tables for passing to
> Linux, etc.
>
> As a starting point, add an optional set of ACPI operations to each
> device. Initially only a single operation is available, to obtain the
> ACPI name for the device. More operations are added later.
>
> Enable ACPI for sandbox to ensure build coverage and so that we can add
> tests.

> +int acpi_copy_name(char *out_name, const char *name)
> +{
> +   strncpy(out_name, name, ACPI_NAME_MAX);

_LEN.

The idea as I tried to explain that name can have only 4 bytes at the
end of the page. I dunno what U-Boot does if you access out of the
boundaries to the page which is not mapped to MMU (in OSes it will be
page fault). Does U-Boot map all pages to MMU?

In any case, the code above has this subtle issue. We may live with
it, but since it's a generic kinda function, better to be pedantic
about it.

> +   out_name[ACPI_NAME_LEN] = '\0';
> +
> +   return 0;
> +}

-- 
With Best Regards,
Andy Shevchenko


[PATCH v5 12/29] dm: core: Add basic ACPI support

2020-04-08 Thread Simon Glass
ACPI (Advanced Configuration and Power Interface) is a standard for
specifying information about a platform. It is a little like device
tree but the bindings are part of the specification and it supports an
interpreted bytecode language.

Driver model does not use ACPI for U-Boot's configuration, but it is
convenient to have it support generation of ACPI tables for passing to
Linux, etc.

As a starting point, add an optional set of ACPI operations to each
device. Initially only a single operation is available, to obtain the
ACPI name for the device. More operations are added later.

Enable ACPI for sandbox to ensure build coverage and so that we can add
tests.

Reviewed-by: Bin Meng 
Reviewed-by: Wolfgang Wallner 
Signed-off-by: Simon Glass 
---

Changes in v5:
- Capitalise ACPI_OPS_PTR since it includes a comma

Changes in v4: None
Changes in v3:
- Drop 'Intel' from 'Intel ACPI'
- Reword commit message to drop the bit about ACPI being complicated
- Compute ACPI_NAME_MAX from ACPI_NAME_LEN
- Rename acpi_return_name() to acpi_copy_name()
- Use strncpy() instead of strcpy() in acpi_copy_name()

Changes in v2:
- Move LOGC_ACPI definition to this patch

 configs/tools-only_defconfig |  1 +
 drivers/core/Kconfig |  9 +
 drivers/core/Makefile|  1 +
 drivers/core/acpi.c  | 33 
 include/dm/acpi.h| 73 
 include/dm/device.h  |  5 +++
 include/log.h|  2 +
 7 files changed, 124 insertions(+)
 create mode 100644 drivers/core/acpi.c
 create mode 100644 include/dm/acpi.h

diff --git a/configs/tools-only_defconfig b/configs/tools-only_defconfig
index 6ca50dc5fd3..2811b2cd37d 100644
--- a/configs/tools-only_defconfig
+++ b/configs/tools-only_defconfig
@@ -26,3 +26,4 @@ CONFIG_SYSRESET=y
 # CONFIG_VIRTIO_PCI is not set
 # CONFIG_VIRTIO_SANDBOX is not set
 # CONFIG_EFI_LOADER is not set
+# CONFIG_ACPIGEN is not set
diff --git a/drivers/core/Kconfig b/drivers/core/Kconfig
index 3b95b5387b9..a3b03993423 100644
--- a/drivers/core/Kconfig
+++ b/drivers/core/Kconfig
@@ -261,4 +261,13 @@ config DM_DEV_READ_INLINE
bool
default y if !OF_LIVE
 
+config ACPIGEN
+   bool "Support ACPI table generation in driver model"
+   default y if SANDBOX || GENERATE_ACPI_TABLE
+   help
+ This option enables generation of ACPI tables using driver-model
+ devices. It adds a new operation struct to each driver, to support
+ things like generating device-specific tables and returning the ACPI
+ name of a device.
+
 endmenu
diff --git a/drivers/core/Makefile b/drivers/core/Makefile
index bce7467da1d..c707026a3a0 100644
--- a/drivers/core/Makefile
+++ b/drivers/core/Makefile
@@ -3,6 +3,7 @@
 # Copyright (c) 2013 Google, Inc
 
 obj-y  += device.o fdtaddr.o lists.o root.o uclass.o util.o
+obj-$(CONFIG_$(SPL_TPL_)ACPIGEN) += acpi.o
 obj-$(CONFIG_DEVRES) += devres.o
 obj-$(CONFIG_$(SPL_)DM_DEVICE_REMOVE)  += device-remove.o
 obj-$(CONFIG_$(SPL_)SIMPLE_BUS)+= simple-bus.o
diff --git a/drivers/core/acpi.c b/drivers/core/acpi.c
new file mode 100644
index 000..0e64c21bf5b
--- /dev/null
+++ b/drivers/core/acpi.c
@@ -0,0 +1,33 @@
+// SPDX-License-Identifier: GPL-2.0+
+/*
+ * Core driver model support for ACPI table generation
+ *
+ * Copyright 2019 Google LLC
+ * Written by Simon Glass 
+ */
+
+#define LOG_CATEOGRY   LOGC_ACPI
+
+#include 
+#include 
+#include 
+#include 
+
+int acpi_copy_name(char *out_name, const char *name)
+{
+   strncpy(out_name, name, ACPI_NAME_MAX);
+   out_name[ACPI_NAME_LEN] = '\0';
+
+   return 0;
+}
+
+int acpi_get_name(const struct udevice *dev, char *out_name)
+{
+   struct acpi_ops *aops;
+
+   aops = device_get_acpi_ops(dev);
+   if (aops && aops->get_name)
+   return aops->get_name(dev, out_name);
+
+   return -ENOSYS;
+}
diff --git a/include/dm/acpi.h b/include/dm/acpi.h
new file mode 100644
index 000..ba0813fa21c
--- /dev/null
+++ b/include/dm/acpi.h
@@ -0,0 +1,73 @@
+/* SPDX-License-Identifier: GPL-2.0+ */
+/*
+ * Core ACPI (Advanced Configuration and Power Interface) support
+ *
+ * Copyright 2019 Google LLC
+ * Written by Simon Glass 
+ */
+
+#ifndef __DM_ACPI_H__
+#define __DM_ACPI_H__
+
+/* Allow operations to be optional for ACPI */
+#if CONFIG_IS_ENABLED(ACPIGEN)
+#define ACPI_OPS_PTR(_ptr) .acpi_ops   = _ptr,
+#else
+#define ACPI_OPS_PTR(_ptr)
+#endif
+
+/* Length of an ACPI name string, excluding nul terminator */
+#define ACPI_NAME_LEN  4
+
+/* Length of an ACPI name string including nul terminator */
+#define ACPI_NAME_MAX  (ACPI_NAME_LEN + 1)
+
+/**
+ * struct acpi_ops - ACPI operations supported by driver model
+ */
+struct acpi_ops {
+   /**
+* get_name() - Obtain the ACPI name of a device
+*
+* @dev: Device to check
+* @out_name: Place to put the name, must hold at least ACPI_NAME_MAX
+*  bytes
+* @return 0 if OK,