[Xen-devel] [PATCH 04/27] tools/xl: Mandatory flag indicating the format of the migration stream

2015-06-15 Thread Andrew Cooper
Introduced at this point so the python stream conversion code has a concrete
ABI to use.

Signed-off-by: Andrew Cooper 
CC: Ian Campbell 
CC: Ian Jackson 
CC: Wei Liu 
---
 tools/libxl/xl_cmdimpl.c |1 +
 1 file changed, 1 insertion(+)

diff --git a/tools/libxl/xl_cmdimpl.c b/tools/libxl/xl_cmdimpl.c
index c858068..ddb293c 100644
--- a/tools/libxl/xl_cmdimpl.c
+++ b/tools/libxl/xl_cmdimpl.c
@@ -109,6 +109,7 @@
*/
 
 #define XL_MANDATORY_FLAG_JSON (1U << 0) /* config data is in JSON format */
+#define XL_MANDATORY_FLAG_STREAMv2 (1U << 1) /* stream is v2 */
 #define XL_MANDATORY_FLAG_ALL  (XL_MANDATORY_FLAG_JSON)
 struct save_file_header {
 char magic[32]; /* savefileheader_magic */
-- 
1.7.10.4


___
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel


Re: [Xen-devel] [PATCH 04/27] tools/xl: Mandatory flag indicating the format of the migration stream

2015-06-16 Thread Ian Campbell
On Mon, 2015-06-15 at 14:44 +0100, Andrew Cooper wrote:
> Introduced at this point so the python stream conversion code has a concrete
> ABI to use.

Please could you also explicitly mention that it isn't added to FLAG_ALL
yet because we don't actually implement it yet and that it will be added
there later.

With that:
> Signed-off-by: Andrew Cooper 

Acked-by: Ian Campbell 

(although I wish I had a better name in mind...)



___
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel


Re: [Xen-devel] [PATCH 04/27] tools/xl: Mandatory flag indicating the format of the migration stream

2015-06-16 Thread Andrew Cooper
On 16/06/15 14:39, Ian Campbell wrote:
> On Mon, 2015-06-15 at 14:44 +0100, Andrew Cooper wrote:
>> Introduced at this point so the python stream conversion code has a concrete
>> ABI to use.
> Please could you also explicitly mention that it isn't added to FLAG_ALL
> yet because we don't actually implement it yet and that it will be added
> there later.

Certainly.

>
> With that:
>> Signed-off-by: Andrew Cooper 
> Acked-by: Ian Campbell 
>
> (although I wish I had a better name in mind...)

Any suggestions welcome.

~Andrew

___
Xen-devel mailing list
Xen-devel@lists.xen.org
http://lists.xen.org/xen-devel