Author: jhen
Date: Fri Dec 2 11:32:18 2016
New Revision: 288512
URL: http://llvm.org/viewvc/llvm-project?rev=288512&view=rev
Log:
[CUDA] Forward sanitizer support to host toolchain
Summary:
This is an improvement on rL288448 where address sanitization was listed
as supported for the CudaToolChai
; }
I will get a patch up later today to do that.
Thanks for the suggestion!
-Jason
On Fri, Dec 2, 2016 at 4:31 AM Hal Finkel wrote:
> - Original Message -
> > From: "Jason Henline via cfe-commits"
> > To: cfe-commits@lists.llvm.org
> > Sent: Thu
Author: jhen
Date: Thu Dec 1 20:04:43 2016
New Revision: 288453
URL: http://llvm.org/viewvc/llvm-project?rev=288453&view=rev
Log:
[CUDA] Fix faulty test from rL288448
Summary:
The test introduced by rL288448 is currently failing because
unimportant but unexpected errors appear as output from a t
Author: jhen
Date: Thu Dec 1 19:42:54 2016
New Revision: 288448
URL: http://llvm.org/viewvc/llvm-project?rev=288448&view=rev
Log:
[CUDA] "Support" ASAN arguments in CudaToolChain
This fixes a bug that was introduced in rL287285. The bug made it
illegal to pass -fsanitize=address during CUDA comp
jhen added a comment.
Thanks for the review!
Repository:
rL LLVM
https://reviews.llvm.org/D25450
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
This revision was automatically updated to reflect the committed changes.
jhen marked an inline comment as done.
Closed by commit rL284992: [clang-tidy] Fix identifier naming in macro args.
(authored by jhen).
Changed prior to commit:
https://reviews.llvm.org/D25450?vs=75430&id=75610#toc
Repos
Author: jhen
Date: Mon Oct 24 12:20:32 2016
New Revision: 284992
URL: http://llvm.org/viewvc/llvm-project?rev=284992&view=rev
Log:
[clang-tidy] Fix identifier naming in macro args.
Summary:
clang-tidy should fix identifier naming even when the identifier is
referenced inside a macro expansion, pr
jhen marked an inline comment as done.
jhen added inline comments.
Comment at: clang-tidy/readability/IdentifierNamingCheck.cpp:654
+ RangeIsEntirelyWithinMacroArgument || !RangeContainsMacroExpansion;
+ Failure.ShouldFix = Failure.ShouldFix && RangeCanBeFixed;
}
-
jhen updated this revision to Diff 75430.
jhen added a comment.
- Early exit if not Failure.ShouldFix
https://reviews.llvm.org/D25450
Files:
clang-tidy/readability/IdentifierNamingCheck.cpp
test/clang-tidy/readability-identifier-naming.cpp
Index: test/clang-tidy/readability-identifier-nami
jhen added a comment.
Adding arron.ballman as a reviewer as alexfh seems to be on leave for a few
weeks.
https://reviews.llvm.org/D25450
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-comm
jhen added a comment.
I just found and fixed another bug in this patch. Before, I wasn't using the
spelling location for the fixit hint. This meant that a macro argument that was
expanded to two locations, for example, would have the same fixit hint applied
to it twice. My new test case verifie
jhen updated this revision to Diff 74184.
jhen added a comment.
- Prevent multiple fixes for macro expansion
https://reviews.llvm.org/D25450
Files:
clang-tidy/readability/IdentifierNamingCheck.cpp
test/clang-tidy/readability-identifier-naming.cpp
Index: test/clang-tidy/readability-identifi
jhen added a comment.
I found a bug in my first patch that I have fixed now. I was trying to iterate
over the source range by using `SourceLocation::getLocWithOffset`, but I
realized that doesn't work, so I removed it and went back to the original
method of checking `SourceRange.getBegin().isMa
jhen updated this revision to Diff 74181.
jhen added a comment.
- Return to original checking for macro in range
https://reviews.llvm.org/D25450
Files:
clang-tidy/readability/IdentifierNamingCheck.cpp
test/clang-tidy/readability-identifier-naming.cpp
Index: test/clang-tidy/readability-iden
jhen added a comment.
alexfh, sorry if you are not the right person to review this change. I based my
choice on this history of this file.
https://reviews.llvm.org/D25450
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org
jhen created this revision.
jhen added a reviewer: alexfh.
jhen added a subscriber: cfe-commits.
Herald added a subscriber: jlebar.
clang-tidy should fix identifier naming even when the identifier is
referenced inside a macro expansion, provided that the identifier enters
the macro expansion compl
jhen marked an inline comment as done.
jhen added a comment.
Thanks for the review rsmith!
http://reviews.llvm.org/D15858
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
jhen updated this revision to Diff 44933.
jhen added a comment.
- Add extra test for OK parameter pack
http://reviews.llvm.org/D15858
Files:
include/clang/AST/Expr.h
include/clang/AST/ExprCXX.h
lib/AST/Expr.cpp
test/SemaCUDA/cxx11-kernel-call.cu
test/SemaCUDA/kernel-call.cu
Index: te
jhen added a comment.
rsmith, I think the patch is ready to be committed. Please take a look if you
have a moment. Thanks for your help.
http://reviews.llvm.org/D15858
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cg
jhen updated this revision to Diff 44538.
jhen added a comment.
- Handle unexpanded parameter packs
The changes for instantiation dependence also fix a bug with unexpanded
parameter packs, so add a unit test for unexpanded parameter packs as well.
http://reviews.llvm.org/D15858
Files:
inc
jhen updated this revision to Diff 44167.
jhen added a comment.
- Use config ptr itself rather than boolean flag
http://reviews.llvm.org/D15858
Files:
include/clang/AST/ExprCXX.h
lib/AST/Expr.cpp
test/SemaCUDA/kernel-call.cu
Index: test/SemaCUDA/kernel-call.cu
===
jhen added inline comments.
Comment at: include/clang/AST/ExprCXX.h:181
@@ +180,3 @@
+assert(
+!IsConfigSet &&
+"CUDAKernelCallExpr.setConfig can only be called once per instance.");
rsmith wrote:
> Perhaps `assert(!getPreArg(CONFIG))` instead
jhen marked an inline comment as done.
Comment at: test/SemaCUDA/kernel-call.cu:27
@@ -26,1 +26,3 @@
+
+ g1<<>>(42); // expected-error {{use of undeclared identifier
'undeclared'}}
}
rsmith wrote:
> jhen wrote:
> > Thanks for bringing this up. While trying to f
jhen updated this revision to Diff 44143.
jhen added a comment.
- Assert setConfig only called once
http://reviews.llvm.org/D15858
Files:
include/clang/AST/ExprCXX.h
test/SemaCUDA/kernel-call.cu
Index: test/SemaCUDA/kernel-call.cu
===
jhen marked 2 inline comments as done.
jhen added a comment.
http://reviews.llvm.org/D15858
___
cfe-commits mailing list
cfe-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits
jhen added inline comments.
Comment at: test/SemaCUDA/kernel-call.cu:27
@@ -26,1 +26,3 @@
+
+ g1<<>>(42); // expected-error {{use of undeclared identifier
'undeclared'}}
}
Thanks for bringing this up. While trying to find tests that dealt with each
dependence
jhen updated this revision to Diff 44131.
jhen added a reviewer: jlebar.
jhen removed a subscriber: jlebar.
jhen added a comment.
- Correct dependence info in CUDA kernel call AST
This patch removes the propagation of type and value dependence and the
propagation of information on unexpanded p
jhen created this revision.
jhen added reviewers: tra, jlebar.
jhen added a subscriber: cfe-commits.
Value, type, and instantiation dependence were not being handled
correctly for CUDAKernelCallExpr AST nodes. As a result, if an undeclared
identifier was used in the triple-angle-bracket kernel cal
jhen added a subscriber: jhen.
Comment at: lib/Headers/__clang_cuda_runtime_wrapper.h:95
@@ -78,3 +94,3 @@
#define __CUDACC__
#include_next "cuda_runtime.h"
Now that the name of this header has been changed, would it be appropriate to
change this #include_nex
29 matches
Mail list logo