[PATCH 1/2] dma-buf/fence-array: add fence_is_array()

2016-06-30 Thread Chris Wilson
On Thu, Jun 30, 2016 at 03:23:59PM +0100, Chris Wilson wrote: > On Thu, Jun 30, 2016 at 11:09:47AM -0300, Gustavo Padovan wrote: > > From: Gustavo Padovan > > > > Add helper to check if fence is array. > > > > Cc: Chris Wilson > > Cc: Christian König > > Signed-off-by: Gustavo Padovan > >

[Bug 96731] [RADEONSI] [LLVM] [bisected] GPU lockups when running Alien: Isolation

2016-06-30 Thread bugzilla-dae...@freedesktop.org
part -- An HTML attachment was scrubbed... URL: <https://lists.freedesktop.org/archives/dri-devel/attachments/20160630/44bbba6b/attachment.html>

[PATCH v2 1/2] drm/fsl-dcu: update the panel dt binding document

2016-06-30 Thread Rob Herring
On Wed, Jun 29, 2016 at 04:17:57PM +0800, Meng Yi wrote: > dropped the old "fsl,panel" property, using the of_graph dt > binding syntax > > Signed-off-by: Meng Yi > --- > Changes in V2: > -drop the unit address of port > --- > Documentation/devicetree/bindings/display/fsl,dcu.txt | 9 +++--

[PATCH] drivers: gpu: drm: amd: powerplay: hwmgr: Remove unused variable

2016-06-30 Thread Matthias Beyer
Signed-off-by: Matthias Beyer --- drivers/gpu/drm/amd/powerplay/hwmgr/polaris10_hwmgr.c | 9 +++-- 1 file changed, 3 insertions(+), 6 deletions(-) diff --git a/drivers/gpu/drm/amd/powerplay/hwmgr/polaris10_hwmgr.c b/drivers/gpu/drm/amd/powerplay/hwmgr/polaris10_hwmgr.c index

[PATCH] Remove unused variable

2016-06-30 Thread Matthias Beyer
Hi, after reading your email, I created this patch. **Please note all**: I'm getting into kernel dev right now (again), so I don't even know how to test-compile this patch, let alone testing it. You're more than welcome to teach me things. Matthias Beyer (1): drivers: gpu: drm: amd:

[PATCH i-g-t 2/2] lib/drmtest: add virtio_gpu support

2016-06-30 Thread Gustavo Padovan
From: Gustavo Padovan Support the virtio GPU on drmtest. Signed-off-by: Gustavo Padovan --- lib/drmtest.c | 9 + lib/drmtest.h | 1 + 2 files changed, 10 insertions(+) diff --git a/lib/drmtest.c b/lib/drmtest.c index 9f3ac7f..b374006 100644 ---

[PATCH i-g-t 1/2] lib/drmtest: Fix igt_skip message

2016-06-30 Thread Gustavo Padovan
From: Gustavo Padovan Now other gpus are supported too. Signed-off-by: Gustavo Padovan --- lib/drmtest.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/lib/drmtest.c b/lib/drmtest.c index 884fe7c..9f3ac7f 100644 --- a/lib/drmtest.c +++

[PATCH v8 02/10] drm/hisilicon: Add hisilicon kirin drm master driver

2016-06-30 Thread Xinliang Liu
On 13 April 2016 at 20:15, Emil Velikov wrote: > Hi Xinliang, > > On 11 April 2016 at 09:55, Xinliang Liu wrote: > >> +static int kirin_drm_connectors_register(struct drm_device *dev) >> +{ >> + struct drm_connector *connector; >> + struct drm_connector *failed_connector; >> +

[PATCH] drm/hisilicon: Fix ADE vblank on/off handling

2016-06-30 Thread Xinliang Liu
Vblank turn on should be called in crtc's enable callback. And turn off called in crtc's disable callback. Thanks to Daniel Vetter, this bug is reported by him. Reported-by: Daniel Vetter Signed-off-by: Xinliang Liu --- drivers/gpu/drm/hisilicon/kirin/kirin_drm_ade.c | 2 ++ 1 file changed, 2

[PULL] drm-intel-fixes

2016-06-30 Thread Jani Nikula
Hi Dave, here's a batch of i915 fixes for 4.7. We don't have coverage for next week, so please pick up any serious fixes directly. Daniel will take over fixes once he returns. BR, Jani. The following changes since commit 4c2e07c6a29e0129e975727b9f57eede813eea85: Linux 4.7-rc5 (2016-06-26

[PATCH] arm64: dts: Add HDMI node for hi6220-hikey

2016-06-30 Thread Xinliang Liu
Add adv7533 HDMI DT node for HiKey board. And this patch depends on the hikey display dts patch[1] and adv7533 support patch[2]. [1] https://patchwork.kernel.org/patch/9189287/ [2] http://www.spinics.net/lists/linux-arm-msm/msg21305.html Signed-off-by: Xinliang Liu ---

[PATCH 2/6] drm/nouveau/core: make use of new strtolower() function

2016-06-30 Thread Markus Mayer
Call strtolower() rather than walking the string explicitly to convert it to lowercase. Signed-off-by: Markus Mayer --- drivers/gpu/drm/nouveau/nvkm/core/firmware.c | 7 +-- 1 file changed, 1 insertion(+), 6 deletions(-) diff --git a/drivers/gpu/drm/nouveau/nvkm/core/firmware.c

[PATCH 1/6] lib: string: add function strtolower()

2016-06-30 Thread Markus Mayer
Add a function called strtolower() to convert strings to lower case in-place, overwriting the original string. This seems to be a recurring requirement in the kernel that is currently being solved by several duplicated implementations doing the same thing. Signed-off-by: Markus Mayer ---

[PATCH 0/6] lib: string: add function strtolower()

2016-06-30 Thread Markus Mayer
This series introduces a new generic function strtolower(), which converts strings to lowercase in-place, overwriting the original string. This kind of functionality is needed in several places in the kernel. Right now, everybody seems to be implementing their own copy of this function. So, we

[PATCH] backlight: Avoid double fbcon backlight handling

2016-06-30 Thread Imre Deak
On to, 2016-06-30 at 12:30 +0100, Chris Wilson wrote: > Backlights controlled by i915.ko and only associated with its > connectors > and also only associated with the intel_drmfb fbcon, controlled by > i915.ko. In this situation, we already handle adjusting the backlight > when the fbcon is

[PATCH 3/3] drm/vgem: Attach sw fences to exported vGEM dma-buf (ioctl)

2016-06-30 Thread Zach Reizner
GEMENT. > + * IN NO EVENT SHALL TUNGSTEN GRAPHICS AND/OR ITS SUPPLIERS BE LIABLE FOR > + * ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION OF > CONTRACT, > + * TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION WITH THE > + * SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE. > + * > + */ > + > +#ifndef _UAPI_VGEM_DRM_H_ > +#define _UAPI_VGEM_DRM_H_ > + > +#include "drm.h" > + > +#if defined(__cplusplus) > +extern "C" { > +#endif > + > +/* Please note that modifications to all structs defined here are > + * subject to backwards-compatibility constraints. > + */ > +#define DRM_VGEM_FENCE_ATTACH 0x1 > +#define DRM_VGEM_FENCE_SIGNAL 0x2 > + > +#define DRM_IOCTL_VGEM_FENCE_ATTACHDRM_IOWR( DRM_COMMAND_BASE + > DRM_VGEM_FENCE_ATTACH, struct drm_vgem_fence_attach) > +#define DRM_IOCTL_VGEM_FENCE_SIGNALDRM_IOW( DRM_COMMAND_BASE + > DRM_VGEM_FENCE_SIGNAL, struct drm_vgem_fence_signal) > + > +struct drm_vgem_fence_attach { > + __u32 handle; > + __u32 flags; > +#define VGEM_FENCE_WRITE 0x1 > + __u32 out_fence; > + __u32 pad; > +}; > + > +struct drm_vgem_fence_signal { > + __u32 fence; > + __u32 flags; > +}; > + > +#if defined(__cplusplus) > +} > +#endif > + > +#endif /* _UAPI_VGEM_DRM_H_ */ > -- > 2.8.1 > Acked-by: Zach Reizner -- next part -- An HTML attachment was scrubbed... URL: <https://lists.freedesktop.org/archives/dri-devel/attachments/20160630/d505c446/attachment-0001.html>

[PATCH V2 00/11] Add support for Tegra DPAUX pinctrl

2016-06-30 Thread Thierry Reding
| 18 +- > 7 files changed, 373 insertions(+), 52 deletions(-) > create mode 100644 > Documentation/devicetree/bindings/pinctrl/nvidia,tegra124-dpaux-padctl.txt Applied, thanks. Thierry -- next part -- A non-text attachment was scrubbed... Name: signature.asc Type: application/pgp-signature Size: 819 bytes Desc: not available URL: <https://lists.freedesktop.org/archives/dri-devel/attachments/20160630/89c23e49/attachment.sig>

[Bug 95528] BioShock Infinite graphical glitches on radeonsi

2016-06-30 Thread bugzilla-dae...@freedesktop.org
rchives/dri-devel/attachments/20160630/75013b45/attachment.html>

[PATCH 1/2] dma-buf/fence-array: add fence_is_array()

2016-06-30 Thread Chris Wilson
On Thu, Jun 30, 2016 at 11:09:47AM -0300, Gustavo Padovan wrote: > From: Gustavo Padovan > > Add helper to check if fence is array. > > Cc: Chris Wilson > Cc: Christian König > Signed-off-by: Gustavo Padovan > --- > include/linux/fence-array.h | 10 ++ > 1 file changed, 10

[PATCH 2/2] dma-buf/sync_file: rework fence storage in struct file

2016-06-30 Thread Chris Wilson
On Thu, Jun 30, 2016 at 11:09:48AM -0300, Gustavo Padovan wrote: > From: Gustavo Padovan > > Create sync_file->fence to abstract the type of fence we are using for > each sync_file. If only one fence is present we use a normal struct fence > but if there is more fences to be added to the

[PATCH v6v3 02/12] mm: migrate: support non-lru movable page migration

2016-06-30 Thread Minchan Kim
On Thu, Jun 30, 2016 at 11:26:45AM +0530, Anshuman Khandual wrote: > >> Did you get a chance to test the driver out ? I am still concerned about > >> how to > >> handle the struct address_space override problem within the struct page. > > > > Hi Anshuman, > > > > Slow but I am working on

[PATCH] backlight: Avoid double fbcon backlight handling

2016-06-30 Thread Jani Nikula
On Thu, 30 Jun 2016, Chris Wilson wrote: > Backlights controlled by i915.ko and only associated with its connectors > and also only associated with the intel_drmfb fbcon, controlled by > i915.ko. In this situation, we already handle adjusting the backlight > when the fbcon is blanked/unblanked

[PATCH v4 0/11] Misc fixup and add RK3399 eDP support to Analogix DP driver[Involving remittance information, please pay attention to the safety of property]

2016-06-30 Thread Yakir Yang
Sean, On 06/29/2016 10:01 PM, Sean Paul wrote: > On Wed, Jun 29, 2016 at 5:14 AM, Yakir Yang wrote: >> RK3399 and RK3288 shared the same eDP IP controller, only some light >> difference with VOP configure and GRF configure. >> > The whole set looks good to me. All patches should have my R-b now,

[PATCH libdrm 1/1] xf86drm.c: Fix mix of tabs and spaces

2016-06-30 Thread Jan Vesely
Remove whitespace at the end of line. diff -b shows only two removed lines Signed-off-by: Jan Vesely --- xf86drm.c | 1444 ++--- 1 file changed, 721 insertions(+), 723 deletions(-) diff --git a/xf86drm.c b/xf86drm.c index 804a413..e99f2e2

[Bug 91841] Juniper 5770 entering Hibernate crashes the system (instant reboot)

2016-06-30 Thread bugzilla-dae...@freedesktop.org
: <https://lists.freedesktop.org/archives/dri-devel/attachments/20160630/957502cc/attachment.html>

[PATCH] backlight: Avoid double fbcon backlight handling

2016-06-30 Thread Chris Wilson
Backlights controlled by i915.ko and only associated with its connectors and also only associated with the intel_drmfb fbcon, controlled by i915.ko. In this situation, we already handle adjusting the backlight when the fbcon is blanked/unblanked and do not require backlight trying to do the same.

[PATCH] [linux-next] drm: Fix a typo in drm_ioctl.c

2016-06-30 Thread Jani Nikula
On Thu, 30 Jun 2016, Masanari Iida wrote: > This patch fix a spelling typo found in > Documentation/DocBook/gpu/API-drm-ioctl-flags.html > It is because the html file was created from comments in source, > I have to fix the source. > > Signed-off-by: Masanari Iida Picked up to drm-misc, thanks

[PATCH V2 01/11] soc/tegra: pmc: Initialise resets associated with a power partition

2016-06-30 Thread Thierry Reding
p-signature Size: 819 bytes Desc: not available URL: <https://lists.freedesktop.org/archives/dri-devel/attachments/20160630/e2a5df54/attachment.sig>

[Bug 96731] [RADEONSI] [LLVM] [bisected] GPU lockups when running Alien: Isolation

2016-06-30 Thread bugzilla-dae...@freedesktop.org
. -- next part -- An HTML attachment was scrubbed... URL: <https://lists.freedesktop.org/archives/dri-devel/attachments/20160630/8e1d8e7a/attachment.html>

[PATCH 2/2] dma-buf/sync_file: rework fence storage in struct file

2016-06-30 Thread Gustavo Padovan
From: Gustavo Padovan Create sync_file->fence to abstract the type of fence we are using for each sync_file. If only one fence is present we use a normal struct fence but if there is more fences to be added to the sync_file a fence_array is created. This change

[PATCH 1/2] dma-buf/fence-array: add fence_is_array()

2016-06-30 Thread Gustavo Padovan
From: Gustavo Padovan Add helper to check if fence is array. Cc: Chris Wilson Cc: Christian König Signed-off-by: Gustavo Padovan --- include/linux/fence-array.h | 10 ++ 1 file changed, 10 insertions(+) diff --git a/include/linux/fence-array.h

[PATCH 0/2] dma-buf/sync_file: rework fences on struct sync_file

2016-06-30 Thread Gustavo Padovan
From: Gustavo Padovan Hi all, This is an attempt to improve fence support on Sync File. The basic idea is to have only sync_file->fence and store all fences there, either as normal fences or fence_arrays. That way we can remove some potential duplication

[Bug 96731] [RADEONSI] [LLVM] [bisected] GPU lockups when running Alien: Isolation

2016-06-30 Thread bugzilla-dae...@freedesktop.org
You are the assignee for the bug. -- next part -- An HTML attachment was scrubbed... URL: <https://lists.freedesktop.org/archives/dri-devel/attachments/20160630/5427670c/attachment.html>

[Bug 96731] [RADEONSI] [LLVM] [bisected] GPU lockups when running Alien: Isolation

2016-06-30 Thread bugzilla-dae...@freedesktop.org
You are the assignee for the bug. -- next part -- An HTML attachment was scrubbed... URL: <https://lists.freedesktop.org/archives/dri-devel/attachments/20160630/78a996a4/attachment.html>

[PATCH v5 43/44] dma-mapping: Remove dma_get_attr

2016-06-30 Thread Krzysztof Kozlowski
After switching DMA attributes to unsigned long it is easier to just compare the bits. Signed-off-by: Krzysztof Kozlowski [for avr32] Acked-by: Hans-Christian Noren Egtvedt [for arc] Acked-by: Vineet Gupta [for arm64 and dma-iommu] Acked-by: Robin Murphy --- Documentation/DMA-API.txt

[PATCH v5 15/44] drm/rockship: dma-mapping: Use unsigned long for dma_attrs

2016-06-30 Thread Krzysztof Kozlowski
Split out subsystem specific changes for easier reviews. This will be squashed with main commit. Signed-off-by: Krzysztof Kozlowski --- drivers/gpu/drm/rockchip/rockchip_drm_gem.c | 17 +++-- drivers/gpu/drm/rockchip/rockchip_drm_gem.h | 2 +- 2 files changed, 8 insertions(+), 11

[PATCH v5 14/44] drm/nouveau: dma-mapping: Use unsigned long for dma_attrs

2016-06-30 Thread Krzysztof Kozlowski
Split out subsystem specific changes for easier reviews. This will be squashed with main commit. Signed-off-by: Krzysztof Kozlowski --- drivers/gpu/drm/nouveau/nvkm/subdev/instmem/gk20a.c | 13 ++--- 1 file changed, 6 insertions(+), 7 deletions(-) diff --git

[PATCH v5 13/44] drm/msm: dma-mapping: Use unsigned long for dma_attrs

2016-06-30 Thread Krzysztof Kozlowski
Split out subsystem specific changes for easier reviews. This will be squashed with main commit. Signed-off-by: Krzysztof Kozlowski --- drivers/gpu/drm/msm/msm_drv.c | 13 ++--- 1 file changed, 6 insertions(+), 7 deletions(-) diff --git a/drivers/gpu/drm/msm/msm_drv.c

[PATCH v5 12/44] drm/mediatek: dma-mapping: Use unsigned long for dma_attrs

2016-06-30 Thread Krzysztof Kozlowski
Split out subsystem specific changes for easier reviews. This will be squashed with main commit. Signed-off-by: Krzysztof Kozlowski --- drivers/gpu/drm/mediatek/mtk_drm_gem.c | 13 ++--- drivers/gpu/drm/mediatek/mtk_drm_gem.h | 2 +- 2 files changed, 7 insertions(+), 8 deletions(-)

[PATCH v5 11/44] drm/exynos: dma-mapping: Use unsigned long for dma_attrs

2016-06-30 Thread Krzysztof Kozlowski
Split out subsystem specific changes for easier reviews. This will be squashed with main commit. Signed-off-by: Krzysztof Kozlowski --- drivers/gpu/drm/exynos/exynos_drm_fbdev.c | 2 +- drivers/gpu/drm/exynos/exynos_drm_g2d.c | 12 +--- drivers/gpu/drm/exynos/exynos_drm_gem.c | 20

[PATCH v5 00/44] dma-mapping: Use unsigned long for dma_attrs

2016-06-30 Thread Krzysztof Kozlowski
Hi, This is fifth approach for replacing struct dma_attrs with unsigned long. The main patch (1/44) doing the change is split into many subpatches for easier review (2-42). They should be squashed together when applying. Rebased on v4.7-rc5. For easier testing the patchset is available

[PULL] sti-drm-next-2016-06-30

2016-06-30 Thread Benjamin Gaignard
+- drivers/gpu/drm/sti/sti_vtg.c | 2 +- 6 files changed, 314 insertions(+), 63 deletions(-) -- next part -- An HTML attachment was scrubbed... URL: <https://lists.freedesktop.org/archives/dri-devel/attachments/20160630/259b9d7d/attachment.html>

[PATCH] [linux-next] drm: Fix a typo in drm_ioctl.c

2016-06-30 Thread Masanari Iida
This patch fix a spelling typo found in Documentation/DocBook/gpu/API-drm-ioctl-flags.html It is because the html file was created from comments in source, I have to fix the source. Signed-off-by: Masanari Iida --- drivers/gpu/drm/drm_ioctl.c | 2 +- 1 file changed, 1 insertion(+), 1

[PATCH] [linux-next] drm: Fix a typo in drm_ioctl.c

2016-06-30 Thread Masanari Iida
This patch fix a spelling typo found in Documentation/DocBook/gpu/API-drm-ioctl-flags.html It is because the html file was created from comments in source, I have to fix the source. Signed-off-by: Masanari Iida --- drivers/gpu/drm/drm_ioctl.c | 2 +- 1 file changed, 1 insertion(+), 1

[PATCH] drm: mediatek: fix prototypes after API change

2016-06-30 Thread Stephen Rothwell
Hi Arnd, On Wed, 29 Jun 2016 16:51:29 +0200 Arnd Bergmann wrote: > > The newly added mediatek HDMI driver clashes with an API change > for struct hdmi_codec_ops, causing an 'allmodconfig' build to fail: > > drivers/gpu/drm/mediatek/mtk_hdmi.c:1653:15: error: initialization from > incompatible

[PATCH] drm: mediatek: fix prototypes after API change

2016-06-30 Thread Kuninori Morimoto
Hi > The newly added mediatek HDMI driver clashes with an API change > for struct hdmi_codec_ops, causing an 'allmodconfig' build to fail: > > drivers/gpu/drm/mediatek/mtk_hdmi.c:1653:15: error: initialization from > incompatible pointer type [-Werror=incompatible-pointer-types] >

[PATCH] drm_aux-dev: fix error handling in drm_dp_aux_dev_init()

2016-06-30 Thread Alexey Khoroshilov
If class_create() fails, there is no need for class_destroy(). Found by Linux Driver Verification project (linuxtesting.org). Signed-off-by: Alexey Khoroshilov --- drivers/gpu/drm/drm_dp_aux_dev.c | 3 +-- 1 file changed, 1 insertion(+), 2 deletions(-) diff --git

[Bug 91880] Radeonsi on Grenada cards (r9 390) exceptionally unstable and poorly performing

2016-06-30 Thread bugzilla-dae...@freedesktop.org
: <https://lists.freedesktop.org/archives/dri-devel/attachments/20160630/bf9b5ca6/attachment.html>

[Bug 96731] [RADEONSI] [LLVM] [bisected] GPU lockups when running Alien: Isolation

2016-06-30 Thread bugzilla-dae...@freedesktop.org
. -- next part -- An HTML attachment was scrubbed... URL: <https://lists.freedesktop.org/archives/dri-devel/attachments/20160630/4fb3c36e/attachment-0001.html>