On Sun, Feb 19, 2017 at 11:03:07AM +, Thomas Gummerer wrote:
> Thanks Junio and Peff for comments on the last round.
>
> Changes since then:
>
> - removed mention of the "new form" of git stash create from the
> Documentation.
> - Changed documentation for git stash without a verb, mention
On Sat, Feb 18, 2017 at 10:27:51PM +, pedro rijo wrote:
> I would say everyone did an amazing job, closing more than 150 old issues
> in a single week! I think the amount of issues is finally manageable (40
> issues currently).
Yes, thank you to all who have been helping. But especially you a
>>> Then you must adjust your definition of "good": All commits that do not have
>>> the feature, yet, are "good": since they do not have the feature in the
>>> first place, they cannot have the breakage that you found in the feature.
>>>
>>> That is exactly the situation in your original example!
On Sun, Feb 19, 2017 at 4:46 PM, Jeff King wrote:
>
> I think there are two potential patches:
>
> 1. Add a custom-format placeholder for the --source value.
> This is an obvious improvement that doesn't hurt anyone.
Right.
> 2. Switch --decorate to the end by default, but _not_ --sourc
Jeff King writes:
> I think there are two potential patches:
>
> 1. Add a custom-format placeholder for the --source value.
> This is an obvious improvement that doesn't hurt anyone.
>
> 2. Switch --decorate to the end by default, but _not_ --source.
>
> This use case _could_ be ser
On Sun, Feb 19, 2017 at 03:03:21PM -0800, Jacob Keller wrote:
> >> I just got bitten by a fallout. I have
> >>
> >> $ git recent --help
> >> `git recent' is aliased to `log --oneline --branches --no-merges \
> >> --source --since=3.weeks'
> >>
> >> but now the branch names are sh
On Sun, Feb 19, 2017 at 11:32:32PM +0100, Damien Regad wrote:
> Use of 'iff' may be confusing to people not familiar with this term.
>
> Improving the --normalize option's documentation to remove the use of
> 'iff', and clearly describe what happens when the condition is not met.
Looks good to m
Convert most leaf functions to struct object_id. Change several
hardcoded numbers to uses of parse_oid_hex. In doing so, verify that we
when we want two trees, we have exactly two trees.
Finally, in stdin_diff_commit, avoid accessing the byte after the NUL.
This will be a NUL as well, since the
There are a few leaf functions in various files that call
resolve_refdup. Convert these functions to use struct object_id
internally to prepare for transitioning resolve_refdup itself.
Signed-off-by: brian m. carlson
---
builtin/notes.c| 18 +-
builtin/receive-pack.c |
Additionally convert several uses of the constant 40 into
GIT_SHA1_HEXSZ.
Signed-off-by: brian m. carlson
---
builtin/merge.c | 134
1 file changed, 66 insertions(+), 68 deletions(-)
diff --git a/builtin/merge.c b/builtin/merge.c
index a9
Convert several functions to use struct object_id, and rename them so
that they no longer refer to SHA-1.
Signed-off-by: brian m. carlson
---
builtin/grep.c | 24
1 file changed, 12 insertions(+), 12 deletions(-)
diff --git a/builtin/grep.c b/builtin/grep.c
index 2c727e
Convert struct reflog_info to use struct object_id by changing the
structure definition and applying the following semantic patch:
@@
struct reflog_info E1;
@@
- E1.osha1
+ E1.ooid.hash
@@
struct reflog_info *E1;
@@
- E1->osha1
+ E1->ooid.hash
@@
struct reflog_info E1;
@@
- E1.nsha1
+ E1.noid.ha
Convert the functions in this file and struct commit_name to struct
object_id.
Signed-off-by: brian m. carlson
---
builtin/describe.c | 50 +-
1 file changed, 25 insertions(+), 25 deletions(-)
diff --git a/builtin/describe.c b/builtin/describe.c
Convert most leaf functions to use struct object_id.
Signed-off-by: brian m. carlson
---
builtin/commit.c | 46 +++---
1 file changed, 23 insertions(+), 23 deletions(-)
diff --git a/builtin/commit.c b/builtin/commit.c
index 2de5f6cc64..4e288bc513 100644
-
Convert the remaining uses of unsigned char [20] to struct object_id.
Signed-off-by: brian m. carlson
---
builtin/merge-base.c | 28 ++--
1 file changed, 14 insertions(+), 14 deletions(-)
diff --git a/builtin/merge-base.c b/builtin/merge-base.c
index db95bc29cf..cfe2a796
This is another series in the continuing conversion to struct object_id.
This series converts more of the builtin directory and some of the refs
code to use struct object_id. Additionally, it implements an
nth_packed_object_oid function which provides a struct object_id version
of the nth_packed_o
There are places in the code where we would like to provide a struct
object_id *, yet read the hash directly from the pack. Provide an
nth_packed_object_oid function that is similar to the
nth_packed_object_sha1 function.
In order to avoid a potentially invalid cast, nth_packed_object_oid
provide
Signed-off-by: brian m. carlson
---
builtin/branch.c | 26 +-
1 file changed, 13 insertions(+), 13 deletions(-)
diff --git a/builtin/branch.c b/builtin/branch.c
index 9d30f55b0b..faf472ff8f 100644
--- a/builtin/branch.c
+++ b/builtin/branch.c
@@ -32,7 +32,7 @@ static cons
Introduce a function, parse_oid_hex, which parses a hexadecimal object
ID and if successful, sets a pointer to just beyond the last character.
This allows for simpler, more robust parsing without needing to
hard-code integer values throughout the codebase.
Signed-off-by: brian m. carlson
---
cac
Convert each_loose_object_fn and each_packed_object_fn to take a pointer
to struct object_id. Update the various callbacks. Convert several
40-based constants to use GIT_SHA1_HEXSZ.
Signed-off-by: brian m. carlson
---
builtin/cat-file.c | 8
builtin/count-objects.c | 4 ++--
bu
Convert most of the code to use struct object_id, including struct
origin_data and struct merge_parents. Convert several instances of
hardcoded numbers into references to GIT_SHA1_HEXSZ.
Signed-off-by: brian m. carlson
---
builtin/fmt-merge-msg.c | 70 ---
Convert the remaining uses of unsigned char [20] to struct object_id.
Signed-off-by: brian m. carlson
---
wt-status.c | 44 ++--
1 file changed, 22 insertions(+), 22 deletions(-)
diff --git a/wt-status.c b/wt-status.c
index 5fac8437b0..a8d1faf80d 100644
-
Convert various uses of unsigned char [20] to struct object_id. Rename
replace_object_sha1 to replace_object_oid. Finally, specify a constant
in terms of GIT_SHA1_HEXSZ.
Signed-off-by: brian m. carlson
---
builtin/replace.c | 112 +++---
1 file c
Make each_reflog_ent_fn take two struct object_id pointers instead of
two pointers to unsigned char. Convert the various callbacks to use
struct object_id as well. Also, rename fsck_handle_reflog_sha1 to
fsck_handle_reflog_oid.
Signed-off-by: brian m. carlson
---
builtin/fsck.c | 16
Signed-off-by: brian m. carlson
---
builtin/clone.c | 10 +-
1 file changed, 5 insertions(+), 5 deletions(-)
diff --git a/builtin/clone.c b/builtin/clone.c
index 3f63edbbf9..b4c929bb8a 100644
--- a/builtin/clone.c
+++ b/builtin/clone.c
@@ -681,7 +681,7 @@ static void update_head(const st
In addition to converting to struct object_id, write some hardcoded
buffer sizes in terms of GIT_SHA1_RAWSZ.
Signed-off-by: brian m. carlson
---
builtin/fast-export.c | 58 +--
1 file changed, 29 insertions(+), 29 deletions(-)
diff --git a/builtin
The current code for reflog entries uses a lot of hard-coded constants,
making it hard to read and modify. Use parse_oid_hex and two temporary
variables to simplify the code and reduce the use of magic constants.
Signed-off-by: brian m. carlson
---
refs/files-backend.c | 11 ++-
1 file
On Sun, Feb 19, 2017 at 2:33 PM, Linus Torvalds
wrote:
> On Fri, Feb 17, 2017 at 9:27 PM, Junio C Hamano wrote:
>>
>> I just got bitten by a fallout. I have
>>
>> $ git recent --help
>> `git recent' is aliased to `log --oneline --branches --no-merges \
>> --source --since=3.week
On Fri, Feb 17, 2017 at 9:27 PM, Junio C Hamano wrote:
>
> I just got bitten by a fallout. I have
>
> $ git recent --help
> `git recent' is aliased to `log --oneline --branches --no-merges \
> --source --since=3.weeks'
>
> but now the branch names are shown at the end, which defe
Use of 'iff' may be confusing to people not familiar with this term.
Improving the --normalize option's documentation to remove the use of
'iff', and clearly describe what happens when the condition is not met.
---
Documentation/git-check-ref-format.txt | 6 +++---
1 file changed, 3 insertions(+)
Thanks all for the feedback.
On 2017-02-19 21:40, Philip Oakley wrote:
> For those not familiar with 'iff', then a change to the doc is worthwhile.
Exactly. Not being a native English speaker, I had never seen 'iff' used
before. Now that you guys have pointed me to its meaning I guess it
makes se
Add a hint for script writers where additional quoting can be configured.
Signed-off-by: Andreas Heiduk
---
Documentation/git-ls-files.txt | 3 ++-
1 file changed, 2 insertions(+), 1 deletion(-)
diff --git a/Documentation/git-ls-files.txt b/Documentation/git-ls-files.txt
index 446209e..19e0636
Jeff Hostetler writes:
> I looked at doing this, but I didn't think the complexity and overhead to
> forward search for peers at the current level didn't warrant the limited
> gains.
It seems that I wasn't clear what I meant. I didn't mean anything
complex like what you said.
Just something s
Jeff Hostetler writes:
>> But the other Jeff sounded like a follow-up was to follow shortly if
>> not imminent so I decided to allocate my time on other topics still
>> only on the list first while waiting to see what happens.
>
> Sorry, I was out of the office for a family emergency on Thursday
Acked-by: Phillip Sz
> Signed-off-by: Ralf Thielow
> ---
> po/de.po | 750
> ++-
> 1 file changed, 409 insertions(+), 341 deletions(-)
>
> diff --git a/po/de.po b/po/de.po
> index 2326da1fd..e9c86f548 100644
> --- a/po/de.po
> +++ b/
Hi all,
I am trying to make url..insteadOf work on the URLs inside
.gitmodules, but it won't work (applying it to the repo itself works
fine, to the config setting seems to be fine).
I do not want to modify .gitmodules: It is maintained upstream.
I cannot simply reconfigure submodule..url: t
Do you need a loan to pay up bill or to start a business? Email Us
From: "Jeff King"
On Sun, Feb 19, 2017 at 12:20:33AM -, Philip Oakley wrote:
> Normalize 'refname' by removing any leading slash (`/`)
> characters and collapsing runs of adjacent slashes between
> - name components into a single slash. Iff the normalized
> + name components into a sing
Hi,
A draft of a new Git Rev News edition is available here:
https://github.com/git/git.github.io/blob/master/rev_news/drafts/edition-24.md
Everyone is welcome to contribute in any section either by editing the
above page on GitHub and sending a pull request, or by commenting on
this GitHub is
On Sun, Feb 19, 2017 at 11:05 AM, Alex Hoffman wrote:
>> Then you must adjust your definition of "good": All commits that do not have
>> the feature, yet, are "good": since they do not have the feature in the
>> first place, they cannot have the breakage that you found in the feature.
>>
>> That i
> Then you must adjust your definition of "good": All commits that do not have
> the feature, yet, are "good": since they do not have the feature in the
> first place, they cannot have the breakage that you found in the feature.
>
> That is exactly the situation in your original example! But you co
"Vanderhoof, Tzadik" writes:
>> From: Duy Nguyen [mailto:pclo...@gmail.com]
>>
>> I face this "problem" every day, but most editors nowadays have block-
>> based editing that would allow you to remove a column of "+/-"
>> easily. At least it has not bothered me to think of improving it.
>
> Woul
Translate 241 messages came from git.pot update in 673bfad09
(l10n: git.pot: v2.12.0 round 1 (239 new, 15 removed)) and a4d94835a
(l10n: git.pot: v2.12.0 round 2 (2 new)).
Signed-off-by: Ralf Thielow
---
po/de.po | 750 ++-
1 file chang
Hi Phillip,
thanks for review!
Am 17. Februar 2017 um 22:56 schrieb Phillip Sz :
>> #: remote.c:2092
>> #, c-format
>> msgid "Your branch is ahead of '%s' by %d commit.\n"
>> msgid_plural "Your branch is ahead of '%s' by %d commits.\n"
>> -msgstr[0] "Ihr Branch ist vor '%s' um %d Commit.\n"
>
Am 19.02.2017 um 12:32 schrieb Alex Hoffman:
The assumption that there is no transition from bad to good in the
graph did not hold in my example and it does not hold when a feature
was recently introduced and gets broken relative shortly afterwards.
Then you must adjust your definition of "good
On Sun, Feb 19, 2017 at 12:32 PM, Alex Hoffman wrote:
>> At the end of the git-bisect man page (in the SEE ALSO section) there
>> is a link to
>> https://github.com/git/git/blob/master/Documentation/git-bisect-lk2009.txt
>> which has a lot of details about how bisect works.
>
> Thanks for pointin
Below is a correction of the first proposed algorithm:
>--o1--o2--o3--G --X1
>\\
> x1--x2--x3--x4--X2--B--
> \ /
> y1--y2--y3
>
Step 1a. (Unchanged) keep only the commits that:
a) are ancestor of the "bad" commit (including the "bad" commit
> At the end of the git-bisect man page (in the SEE ALSO section) there
> is a link to
> https://github.com/git/git/blob/master/Documentation/git-bisect-lk2009.txt
> which has a lot of details about how bisect works.
>
Thanks for pointing out the SEE ALSO section. I think it makes sense
to includ
Now that stash_push is used in the no verb form of stash, allow
specifying the command line for this form as well. Always use -- to
disambiguate pathspecs from other non-option arguments.
Also make git stash -p an alias for git stash push -p. This allows
users to use git stash -p .
Signed-off-b
Introduce a new git stash push verb in addition to git stash save. The
push verb is used to transition from the current command line arguments
to a more conventional way, in which the message is given as an argument
to the -m option.
This allows us to have pathspecs at the end of the command line
Refactor the internal stash_create function to use a -m flag for
specifying the message and -u flag to indicate whether untracked files
should be added to the stash.
This makes it easier to pass a pathspec argument to stash_create in the
next patch.
The user interface for git stash create stays t
While working on a repository, it's often helpful to stash the changes
of a single or multiple files, and leave others alone. Unfortunately
git currently offers no such option. git stash -p can be used to work
around this, but it's often impractical when there are a lot of changes
over multiple f
Currently there is no test showing the expected behaviour of git stash
create's command line arguments. Add a test for that to show the
current expected behaviour and to make sure future refactorings don't
break those expectations.
Signed-off-by: Thomas Gummerer
---
t/t3903-stash.sh | 18 ++
Now that we have stash_push, which accepts pathspec arguments, use
it instead of stash_save in git stash without any additional verbs.
Previously we allowed git stash -- -message, which is no longer allowed
after this patch. Messages starting with a hyphen was allowed since
3c2eb80f, ("stash: sim
Thanks Junio and Peff for comments on the last round.
Changes since then:
- removed mention of the "new form" of git stash create from the
Documentation.
- Changed documentation for git stash without a verb, mentioning
stash -p now being an alias for git stash push -p and that -- can be
use
On 02/17, Jeff King wrote:
> On Fri, Feb 17, 2017 at 10:41:41PM +, Thomas Gummerer wrote:
>
> > Now that stash_push is used in the no verb form of stash, allow
> > specifying the command line for this form as well. Always use -- to
> > disambiguate pathspecs from other non-option arguments.
>
On 02/17, Jeff King wrote:
> On Fri, Feb 17, 2017 at 10:41:38PM +, Thomas Gummerer wrote:
>
> > Refactor the internal stash_create function to use a -m flag for
> > specifying the message and -u flag to indicate whether untracked files
> > should be added to the stash.
> >
> > This makes it e
You are a recipient to Mrs Julie Leach Donation of $3 million USD. Contact
( julieleac...@gmail.com ) for claims.
58 matches
Mail list logo