On Thu, May 25, 2017 at 3:55 PM, Ben Peart wrote:
>
>
> On 5/24/2017 6:54 AM, Christian Couder wrote:
>>>
>>> Design
>>> ~~
>>>
>>> A new git hook (query-fsmonitor) must exist and be enabled
>>> (core.fsmonitor=true) that takes a time_t formatted as a string and
>>> outputs to stdout all files
---
Documentation/git-stash.txt | 8
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/Documentation/git-stash.txt b/Documentation/git-stash.txt
index 70191d06b69e..3899d36b2bab 100644
--- a/Documentation/git-stash.txt
+++ b/Documentation/git-stash.txt
@@ -233,7 +233,7 @@ retu
Hi Stefan,
On 26/05/17 01:50 PM, Stefan Beller wrote:
> On Thu, May 25, 2017 at 8:15 PM, Liam Beguin wrote:
>> Hi Johannes,
>>
>> Johannes Schindelin writes:
>>> The commands used to be indented, and it is nice to look at, but when we
>>> transform the SHA-1s, the indentation is removed. So let'
On 26/05/17 18:07, Stefan Beller wrote:
> On Fri, May 26, 2017 at 9:31 AM, Ramsay Jones
> wrote:
>> Hmm, I'm not sure which documentation you are referring to,
>
> Quite likely our fine manual pages. ;)
>
>foreach [--recursive]
>Evaluates an arbitrary shell command in each
Am 26.05.2017 um 17:17 schrieb Prathamesh Chavan:
+ argv_array_pushf(&cp.env_array, "path=%s", list_item->name);
Not good! On Windows, environment variables are case insensitive. The
environment variable "path" has a very special purpose, although it is
generally spelled "PATH" (actuall
Remove a test line that's exactly the same as the preceding
line.
This was brought in in commit feabcc173b ("Integrate wildmatch to
git", 2012-10-15), these tests are originally copied from rsync.git,
but the duplicate line was never present there, so must have just
snuck in during integration wit
On 05/26, Johannes Sixt wrote:
> Am 26.05.2017 um 17:17 schrieb Prathamesh Chavan:
> >+argv_array_pushf(&cp.env_array, "path=%s", list_item->name);
>
> Not good! On Windows, environment variables are case insensitive.
> The environment variable "path" has a very special purpose, although
> it
On Mon, May 22, 2017 at 7:40 PM, Stefan Beller wrote:
> v4:
> * interdiff to v3 (what is currently origin/sb/diff-color-move) below.
> * renamed the "buffered_patch_line" to "diff_line". Originally I planned
> to not carry the "line" part as it can be a piece of a line as well.
> But for the i
When a patch consists mostly of moving blocks of code around, it can
be quite tedious to ensure that the blocks are moved verbatim, and not
undesirably modified in the move. To that end, color blocks that are
moved within the same patch differently. For example (OM, del, add,
and NM are different c
On 26/05/17 22:54, Johannes Sixt wrote:
> Am 26.05.2017 um 17:17 schrieb Prathamesh Chavan:
>> +argv_array_pushf(&cp.env_array, "path=%s", list_item->name);
>
> Not good! On Windows, environment variables are case insensitive. The
> environment variable "path" has a very special purpose, al
adding and updating an example..
From: "Philip Oakley"
been trying to keep up...
From: "Jeff King"
On Thu, May 25, 2017 at 11:59:24AM -0400, Jeff King wrote:
The just-HEAD case could look like:
This patch does work, in the sense that upload-pack advertises the
unborn HEAD symref. But the
This is a new version of the latest patch of sb/diff-color-move.
It seems as if different people prefer different settings for the
boundary/alternate coloring, so let's have all of them. (As the
block detection is rather simple we do not need a lot of overhead
to support multiple modes).
With mor
been trying to keep up...
From: "Jeff King"
On Thu, May 25, 2017 at 11:59:24AM -0400, Jeff King wrote:
The just-HEAD case could look like:
This patch does work, in the sense that upload-pack advertises the
unborn HEAD symref. But the client doesn't actually do anything with it.
The capabili
On Thu, May 25, 2017 at 6:20 PM, Junio C Hamano wrote:
> Stefan Beller writes:
>
>> As you turn on/off normal coloring via "color.diff" and this only extends
>> the coloring scheme, I have the impression "color" is the right section.
>> Maybe color.diffStyle=[normal/enhanced] and "enhanced" means
The closest mapping from the boolean 'submodule.recurse' set to "yes"
to the variety of submodule push modes is "on-demand", so implement that.
Signed-off-by: Stefan Beller
Signed-off-by: Junio C Hamano
---
builtin/push.c | 4
t/t5531-deep-submodule-push.sh | 21 ++
In a later patch we want to introduce a config option to trigger the
submodule recursing by default. As this option should be available and
uniform across all commands that deal with submodules we'd want to test
for this option in the submodule update library.
So instead of calling the whole test
In builtin/grep.c we parse the config before evaluating the command line
options. This makes the task of teaching grep to respect the new config
option 'submodule.recurse' very easy by just parsing that option.
As an alternative I had implemented a similar structure to treat
submodules as the fetc
The callback function is essentially duplicated 3 times. Remove all
of them and offer a new callback function, that lives in submodule.c
By putting the callback function there, we no longer need the function
'set_config_update_recurse_submodules', nor duplicate the global variable
in each builtin
Any command that understands '--recurse-submodules' can have its
default changed to true, by setting the new 'submodule.recurse'
option.
This patch includes read-tree/checkout/reset for working tree
manipulating commands. Later patches will cover other commands.
Signed-off-by: Stefan Beller
---
For commands that take revisions and pathspecs, magic
pathspecs like ":(exclude)foo" require the user to specify
a disambiguating "--", since they do not match a file in the
filesystem, like:
git grep foo -- :(exclude)bar
This makes them more annoying to use than they need to be.
We loosened th
v2:
* A reroll of sb/submodule-blanket-recursive.
* This requires ab/grep-preparatory-cleanup
* It changed a lot from v1, as in v1 the tests did not work,
hence the code was broken. Now it actually works.
* it also includes grep, fetch, push in addition to plain working tree
manipulators.
Tha
Signed-off-by: Stefan Beller
---
builtin/fetch.c | 7 +++
t/t5526-fetch-submodules.sh | 10 ++
2 files changed, 17 insertions(+)
diff --git a/builtin/fetch.c b/builtin/fetch.c
index 5f2c2ab23e..c1ec3b03c3 100644
--- a/builtin/fetch.c
+++ b/builtin/fetch.c
@@ -73,6 +73,13
The looks_like_pathspec() check is much cheaper than
check_filename(), which actually stats the file. Since
either is sufficient for our return value, we should do the
cheaper one first, potentially short-circuiting the other.
Signed-off-by: Jeff King
---
Probably doesn't matter, but it bugged me
The command line option for '--recurse-submodules' is implemented
using an OPTION_CALLBACK, which takes both the callback (that sets
the file static global variable) as well as passes the same file
static global variable to the option parsing machinery to assign it.
This is fixed in this commit by
The .gitmodules file is not supposed to have all the options available,
that are available in the configuration so separate it out.
A configuration option such as the hypothetical submodule.color.diff
that determines in which color a submodule change is printed,
is a very user specific thing, that
We special-case "git log :/foo" to work when "foo" exists in
the working tree. But :^ (and its alias :!) do not get the
same treatment, requiring the user to supply a
disambiguating "--". Let's make them work without requiring
the user to type the "--".
Signed-off-by: Jeff King
---
setup.c
We handle arguments with the ":/" pathspec magic specially,
making sure the name exists at the top-level. We'll want to
handle more pathspec magic in future patches, so let's do a
little rearranging to make that easier.
Instead of relying on an if/else cascade to avoid the
prefix_filename() call,
This avoids some magic numbers (and we'll be adding more
similar calls in a minute).
Signed-off-by: Jeff King
---
setup.c | 5 ++---
1 file changed, 2 insertions(+), 3 deletions(-)
diff --git a/setup.c b/setup.c
index 000ffa810..f2a8070bd 100644
--- a/setup.c
+++ b/setup.c
@@ -137,10 +137,9 @@
The DWIM magic in check_filename() doesn't just recognize
":/". It actually makes sure that the file it points to
exists. t4208 checks only the case where the path is
present, not the opposite. Since the next patches will be
touching this area, let's add a test to make sure it
continues working.
S
On Fri, May 26, 2017 at 09:24:32AM -0400, Jeff King wrote:
> The middle ground would be to replicate a simple subset of the rules in
> verify_filename(). If we assume that all arguments with ":(" are
> pathspecs (which seem rather unlikely to have false positives), then
> that leaves only a few sh
On Fri, May 26, 2017 at 07:36:54PM +0200, Andreas Heiduk wrote:
> The function `set_ident` in `filter-branch` exported the variables
> GIT_(AUTHOR|COMMITTER)_(NAME|EMAIL|DATE) at least since 6f6826c52b in 2007.
> Therefore the filter scripts don't need to re-eport them again.
Some old shells keep
The following commands work as expected (using commit b06d364310
in the git://git.kernel.org/pub/scm/git/git.git repo as test case):
$ export TZ=Europe/Berlin
$ git --no-pager log -1 --pretty="%ad" --date=iso b06d364310
2017-05-09 23:26:02 +0900
$ git --no-pager log -1 --pretty="%ad" --date=iso-lo
On Thu, May 25, 2017 at 8:15 PM, Liam Beguin wrote:
> Hi Johannes,
>
> Johannes Schindelin writes:
>> The commands used to be indented, and it is nice to look at, but when we
>> transform the SHA-1s, the indentation is removed. So let's do away with it.
>>
>> For the moment, at least: when we wil
The function `set_ident` in `filter-branch` exported the variables
GIT_(AUTHOR|COMMITTER)_(NAME|EMAIL|DATE) at least since 6f6826c52b in 2007.
Therefore the filter scripts don't need to re-eport them again.
Signed-off-by: Andreas Heiduk
---
Documentation/git-filter-branch.txt | 5 +
1 file c
On Fri, May 26, 2017 at 9:31 AM, Ramsay Jones
wrote:
>
>
> On 26/05/17 16:17, Prathamesh Chavan wrote:
>> According to the documentation about git-submodule foreach subcommand's
>> $path variable:
>> $path is the name of the submodule directory relative to the superproject
>>
>> But it was observe
On 05/26, Prathamesh Chavan wrote:
> This aims to make git-submodule foreach a builtin. This is the very
> first step taken in this direction. Hence, 'foreach' is ported to
> submodule--helper, and submodule--helper is called from git-submodule.sh.
> The code is split up to have one function to obt
On 05/26, Prathamesh Chavan wrote:
> Additional test cases added to the submodule-foreach test suite
> to check the submodule foreach --recursive behavior from a
> subdirectory as this was missing from the test suite.
>
> Helped-by: Brandon Williams
> Mentored-by: Christian Couder
> Mentored-by:
On 26/05/17 16:17, Prathamesh Chavan wrote:
> According to the documentation about git-submodule foreach subcommand's
> $path variable:
> $path is the name of the submodule directory relative to the superproject
>
> But it was observed when the value of the $path value deviates from this
> for t
Hi! Thanks for the responses (I hope reply-all isn't bad mailing-list
etiquette? Feel free to yell at with a direct reply!). For whatever it's
worth, as a random user, here's my thoughts:
On Sat, May 20, 2017 at 2:07 AM, Jeff King wrote:
> On Fri, May 19, 2017 at 11:55:34PM +0200, Dennis Kaarsema
On Fri, May 26, 2017 at 8:17 AM, Prathamesh Chavan wrote:
> Additional test cases added to the submodule-foreach test suite
> to check the submodule foreach --recursive behavior from a
> subdirectory as this was missing from the test suite.
As this demonstrates the fixture of the first patch,
thi
On Fri, May 26, 2017 at 8:17 AM, Prathamesh Chavan wrote:
> This aims to make git-submodule foreach a builtin.
Cool. I reviewed the code and only have one minor nit.
> +static void runcommand_in_submodule(const struct cache_entry *list_item,
> + void *cb_data)
>
On 5/26/2017 5:47 AM, Ævar Arnfjörð Bjarmason wrote:
On Wed, May 24, 2017 at 3:12 PM, Christian Couder
wrote:
On Thu, May 18, 2017 at 10:13 PM, Ben Peart wrote:
This hook script integrates the new fsmonitor capabilities of git with
the cross platform Watchman file watching service. To use t
Additional test cases added to the submodule-foreach test suite
to check the submodule foreach --recursive behavior from a
subdirectory as this was missing from the test suite.
Helped-by: Brandon Williams
Mentored-by: Christian Couder
Mentored-by: Stefan Beller
Signed-off-by: Prathamesh Chavan
This aims to make git-submodule foreach a builtin. This is the very
first step taken in this direction. Hence, 'foreach' is ported to
submodule--helper, and submodule--helper is called from git-submodule.sh.
The code is split up to have one function to obtain all the list of
submodules. This functi
According to the documentation about git-submodule foreach subcommand's
$path variable:
$path is the name of the submodule directory relative to the superproject
But it was observed when the value of the $path value deviates from this
for the nested submodules when the is run from a subdirectory.
On Mon, May 15, 2017 at 1:05 PM, SZEDER Gábor wrote:
> Due to limitations/bugs in the current implementation, some
> configuration variables specified via 'git clone -c var=val' (or 'git
> -c var=val clone') are ignored during the initial fetch and checkout.
>
> Let the users know which configurat
On Fri, May 26, 2017 at 12:04:03PM +0200, SZEDER Gábor wrote:
> > but given that it lazy-parses in
> > some cases, it feels a little dangerous.
>
> I'm not sure about lazy parsing.
> remote_get() returns a fully-parsed, cached struct remote instance
> without re-reading the configuration, so all
On Fri, May 26, 2017 at 11:13:55AM +0900, Junio C Hamano wrote:
> >- git log :^foo
> > (when "^foo" exists in your index)
> >
> > The same logic applies; it would continue to work. And
> > ditto for any other weird filenames in your index like
> > "(attr)foo".
>
> "git
GREETINGS,
I AM BORTE ,MY DOCTOR JUST CONFIRM THAT I HAVE OVARIAN CANCER AND I
HAVE FEW WEEKS TO LIVE, SO I HAVE DECIDED TO DONATE EVERYTHING I HAVE
TO THE ORPHANAGE AND THE POOR WIDOWS THROUGH YOU IN YOUR AREA.PLEASE
KINDLY REPLY ME ONLY ON MY EMAIL ADDRES HERE (missboteogotai@gmail.
com) A
***.
Peace be with you,
Gladly seek for your sincere help in setting up a Charitable
Organization to help the less privileged, old aged and vulnerable
people under your care,
It is my desire to use my late husband wealth of $3,000,000.00 to set
up a charity foundation to help the needy and the l
On Tue, May 16, 2017 at 1:07 AM, Jeff King wrote:
>> @@ -989,6 +994,10 @@ int cmd_clone(int argc, const char **argv, const char
>> *prefix)
>> strbuf_reset(&value);
>>
>> remote = remote_get(option_origin);
>> + REALLOC_ARRAY(remote->fetch, remote->fetch_refspec_nr + 1);
>> +
Ævar Arnfjörð Bjarmason writes:
> To be clear the point of my mail was not to say "I can't think of a
> way to support both of these things, help!", obviously we can continue
> to maintain two codepaths. The point was to raise the idea that we
> could simply remove the more complex & doomed to fo
On Wed, May 24, 2017 at 3:12 PM, Christian Couder
wrote:
> On Thu, May 18, 2017 at 10:13 PM, Ben Peart wrote:
>> This hook script integrates the new fsmonitor capabilities of git with
>> the cross platform Watchman file watching service. To use the script:
>>
>> Download and install Watchman from
On Wed, May 24, 2017 at 4:22 PM, Robert Dailey wrote:
> Is it possible to hide decorated refs in `git log` even if they are
> reachable from the refs I'm actually interested in seeing the logs of?
>
> For example, if I do `git log --graph --decorate --oneline --branches
> 'feature/*'`, I'd like to
On Fri, May 26, 2017 at 2:58 AM, Junio C Hamano wrote:
> Ævar Arnfjörð Bjarmason writes:
>
>> I think it's a pointless distraction to start speculating in this
>> commit message what we're going to do with --debug it if it ever
>> starts emitting some debugging information at pattern execution ti
55 matches
Mail list logo