Hi Christoph,
> From: Christoph Hellwig, Sent: Monday, June 17, 2019 3:54 PM
>
> On Mon, Jun 17, 2019 at 06:46:33AM +, Yoshihiro Shimoda wrote:
> > > can_merge seems a little too generic a name to me. Maybe can_iommu_merge?
> >
> > I'll fix the name. Also, only the device_iommu_mapped() cond
On Mon, Jun 17, 2019 at 06:46:33AM +, Yoshihiro Shimoda wrote:
> > can_merge seems a little too generic a name to me. Maybe can_iommu_merge?
>
> I'll fix the name. Also, only the device_iommu_mapped() condition wiil cause
> a problem on iommu=pt [1]. So, I'll add another condition here.
Inst
Hi Christoph,
> From: Christoph Hellwig, Sent: Friday, June 14, 2019 4:25 PM
>
> On Thu, Jun 13, 2019 at 07:20:15PM +0900, Yoshihiro Shimoda wrote:
> > +static unsigned int mmc_get_max_segments(struct mmc_host *host)
> > +{
> > + return host->can_merge ? BLK_MAX_SEGMENTS : host->max_segs;
> > +
Hi Wolfram-san,
> From: Wolfram Sang, Sent: Friday, June 14, 2019 4:59 AM
>
> > - blk_queue_max_segments(mq->queue, host->max_segs);
> > + /* blk_queue_can_use_iommu_merging() should succeed if can_merge = 1 */
> > + if (host->can_merge &&
> > + !blk_queue_can_use_iommu_merging(mq->qu
> > + host->can_merge = 1;
> > + else
> > + host->can_merge = 0;
> > +
>
> can_merge seems a little too generic a name to me. Maybe can_iommu_merge?
Ack.
signature.asc
Description: PGP signature
On Thu, Jun 13, 2019 at 07:20:15PM +0900, Yoshihiro Shimoda wrote:
> +static unsigned int mmc_get_max_segments(struct mmc_host *host)
> +{
> + return host->can_merge ? BLK_MAX_SEGMENTS : host->max_segs;
> +}
Note that BLK_MAX_SEGMENTS is really a little misnamed, it just
is a BLK_DEFAULT_SEGME
> - blk_queue_max_segments(mq->queue, host->max_segs);
> + /* blk_queue_can_use_iommu_merging() should succeed if can_merge = 1 */
> + if (host->can_merge &&
> + !blk_queue_can_use_iommu_merging(mq->queue, mmc_dev(host)))
> + WARN_ON(1);
> + blk_queue_max_segmen