[PATCH 1/2] KVM: x86: extract guest running logic from __vcpu_run

2015-02-06 Thread Paolo Bonzini
Rename the old __vcpu_run to vcpu_run, and extract its main logic to a new function. The next patch will add a new early-exit condition to __vcpu_run, avoid extra indentation. Signed-off-by: Paolo Bonzini --- arch/x86/kvm/x86.c | 67 +- 1 file

Re: [PATCH 1/2] KVM: x86: extract guest running logic from __vcpu_run

2015-02-09 Thread David Matlack
On Fri, Feb 6, 2015 at 4:16 AM, Paolo Bonzini wrote: > Rename the old __vcpu_run to vcpu_run, and extract its main logic > to a new function. > > The next patch will add a new early-exit condition to __vcpu_run, > avoid extra indentation. > > Signed-off-by: Paolo Bonzini > --- Reviewed-by: David

Re: [PATCH 1/2] KVM: x86: extract guest running logic from __vcpu_run

2015-02-09 Thread Rik van Riel
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 On 02/06/2015 07:16 AM, Paolo Bonzini wrote: > Rename the old __vcpu_run to vcpu_run, and extract its main logic > to a new function. > > The next patch will add a new early-exit condition to __vcpu_run, > avoid extra indentation. > > Signed-off-by

Re: [PATCH 1/2] KVM: x86: extract guest running logic from __vcpu_run

2015-02-10 Thread Paolo Bonzini
On 09/02/2015 23:44, David Matlack wrote: >> > >> > +static inline int __vcpu_run(struct kvm *kvm, struct kvm_vcpu *vcpu) > Kind of confusing function body given the name. Maybe put > >if (vcpu->arch.mp_state == KVM_MP_STATE_RUNNABLE && >!vcpu->arch.apf.halted) >