Re: [patch 1/1] x86_64: Rename KDB_VECTOR to DEBUGGER_VECTOR

2005-08-08 Thread Keith Owens
On Tue, 9 Aug 2005 01:16:37 +0200, Andi Kleen <[EMAIL PROTECTED]> wrote: >On Tue, Aug 09, 2005 at 09:14:52AM +1000, Keith Owens wrote: >> On Mon, 8 Aug 2005 21:28:50 +0200, >> Andi Kleen <[EMAIL PROTECTED]> wrote: >> >On Mon, Aug 08, 2005 at 12:27:10PM -0700, Tom Rini wrote: >> >> { >> >> unsi

Re: [patch 1/1] x86_64: Rename KDB_VECTOR to DEBUGGER_VECTOR

2005-08-08 Thread Andi Kleen
On Tue, Aug 09, 2005 at 09:14:52AM +1000, Keith Owens wrote: > On Mon, 8 Aug 2005 21:28:50 +0200, > Andi Kleen <[EMAIL PROTECTED]> wrote: > >On Mon, Aug 08, 2005 at 12:27:10PM -0700, Tom Rini wrote: > >> { > >>unsigned int icr = APIC_DM_FIXED | shortcut | vector | dest; > >> - if (vector ==

Re: [patch 1/1] x86_64: Rename KDB_VECTOR to DEBUGGER_VECTOR

2005-08-08 Thread Keith Owens
On Mon, 8 Aug 2005 21:28:50 +0200, Andi Kleen <[EMAIL PROTECTED]> wrote: >On Mon, Aug 08, 2005 at 12:27:10PM -0700, Tom Rini wrote: >> { >> unsigned int icr = APIC_DM_FIXED | shortcut | vector | dest; >> -if (vector == KDB_VECTOR) >> +if (vector == NMI_VECTOR) >> icr =

Re: [patch 1/1] x86_64: Rename KDB_VECTOR to DEBUGGER_VECTOR

2005-08-08 Thread Andi Kleen
On Mon, Aug 08, 2005 at 12:27:10PM -0700, Tom Rini wrote: > { > unsigned int icr = APIC_DM_FIXED | shortcut | vector | dest; > - if (vector == KDB_VECTOR) > + if (vector == NMI_VECTOR) > icr = (icr & (~APIC_VECTOR_MASK)) | APIC_DM_NMI; That if () should be removed sin

[patch 1/1] x86_64: Rename KDB_VECTOR to DEBUGGER_VECTOR

2005-08-08 Thread Tom Rini
CC: Andi Kleen <[EMAIL PROTECTED]>, Keith Owens <[EMAIL PROTECTED]> The existing hook from KDB in the IPI code is really just a hook for the NMI vector. We rename the vector thusly and then it's up to the debugger to handle things from default_do_nmi(). --- linux-2.6.13-rc6-trini/arch/x86_64/k