Re: [net-next resend PATCH 1/6] net: cpsw: enhance pinctrl support

2013-05-22 Thread David Miller
From: Mugunthan V N Date: Tue, 21 May 2013 15:24:58 +0530 > + priv->pins_default = pinctrl_lookup_state(priv->pinctrl, > + PINCTRL_STATE_DEFAULT); This is not indented correctly. Argument on the second, and subsequent, lines of a function

Re: [BISECTED] 3.10-rc1 OMAP1 GPIO IRQ regression

2013-05-22 Thread Aaro Koskinen
On Tue, May 21, 2013 at 08:37:16PM +0100, Jon Hunter wrote: > On 21/05/13 18:39, Aaro Koskinen wrote: > > On Mon, May 20, 2013 at 10:46:21AM -0700, Tony Lindgren wrote: > >> * Tony Lindgren [130516 14:50]: > >>> * Aaro Koskinen [130516 14:05]: > On Thu, May 16, 2013 at 11:09:34AM -0700, Tony

Re: [GIT PULL] ARM: OMAP2+: hwmod/serial: fix DT case

2013-05-22 Thread Olof Johansson
On Tue, May 21, 2013 at 11:11:10AM -0700, Tony Lindgren wrote: > Olof, > > Care to pull this into your fixes directly? Pulled, thanks. -Olof -- To unsubscribe from this list: send the line "unsubscribe linux-omap" in the body of a message to majord...@vger.kernel.org More majordomo info at htt

[RFC/RFT] ARM: dts: add minimal DT support for Nokia N950 & N9

2013-05-22 Thread Aaro Koskinen
Add minimal DT support for Nokia N950 & N9. The basic boot works. I can connect to both devices with USB networking & ssh. dmesg output looks OK. Functionality compared to the legacy board file: - MMC not detected - reason unknown, any tips welcome - OneNAND missing completely S

[RFC PATCH 2/4] PM / AVS: Introduce support for OMAP Voltage Controller(VC) with device tree nodes

2013-05-22 Thread Nishanth Menon
Texas Instrument's OMAP SoC generations since OMAP3-5 introduced an TI custom hardware block to better facilitate and standardize integration of Power Management ICs which communicate over I2C called Voltage Controller(VC). This is an specialized hardware block meant to support PMIC chips and is c

[RFC PATCH 1/4] regulator: Introduce OMAP regulator to control PMIC over VC/VP

2013-05-22 Thread Nishanth Menon
Texas Instrument's OMAP SoC generations since OMAP3-5 introduced an TI custom hardware block to better facilitate and standardize integration of Power Management ICs which communicate over I2C. In fact, many custom PMICs were designed to be usable over this interface. On the other hand, generic PM

[RFC PATCH 3/4] PM / AVS: Introduce support for OMAP Voltage Processor(VP) with device tree nodes

2013-05-22 Thread Nishanth Menon
Texas Instrument's OMAP SoC generations since OMAP3-5 introduced an TI custom hardware block to better facilitate and standardize integration of Power Management ICs which communicate over I2C called Voltage Processor(VP). This is an specialized hardware block meant to support PMIC chips only over

[RFC PATCH 4/4] HACK: OMAP4460/TPS/TWL/PandaBoardES - Enable VP regulator for cpufreq

2013-05-22 Thread Nishanth Menon
This is just an example patch - Tested on PandaBoard-ES OMAP4460 Connectivity is as follows: VP_MPU -> VC_CH_MPU -> VC -> TPS62361 TPS62631 Voltage register selection is done using GPIO (GPIO_WK 7) VP_IVA -> VC_CH_IVA -> VC -> TWL6030/vcore2 VP_CORE -> VC_CH_CORE -> VC -> TWL6030/vcore1 NOT-Signed

[RFC PATCH 0/4] regulator/OMAP: support VC/VP support in dts

2013-05-22 Thread Nishanth Menon
Hi, Texas Instrument's OMAP Processor have a dedicated hardware module which is customised to operate with Power Management IC(PMIC) over an dedicated I2C. The communication involves a few SoC internal modules as follows: PMIC - The power management chip on the dedicated I2C (sometimes called I2C_

Re: [PATCH 1/5] ARM: dts: OMAP2+: use #include for all device trees

2013-05-22 Thread Florian Vaussard
Hi Tony, On 05/22/2013 05:40 PM, Tony Lindgren wrote: * Florian Vaussard [130522 07:33]: Replace /include/ by #include for OMAP2+ DT, in order to use the C pre-processor, making use of #define features possible. This is good, but let's use it with case. Probably the best use for this right n

Re: [PATCH 2/5] ARM: dts: OMAP2+: create a DT header for GPIO

2013-05-22 Thread Stephen Warren
On 05/22/2013 10:00 AM, Florian Vaussard wrote: > Hello Stephan, Tony, > > Thank you for your reviews. > > On 05/22/2013 05:34 PM, Tony Lindgren wrote: >> * Stephen Warren [130522 08:32]: >>> On 05/22/2013 08:27 AM, Florian Vaussard wrote: Define the OMAP_GPIO macro to conveniently use GPIO

Re: [PATCH 3/5] ARM: dts: OMAP2+: convert DT files to use the new OMAP_GPIO macro

2013-05-22 Thread Florian Vaussard
Hi Stepen, Thank you for your review, On 05/22/2013 05:28 PM, Stephen Warren wrote: On 05/22/2013 08:27 AM, Florian Vaussard wrote: Use OMAP_GPIO(), in conjunction with standard GPIO flags, to enhance the readability of DT GPIOs. diff --git a/arch/arm/boot/dts/omap3-beagle-xm.dts b/arch/ar

Re: [PATCH 2/5] ARM: dts: OMAP2+: create a DT header for GPIO

2013-05-22 Thread Florian Vaussard
Hello Stephan, Tony, Thank you for your reviews. On 05/22/2013 05:34 PM, Tony Lindgren wrote: * Stephen Warren [130522 08:32]: On 05/22/2013 08:27 AM, Florian Vaussard wrote: Define the OMAP_GPIO macro to conveniently use GPIO inside OMAP DT. For example: gpios = <&gpio6 3 0>; /* G

Re: [PATCH 1/5] ARM: dts: OMAP2+: use #include for all device trees

2013-05-22 Thread Tony Lindgren
* Florian Vaussard [130522 07:33]: > Replace /include/ by #include for OMAP2+ DT, in order to use the > C pre-processor, making use of #define features possible. This is good, but let's use it with case. Probably the best use for this right now is to add defines for the mux modes from mach-omap2/

Re: [PATCH 4/5] ARM: dts: OMAP3: fix incorrect notation for musb-hdrc interrupt

2013-05-22 Thread Tony Lindgren
* Florian Vaussard [130522 07:33]: > On OMAP3, the INTC interrupt controller has only 1 cell. > > Signed-off-by: Florian Vaussard Thanks a similar fix is already queued up and on it's way to mainline tree. Regards, Tony > --- > arch/arm/boot/dts/omap3.dtsi |2 +- > 1 files changed, 1 in

Re: [PATCH 2/5] ARM: dts: OMAP2+: create a DT header for GPIO

2013-05-22 Thread Tony Lindgren
* Stephen Warren [130522 08:32]: > On 05/22/2013 08:27 AM, Florian Vaussard wrote: > > Define the OMAP_GPIO macro to conveniently use GPIO inside OMAP DT. > > For example: > > > > gpios = <&gpio6 3 0>; /* GPIO 163 */ > > > > can be replaced by > > > > gpios = OMAP_GPIO(163, 0); > > >

Re: [PATCH 3/5] ARM: dts: OMAP2+: convert DT files to use the new OMAP_GPIO macro

2013-05-22 Thread Stephen Warren
On 05/22/2013 08:27 AM, Florian Vaussard wrote: > Use OMAP_GPIO(), in conjunction with standard GPIO flags, to enhance the > readability of DT GPIOs. > diff --git a/arch/arm/boot/dts/omap3-beagle-xm.dts > b/arch/arm/boot/dts/omap3-beagle-xm.dts > index e0ce823..e773a5e 100644 > --- a/arch/arm/boo

Re: [PATCH 2/5] ARM: dts: OMAP2+: create a DT header for GPIO

2013-05-22 Thread Stephen Warren
On 05/22/2013 08:27 AM, Florian Vaussard wrote: > Define the OMAP_GPIO macro to conveniently use GPIO inside OMAP DT. > For example: > > gpios = <&gpio6 3 0>; /* GPIO 163 */ > > can be replaced by > > gpios = OMAP_GPIO(163, 0); > diff --git a/include/dt-bindings/gpio/omap-gpio.h >

[PATCH 5/5] ARM: dts: OMAP4/5: use existing constants for IRQs

2013-05-22 Thread Florian Vaussard
Use the constants defined in include/dt-bindings/interrupt-controller/ to enhance readability. Signed-off-by: Florian Vaussard --- arch/arm/boot/dts/omap4-panda-common.dtsi |8 +- arch/arm/boot/dts/omap4-sdp.dts |6 +- arch/arm/boot/dts/omap4-var-som.dts |4 +- arch/a

[PATCH 4/5] ARM: dts: OMAP3: fix incorrect notation for musb-hdrc interrupt

2013-05-22 Thread Florian Vaussard
On OMAP3, the INTC interrupt controller has only 1 cell. Signed-off-by: Florian Vaussard --- arch/arm/boot/dts/omap3.dtsi |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/arch/arm/boot/dts/omap3.dtsi b/arch/arm/boot/dts/omap3.dtsi index 15049b8..0f3be20 100644 --- a/arch

[PATCH 0/5] ARM: dts: OMAP2+: use preprocessor for device trees

2013-05-22 Thread Florian Vaussard
Hello, Following a similar proposal by Stephen Warren for tegra [1], this series makes use of the C preprocessor when compiling OMAP DT files, and accomplishes some improvements to improve overall readability. Patch 2 creates a header file to define the OMAP_GPIO() macro, used by patch 3 to make

[PATCH 3/5] ARM: dts: OMAP2+: convert DT files to use the new OMAP_GPIO macro

2013-05-22 Thread Florian Vaussard
Use OMAP_GPIO(), in conjunction with standard GPIO flags, to enhance the readability of DT GPIOs. Signed-off-by: Florian Vaussard --- arch/arm/boot/dts/omap2.dtsi |2 ++ arch/arm/boot/dts/omap3-beagle-xm.dts |4 ++-- arch/arm/boot/dts/omap3-beagle.dts|6 +++--

[PATCH 2/5] ARM: dts: OMAP2+: create a DT header for GPIO

2013-05-22 Thread Florian Vaussard
Define the OMAP_GPIO macro to conveniently use GPIO inside OMAP DT. For example: gpios = <&gpio6 3 0>; /* GPIO 163 */ can be replaced by gpios = OMAP_GPIO(163, 0); Signed-off-by: Florian Vaussard --- include/dt-bindings/gpio/omap-gpio.h | 289

[PATCH 1/5] ARM: dts: OMAP2+: use #include for all device trees

2013-05-22 Thread Florian Vaussard
Replace /include/ by #include for OMAP2+ DT, in order to use the C pre-processor, making use of #define features possible. Signed-off-by: Florian Vaussard --- arch/arm/boot/dts/omap2.dtsi |2 +- arch/arm/boot/dts/omap2420-h4.dts |2 +- arch/arm/boot/dts/omap2420.dtsi

Re: [PATCH] arm: configs: omap2plus_defconfig: enable USB bits which work

2013-05-22 Thread Roger Quadros
On 05/14/2013 05:09 PM, Kevin Hilman wrote: > Felipe Balbi writes: > >> those USB bits work fine, so we can enable them >> safely. Plus, without USB_PHY EHCI wouldn't work >> and it would take quite a few bogus error reports >> until all users got the new changes. >> >> Signed-off-by: Felipe Balb

Re: [PATCH] ARM: OMAP3: Fix iva2_pwrdm settings for 3703

2013-05-22 Thread Yegor Yefremov
On Tue, May 21, 2013 at 8:20 PM, Kevin Hilman wrote: > Tony Lindgren writes: > >> * Yegor Yefremov [130517 14:34]: >>> On Fri, May 17, 2013 at 8:56 PM, Mark A. Greer >>> wrote: >>> > On Thu, May 16, 2013 at 12:19:20PM +0200, Yegor Yefremov wrote: >>> >> On 15.05.2013 23:50, Mark A. Greer wrote