Re: [PATCH 04/24] scsi: introduce sdev_prefix_printk()

2014-10-06 Thread Hannes Reinecke
On 10/03/2014 06:31 PM, Ewan Milne wrote: On Thu, 2014-10-02 at 18:37 +, Elliott, Robert (Server Storage) wrote: -Original Message- From: Hannes Reinecke [mailto:h...@suse.de] ... diff --git a/drivers/scsi/sd.h b/drivers/scsi/sd.h index 4c3ab83..c01dc89 100644 ---

Re: [PATCH 21/24] scsi: simplify scsi_log_(send|completion)

2014-10-06 Thread Hannes Reinecke
On 10/03/2014 04:32 AM, Elliott, Robert (Server Storage) wrote: -Original Message- From: Hannes Reinecke [mailto:h...@suse.de] Sent: Wednesday, 01 October, 2014 1:23 AM To: James Bottomley Cc: Christoph Hellwig; linux-scsi@vger.kernel.org; Elliott, Robert (Server Storage); Hannes

[no subject]

2014-10-06 Thread Suman Tripathi
commit 72f79f9e35bd3f78ee8853f2fcacaa197d23ebac upstream. Subject: [PATCH 3.16 350/357] ahci_xgene: Removing NCQ support from the APM X-Gene SoC AHCI SATA Host Controller driver. This patch removes the NCQ support from the APM X-Gene SoC AHCI Host Controller driver as it doesn't support it.

Re: [PATCH 23/29] atari_scsi: Convert to platform device

2014-10-06 Thread Finn Thain
On Sun, 5 Oct 2014, Michael Schmitz wrote: On Fri, 3 Oct 2014, Geert Uytterhoeven wrote: + if (ATARIHW_PRESENT(TT_SCSI)) { + atari_scsi_reg_read = atari_scsi_tt_reg_read; + atari_scsi_reg_write = atari_scsi_tt_reg_write; + } else

Re: [PATCH -next] scsi: ufs: fix configuring power mode after UIC link down

2014-10-06 Thread Akinobu Mita
Hi Subhash, 2014-10-06 7:38 GMT+09:00 Subhash Jadavani subha...@codeaurora.org: Hi Akinobu, Thanks for the patch. After you reported the issue, I was looking through our driver to make sure that why this issue was not catched and in fact it's already have a fix internally and it was yet to

Re: [PATCH 23/29] atari_scsi: Convert to platform device

2014-10-06 Thread Michael Schmitz
Hi Finn, Can these be handled through the platform_device's resources? I don't know. Should be possible - I've seen that used in the ISP116x HCD driver (arch-dependent post-register access delay function passed via platform data). Yes, possible, but is it

Re: [PATCH 23/29] atari_scsi: Convert to platform device

2014-10-06 Thread Geert Uytterhoeven
On Mon, Oct 6, 2014 at 9:05 AM, Finn Thain fth...@telegraphics.com.au wrote: + if (IS_A_TT()) + instance-irq = IRQ_TT_MFP_SCSI; + else + instance-irq = IRQ_NONE; platform_device resource? If I thought it possible to parameterize

[PATCH 07/26] fas216: Return DID_ERROR for incomplete data transfer

2014-10-06 Thread Hannes Reinecke
fas216 returns DID_BAD_TARGET for an incomplete data transfer. The midlayer uses DID_BAD_TARGET to signal a non-existing or not reachable target. So we should rather be using DID_ERROR here. Reviewed-by: Robert Elliott elli...@hp.com Reviewed-by: Christoph Hellwig h...@lst.de Signed-off-by:

[PATCHv6 00/26] scsi logging update (the boring part)

2014-10-06 Thread Hannes Reinecke
Hi all, here is now the sixth iteration of my scsi logging update. For this I've fixed all issues noticed by Robert Elliott (thanks, Robert!) and Ewan Milne. And added the 'Reviewed-by:' tags where appropriate. Hannes Reinecke (26): Remove scsi_cmd_print_sense_hdr() sd: Remove

[PATCH 10/26] scsi: stop decoding if scsi_normalize_sense() fails

2014-10-06 Thread Hannes Reinecke
If scsi_normalize_sense() fails we couldn't decode the sense buffer, and the scsi_sense_hdr fields are invalid. For those cases we should rather dump the sense buffer and not try to decode invalid fields. Reviewed-by: Robert Elliott elli...@hp.com Reviewed-by: Christoph Hellwig h...@lst.de

[PATCH 08/26] fas216: Update logging messages

2014-10-06 Thread Hannes Reinecke
Update logging messages to use dev_printk() variants for correct device annotations. Reviewed-by: Robert Elliott elli...@hp.com Reviewed-by: Christoph Hellwig h...@lst.de Signed-off-by: Hannes Reinecke h...@suse.de --- drivers/scsi/arm/fas216.c | 26 +++--- 1 file changed, 11

[PATCH 04/26] scsi: introduce sdev_prefix_printk()

2014-10-06 Thread Hannes Reinecke
Like scmd_printk(), but the device name is passed in as a string. Can be used by eg ULDs which do not have access to the scsi_cmnd structure. Reviewed-by: Robert Elliott elli...@hp.com Reviewed-by: Christoph Hellwig h...@lst.de Signed-off-by: Hannes Reinecke h...@suse.de --- drivers/scsi/ch.c

[PATCH 11/26] scsi: do not decode sense extras

2014-10-06 Thread Hannes Reinecke
Currently we're only decoding sense extras for tape devices. And even there only for fixed format sense formats. As this is of rather limited use in the general case we should be stop trying to decode sense extras; the tape driver does its own decoding anyway. Reviewed-by: Robert Elliott

[PATCH 01/26] Remove scsi_cmd_print_sense_hdr()

2014-10-06 Thread Hannes Reinecke
Unused. Reviewed-by: Robert Elliott elli...@hp.com Reviewed-by: Christoph Hellwig h...@infradead.org Signed-off-by: Hannes Reinecke h...@suse.de --- drivers/scsi/constants.c | 14 -- include/scsi/scsi_dbg.h | 2 -- 2 files changed, 16 deletions(-) diff --git

[PATCH 05/26] scsi: Use sdev as argument for sense code printing

2014-10-06 Thread Hannes Reinecke
We should be using the standard dev_printk() variants for sense code printing. Reviewed-by: Robert Elliott elli...@hp.com Reviewed-by: Christoph Hellwig h...@infradead.org Signed-off-by: Hannes Reinecke h...@suse.de --- drivers/scsi/53c700.c | 2 +- drivers/scsi/ch.c | 2 +-

[PATCH 09/26] 53c700: remove scsi_print_sense() usage

2014-10-06 Thread Hannes Reinecke
The 53c700 driver would be using scsi_print_sense() in a debug statement, which was never compiled in. Plus the same information can get retrieved with logging. So remove it. Reviewed-by: Robert Elliott elli...@hp.com Reviewed-by: Christoph Hellwig h...@lst.de Signed-off-by: Hannes Reinecke

[PATCH 06/26] acornscsi: use scsi_print_command()

2014-10-06 Thread Hannes Reinecke
Update acornscsi to use scsi_print_command() instead of the underscore version and use scmd_printk() in acornscsi_done(). This will add correct device annotations in the resulting message. And we should be using set_host_byte() for setting the final result. Reviewed-by: Robert Elliott

[PATCH 16/26] scsi: consolidate opcode lookup in scsi_opcode_sa_name()

2014-10-06 Thread Hannes Reinecke
Consolidate the CDB opcode lookup in scsi_opcode_sa_name(), so that we don't have to call several functions to figure out the CDB opcode string. Reviewed_by: Robert Elliott elli...@hp.com Reviewed-by: Christoph Hellweg h...@lst.de Signed-off-by: Hannes Reinecke h...@suse.de ---

[PATCH 21/26] scsi: simplify scsi_log_(send|completion)

2014-10-06 Thread Hannes Reinecke
Simplify scsi_log_(send|completion) by externalizing scsi_mlreturn_string() and always print the command address. Reviewed-by: Robert Elliott elli...@hp.com Reviewed-by: Christoph Hellwig h...@lst.de Signed-off-by: Hannes Reinecke h...@suse.de --- drivers/scsi/constants.c | 39

[PATCH 26/26] scsi: correct return values for .eh_abort_handler implementations

2014-10-06 Thread Hannes Reinecke
The .eh_abort_handler needs to return SUCCESS, FAILED, or FAST_IO_FAIL. So fixup all callers to adhere to this requirement. Signed-off-by: Hannes Reinecke h...@suse.de --- drivers/scsi/NCR5380.c| 2 +- drivers/scsi/aha1740.c| 2 +- drivers/scsi/esas2r/esas2r_main.c | 2 +-

[PATCH 20/26] sd: Cleanup logging

2014-10-06 Thread Hannes Reinecke
Open-code scsi_print_result in sd.c, and cleanup logging to not print duplicate informations. With that we can remove scsi_show_result in constants.c Reviewed-by: Robert Elliott elli...@hp.com Reviewed-by: Christoph Hellwig h...@lst.de Signed-off-by: Hannes Reinecke h...@suse.de ---

[PATCH 03/26] aha152x: Debug output update and whitespace cleanup

2014-10-06 Thread Hannes Reinecke
Remove all uncommented debugging code and move all printk() statements over to dev_printk(). And while we're at it we should be doing a whitespace cleanup, too. Reviewed-by: Robert Elliott elli...@hp.com Reviewed-by: Christoph Hellwig h...@lst.de Signed-off-by: Hannes Reinecke h...@suse.de ---

[PATCH 18/26] scsi: Remove scsi_print_command when calling abort

2014-10-06 Thread Hannes Reinecke
Calling scsi_print_command should not be necessary during abort; if the information is required one should enable scsi logging. Reviewed-by: Robert Elliott elli...@hp.com Reviewed-by: Christoph Hellwig h...@lst.de Signed-off-by: Hannes Reinecke h...@suse.de --- drivers/scsi/53c700.c| 4

[PATCH 19/26] scsi: separate out scsi_(host|driver)byte_string()

2014-10-06 Thread Hannes Reinecke
Export functions for later use. Reviewed-by: Robert Elliott elli...@hp.com Reviewed-by: Christoph Hellwig h...@lst.de Signed-off-by: Hannes Reinecke h...@suse.de --- drivers/scsi/constants.c | 58 include/scsi/scsi_dbg.h | 2 ++ 2 files changed,

[PATCH 23/26] scsi: use shost argument in scsi_eh_prt_fail_stats

2014-10-06 Thread Hannes Reinecke
The EH statistics are per host, so we should be using shost_printk() here. Suggested-by: Robert Elliott elli...@hp.com Reviewed-by: Robert Elliott elli...@hp.com Reviewed-by: Christoph Hellwig h...@lst.de Signed-off-by: Hannes Reinecke h...@suse.de --- drivers/scsi/scsi_error.c | 2 +- 1 file

[PATCH 15/26] scsi: merge print_opcode_name()

2014-10-06 Thread Hannes Reinecke
Instead of having two versions of print_opcode_name() we should be consolidating them into one version. Reviewed-by: Robert Elliott elli...@hp.com Reviewed-by: Christoph Hellwig h...@lst.de Signed-off-by: Hannes Reinecke h...@suse.de --- drivers/scsi/constants.c | 90

[PATCH 14/26] Implement scsi_opcode_sa_name

2014-10-06 Thread Hannes Reinecke
Implement a lookup array for SERVICE ACTION commands instead of hardcoding it in a large switch statement. Reviewed-by: Robert Elliott elli...@hp.com Reviewed-by: Christoph Hellwig h...@infradead.org Signed-off-by: Hannes Reinecke h...@suse.de --- drivers/scsi/constants.c | 131

[PATCH 12/26] scsi: use 'bool' as return value for scsi_normalize_sense()

2014-10-06 Thread Hannes Reinecke
Convert scsi_normalize_sense() and frieds to return 'bool' instead of an integer. Reviewed-by: Robert Elliott elli...@hp.com Reviewed-by: Yoshihiro Yunomae yoshihiro.yunomae...@hitachi.com Reviewed-by: Christoph Hellwig h...@lst.de Signed-off-by: Hannes Reinecke h...@suse.de ---

[PATCH 13/26] scsi: remove scsi_print_status()

2014-10-06 Thread Hannes Reinecke
Last caller is gone, so we can remove it. Reviewed-bt: Robert Elliott elli...@hp.com Reviewed-by: Christoph Hellwig h...@lst.de Signed-off-by: Hannes Reinecke h...@suse.de --- drivers/scsi/constants.c | 35 --- include/scsi/scsi_dbg.h | 1 - 2 files changed, 36

[PATCH 17/26] scsi: repurpose the last argument from print_opcode_name()

2014-10-06 Thread Hannes Reinecke
print_opcode_name() was only ever called with a '0' argument from LLDDs and ULDs which were _not_ supporting variable length CDBs, so the 'if' clause was never triggered. Instead we should be using the last argument to specify the cdb length to avoid accidental overflow when reading the cdb

[PATCH 22/26] scsi: fixup logging messages in scsi_error.c

2014-10-06 Thread Hannes Reinecke
Use the matching scope for logging messages to allow for better command tracing. Suggested-by: Robert Elliott elli...@hp.com Reviewed-by: Robert Elliott elli...@hp.com Reviewed-by: Christoph Hellwig h...@lst.de Signed-off-by: Hannes Reinecke h...@suse.de --- drivers/scsi/hosts.c | 4 +--

[PATCH 25/26] scsi: check for corrent return code in scsi_eh_abort_cmds()

2014-10-06 Thread Hannes Reinecke
scsi_try_to_abort_cmd() might return SUCCESS, FAILED, or FAST_IO_FAIL. So just checking for FAILED will treat FAST_IO_FAIL as SUCCESS, which is wrong. Signed-off-by: Hannes Reinecke h...@suse.de --- drivers/scsi/scsi_error.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

Re: [PATCH 01/29] ncr5380: Use printk() not pr_debug()

2014-10-06 Thread Hannes Reinecke
On 10/02/2014 08:56 AM, Finn Thain wrote: Having defined NDEBUG, and having set the console log level, I'd like to see some output. Don't use pr_debug(), it's annoying to have to define DEBUG as well. Signed-off-by: Finn Thain fth...@telegraphics.com.au --- Use of pr_debug() here was a

Re: [PATCH 02/29] ncr5380: Remove unused hostdata fields

2014-10-06 Thread Hannes Reinecke
On 10/02/2014 08:56 AM, Finn Thain wrote: Remove unused fields from hostdata structs declared with the NCR5380_implementation_fields macro. Signed-off-by: Finn Thain fth...@telegraphics.com.au Reviewed-by: Hannes Reinecke h...@suse.de Cheers, Hannes -- Dr. Hannes Reinecke

Re: [PATCH 07/29] ncr5380: Cleanup TAG_NEXT and TAG_NONE macros

2014-10-06 Thread Hannes Reinecke
On 10/02/2014 08:56 AM, Finn Thain wrote: Both atari_NCR5380.c and sun3_NCR5380.c core drivers #undef TAG_NONE and then redefine it. But the original definition is unused because NCR5380.c lacks support for tagged queueing. So just define it once. The TAG_NEXT macro only appears in the

Re: [PATCH 03/29] ncr5380: Fix compiler warnings and __setup options

2014-10-06 Thread Hannes Reinecke
On 10/02/2014 08:56 AM, Finn Thain wrote: Some __setup() options mentioned in Documentation/scsi don't work because a few lines of code went missing sometime since Linux 2.4. Fix the options and thus fix some compiler warnings for both the non-modular case, CC drivers/scsi/dtc.o

Re: [PATCH 04/29] ncr5380: Remove unused macros

2014-10-06 Thread Hannes Reinecke
On 10/02/2014 08:56 AM, Finn Thain wrote: Some macros are never evaluated (i.e. FOO, USLEEP, SCSI2 and USE_WRAPPER; and in some drivers, NCR5380_intr and NCR5380_proc_info). DRIVER_SETUP serves no purpose anymore. Remove these macro definitions. Signed-off-by: Finn Thain

Re: [PATCH 28/29] atari_NCR5380: Refactor Falcon special cases

2014-10-06 Thread Hannes Reinecke
On 10/02/2014 08:56 AM, Finn Thain wrote: Make the atari_NCR5380.c core driver usable by sun3_scsi, mac_scsi and others by moving some of the Falcon-specific code out of the core driver: !IS_A_TT, atari_read_overruns and falcon_dont_release. Replace these with hostdata variables and flags.

Re: [PATCH 8/8] IB/srp: Add multichannel support

2014-10-06 Thread Bart Van Assche
On 10/02/14 19:30, Christoph Hellwig wrote: Also if we want to merge scsi LLDDs that can take advantage of multiqueue support it would probably be best if I take this via the SCSI tree. Sending these patches to you is fine with me, at least if Roland agrees. Bart. -- To unsubscribe from

Re: [PATCH 28/29] atari_NCR5380: Refactor Falcon special cases

2014-10-06 Thread Finn Thain
On Mon, 6 Oct 2014, Hannes Reinecke wrote: On 10/02/2014 08:56 AM, Finn Thain wrote: Make the atari_NCR5380.c core driver usable by sun3_scsi, mac_scsi and others by moving some of the Falcon-specific code out of the core driver: !IS_A_TT, atari_read_overruns and falcon_dont_release.

Re: [PATCH 07/29] ncr5380: Cleanup TAG_NEXT and TAG_NONE macros

2014-10-06 Thread Finn Thain
On Mon, 6 Oct 2014, Hannes Reinecke wrote: On 10/02/2014 08:56 AM, Finn Thain wrote: Both atari_NCR5380.c and sun3_NCR5380.c core drivers #undef TAG_NONE and then redefine it. But the original definition is unused because NCR5380.c lacks support for tagged queueing. So just define it

Re: [PATCH 28/29] atari_NCR5380: Refactor Falcon special cases

2014-10-06 Thread Ondrej Zary
On Monday 06 October 2014, Finn Thain wrote: On Mon, 6 Oct 2014, Hannes Reinecke wrote: On 10/02/2014 08:56 AM, Finn Thain wrote: Make the atari_NCR5380.c core driver usable by sun3_scsi, mac_scsi and others by moving some of the Falcon-specific code out of the core driver: !IS_A_TT,

Re: [dm-devel] [PATCH 1/1] multipath-tools: Change path checker for IBM IPR devices

2014-10-06 Thread Brian King
On 10/01/2014 07:51 AM, Christoph Hellwig wrote: Unfortunately the patch wasn't quite correct - all TEST_UNIT_READY commands are sent as BLOCK_PC, so this would basically revert James' original fix for the SATL case. Am I right to assume you only need the call to scsi_dh-check_sense and not

Re: [PATCH 21/26] scsi: simplify scsi_log_(send|completion)

2014-10-06 Thread Ewan Milne
Rats. I found another case of (null) appearing in the log messages where I think you really just wanted no text at all to appear. Sorry I didn't find it last time along with the other one... -Ewan On Mon, 2014-10-06 at 11:01 +0200, Hannes Reinecke wrote: Simplify scsi_log_(send|completion) by

Re: [PATCH v2 7/7] driver-core: add preferred async probe option for built-in and modules

2014-10-06 Thread Tejun Heo
Hello, Luis. The patchset generally looks good to me. Please feel free to add Reviewed-by: Tejun Heo t...@kernel.org A question below. On Fri, Oct 03, 2014 at 02:44:43PM -0700, Luis R. Rodriguez wrote: + bus.enable_kern_async=1 [KNL] + This tells the kernel

Re: [PATCH v2 7/7] driver-core: add preferred async probe option for built-in and modules

2014-10-06 Thread Luis R. Rodriguez
On Mon, Oct 06, 2014 at 04:19:26PM -0400, Tejun Heo wrote: Hello, Luis. The patchset generally looks good to me. Please feel free to add Reviewed-by: Tejun Heo t...@kernel.org Will do. A question below. On Fri, Oct 03, 2014 at 02:44:43PM -0700, Luis R. Rodriguez wrote: +

Re: [PATCH v2 7/7] driver-core: add preferred async probe option for built-in and modules

2014-10-06 Thread Dmitry Torokhov
Hi Luis, On Fri, Oct 03, 2014 at 02:44:43PM -0700, Luis R. Rodriguez wrote: From: Luis R. Rodriguez mcg...@suse.com At times we may wish to express the desire to prefer to have a device driver probe asynchronously by default. We cannot simply enable all device drivers to do this without

Re: [PATCH v2 7/7] driver-core: add preferred async probe option for built-in and modules

2014-10-06 Thread Tejun Heo
Hello, On Mon, Oct 06, 2014 at 10:36:27PM +0200, Luis R. Rodriguez wrote: Do we intend to keep this param permanently? Isn't this more of a temp tool to be used during development? If so, maybe we should make that clear with __DEVEL__ too? As its designed right now no, its not a temp

Re: [PATCH v2 7/7] driver-core: add preferred async probe option for built-in and modules

2014-10-06 Thread Luis R. Rodriguez
On Mon, Oct 06, 2014 at 05:01:18PM -0400, Tejun Heo wrote: Hello, On Mon, Oct 06, 2014 at 10:36:27PM +0200, Luis R. Rodriguez wrote: Do we intend to keep this param permanently? Isn't this more of a temp tool to be used during development? If so, maybe we should make that clear with

[PATCH] target/file: fix inclusive vfs_fsync_range() end

2014-10-06 Thread Zach Brown
Both of the file target's calls to vfs_fsync_range() got the end offset off by one. The range is inclusive, not exclusive. It would sync a bit more data than was required. The sync path already tested the length of the range and fell back to LLONG_MAX so I copied that pattern in the rw path.