Re: best method to debug problems with amdump runs?

2007-09-27 Thread Craig Dewick

On Thu, 27 Sep 2007, Jean-Louis Martineau wrote:


Craig Dewick wrote:

What's the resolution for localhost?
What's the resolution for 127.0.0.1?
Do you have a route for 127.0.0.1 and localhost?


I'm not sure what you're asking with these. 8-)

ping localhost


1 [EMAIL PROTECTED] #> ping localhost
localhost is alive


ping 127.0.0.1


2 [EMAIL PROTECTED] #> ping 127.0.0.1
127.0.0.1 is alive


grep localhost /etc/hosts


3 [EMAIL PROTECTED] #> grep localhost /etc/hosts
127.0.0.1 localhost

I've checked /etc/hosts on the tape host system before and didn't think 
anything of that since I know all the other networking functions of my 
systems work fine, even though I'm not too sure if my Cisco's 
configuration is 'optimal'.


If it helps with determining networking problems, these are the relevant 
bits of my Cisco's config file:


!
interface FastEthernet0/0
 ip address 192.168.0.1 255.255.255.0 secondary
 ip address 192.168.1.1 255.255.255.0 secondary
 ip address 203.14.152.49 255.255.255.224
 ip access-group 101 in
 ip accounting output-packets
 no ip mroute-cache
 speed auto
 full-duplex
 no cdp enable
!
interface BRI0/0
 description old ORBnet main link
 shutdown 
!

interface Ethernet1/0
 description "ethernet to DSL router"
 ip address 10.1.1.2 255.0.0.0
 ip verify unicast reverse-path
 ip accounting output-packets
 no ip mroute-cache
 full-duplex
!
ip default-gateway 10.1.1.1
no ip http server
no ip classless
ip route 203.14.152.32 255.255.255.224 FastEthernet0/0
ip route 192.168.0.0 255.255.255.0 FastEthernet0/0
ip route 192.168.1.0 255.255.255.0 FastEthernet0/0
ip route 0.0.0.0 0.0.0.0 10.1.1.1
ip route 10.0.0.0 255.0.0.0 Ethernet1/0
!

The 'ip access-group' statement in the FastEthernet0/0 definition is 
redundant (I don't have access group 101 set up in the config file) and 
I've removed that this morning, but I don't believe it would be the 
problem. If it is, I'll know later on when I try a manual run of 'amdump' 
with the extra debugging turned on.


Craig.

--
Post by Craig Dewick (tm). Web @ "http://lios.apana.org.au/~cdewick";.
Email 2 "[EMAIL PROTECTED]". SunShack @ "http://www.sunshack.org";
Galleries @ "http://www.sunshack.org/gallery2";. Also lots of tech data, etc.
Sun Microsystems webring at "http://n.webring.com/hub?ring=sunmicrosystemsu";.


Re: best method to debug problems with amdump runs?

2007-09-27 Thread Jean-Louis Martineau

Craig Dewick wrote:

What's the resolution for localhost?
What's the resolution for 127.0.0.1?
Do you have a route for 127.0.0.1 and localhost?


I'm not sure what you're asking with these. 8-)

ping localhost
ping 127.0.0.1
grep localhost /etc/hosts



Re: best method to debug problems with amdump runs?

2007-09-27 Thread Craig Dewick

On Thu, 27 Sep 2007, Jean-Louis Martineau wrote:


Craig, Can you fix the reply-to field of your email message.


Oops my boo-boo with PINE. Fixed up now. 8-) Sorry about that.


You can set 'debug_auth 1' in amand.conf, debug files will show more details.
The problem is not with the planner, but with the dumper-chunker socket.


Thanks I'll try out the debug config option, and yes I agree with you that 
the problem is with the communication between those two sub-utilities of 
Amanda.



Post dumper and chunker debug files.


Ok once I get some I'll post them. Might do a manual 'amdump' run with the 
debug option enabled.



What's the resolution for localhost?
What's the resolution for 127.0.0.1?
Do you have a route for 127.0.0.1 and localhost?


I'm not sure what you're asking with these. 8-)

Craig.

--
Post by Craig Dewick (tm). Web @ "http://lios.apana.org.au/~cdewick";.
Email 2 "[EMAIL PROTECTED]". SunShack @ "http://www.sunshack.org";
Galleries @ "http://www.sunshack.org/gallery2";. Also lots of tech data, etc.
Sun Microsystems webring at "http://n.webring.com/hub?ring=sunmicrosystemsu";.


Re: best method to debug problems with amdump runs?

2007-09-27 Thread Jean-Louis Martineau

Craig, Can you fix the reply-to field of your email message.

You can set 'debug_auth 1' in amand.conf, debug files will show more 
details.

The problem is not with the planner, but with the dumper-chunker socket.
Post dumper and chunker debug files.

What's the resolution for localhost?
What's the resolution for 127.0.0.1?
Do you have a route for 127.0.0.1 and localhost?

Jean-Louis

Craig Dewick wrote:


I'm wondering if there are any additional debugging features that 
could be used to delve more into why the nightly amdump runs cannot do 
their thing and instead report network errors. amcheck has just run 
from cron a short while ago and reported no errors. Could there be 
something in the amanda-2.5.2p1 code that is hitting against some sort 
of Solaris specific quirk? My Sun boxes are all running Solaris 9.


Some hints would be helpful at this stage in the process. Everything 
else appears to work fine. I might try dropping back to an earlier 
2.5.x version or even a late 2.4.x version to see if it makes any 
difference, should any of you feel that's a worthwhile approach to 
narrowing down what the actual problem is.


Regards,

Craig.