Re: [PATCH] drm/amd/display: fix DCC settings for DCN3

2021-09-30 Thread Joshua Ashton

Thanks for the info!

- Joshie ✨

On 9/30/21 18:33, Marek Olšák wrote:
The name is kind of correct. It means "64B with no 128B cache line 
straddling", which really means just 64B independent blocks with a small 
modification to support DCC image stores.  They are not true 128B 
independent blocks.


Marek

On Thu, Sep 30, 2021 at 12:35 PM Joshua Ashton > wrote:


Can we please add documentation for this enum?

This was not necessarily a typo, but me misunderstanding and stuff it
working in my testing.

I guess I don't understand why hubp_ind_block_64b_no_128bcl is for 64b
&& 128b when it specifically says "no_128" in the name.

Is there something about it I am missing or is it just misleading
naming?

- Joshie ✨

On 9/30/21 17:14, Marek Olšák wrote:
 > I've also amended the version bump that I forgot to do:
 >
 > -#define KMS_DRIVER_MINOR       43
 > +#define KMS_DRIVER_MINOR       44
 >
 > Marek
 >
 > On Thu, Sep 30, 2021 at 12:06 PM Alex Deucher
mailto:alexdeuc...@gmail.com>
 > >> wrote:
 >
 >     Acked-by: Alex Deucher mailto:alexander.deuc...@amd.com>
 >     >>
 >
 >     On Thu, Sep 30, 2021 at 11:50 AM Marek Olšák
mailto:mar...@gmail.com>
 >     >> wrote:
 >      >
 >      > Hi,
 >      >
 >      > Just discovered this typo. Please review.
 >      >
 >      > Thanks,
 >      > Marek
 >



Re: [PATCH] drm/amd/display: fix DCC settings for DCN3

2021-09-30 Thread Marek Olšák
The name is kind of correct. It means "64B with no 128B cache line
straddling", which really means just 64B independent blocks with a small
modification to support DCC image stores.  They are not true 128B
independent blocks.

Marek

On Thu, Sep 30, 2021 at 12:35 PM Joshua Ashton  wrote:

> Can we please add documentation for this enum?
>
> This was not necessarily a typo, but me misunderstanding and stuff it
> working in my testing.
>
> I guess I don't understand why hubp_ind_block_64b_no_128bcl is for 64b
> && 128b when it specifically says "no_128" in the name.
>
> Is there something about it I am missing or is it just misleading naming?
>
> - Joshie ✨
>
> On 9/30/21 17:14, Marek Olšák wrote:
> > I've also amended the version bump that I forgot to do:
> >
> > -#define KMS_DRIVER_MINOR   43
> > +#define KMS_DRIVER_MINOR   44
> >
> > Marek
> >
> > On Thu, Sep 30, 2021 at 12:06 PM Alex Deucher  > > wrote:
> >
> > Acked-by: Alex Deucher  > >
> >
> > On Thu, Sep 30, 2021 at 11:50 AM Marek Olšák  > > wrote:
> >  >
> >  > Hi,
> >  >
> >  > Just discovered this typo. Please review.
> >  >
> >  > Thanks,
> >  > Marek
> >
>
>


Re: [PATCH] drm/amd/display: fix DCC settings for DCN3

2021-09-30 Thread Joshua Ashton

Can we please add documentation for this enum?

This was not necessarily a typo, but me misunderstanding and stuff it 
working in my testing.


I guess I don't understand why hubp_ind_block_64b_no_128bcl is for 64b 
&& 128b when it specifically says "no_128" in the name.


Is there something about it I am missing or is it just misleading naming?

- Joshie ✨

On 9/30/21 17:14, Marek Olšák wrote:

I've also amended the version bump that I forgot to do:

-#define KMS_DRIVER_MINOR       43
+#define KMS_DRIVER_MINOR       44

Marek

On Thu, Sep 30, 2021 at 12:06 PM Alex Deucher > wrote:


Acked-by: Alex Deucher mailto:alexander.deuc...@amd.com>>

On Thu, Sep 30, 2021 at 11:50 AM Marek Olšák mailto:mar...@gmail.com>> wrote:
 >
 > Hi,
 >
 > Just discovered this typo. Please review.
 >
 > Thanks,
 > Marek





Re: [PATCH] drm/amd/display: fix DCC settings for DCN3

2021-09-30 Thread Marek Olšák
I've also amended the version bump that I forgot to do:

-#define KMS_DRIVER_MINOR   43
+#define KMS_DRIVER_MINOR   44

Marek

On Thu, Sep 30, 2021 at 12:06 PM Alex Deucher  wrote:

> Acked-by: Alex Deucher 
>
> On Thu, Sep 30, 2021 at 11:50 AM Marek Olšák  wrote:
> >
> > Hi,
> >
> > Just discovered this typo. Please review.
> >
> > Thanks,
> > Marek
>


Re: [PATCH] drm/amd/display: fix DCC settings for DCN3

2021-09-30 Thread Alex Deucher
Acked-by: Alex Deucher 

On Thu, Sep 30, 2021 at 11:50 AM Marek Olšák  wrote:
>
> Hi,
>
> Just discovered this typo. Please review.
>
> Thanks,
> Marek


[PATCH] drm/amd/display: fix DCC settings for DCN3

2021-09-30 Thread Marek Olšák
Hi,

Just discovered this typo. Please review.

Thanks,
Marek
From 3abee824223e214d8a74c3f1b47a24e5ea9a9a34 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Marek=20Ol=C5=A1=C3=A1k?= 
Date: Thu, 30 Sep 2021 11:13:59 -0400
Subject: [PATCH] drm/amd/display: fix DCC settings for DCN3
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

ind_block_64b_no_128bcl means INDEP_64B && INDEP_128B &&
MAX_COMPRESSED_BLOCK_SIZE == 64B. Only used by gfx10.3.

ind_block_64b means INDEP_64B && !INDEP_128B &&
MAX_COMPRESSED_BLOCK_SIZE == 64B. Only used by gfx9 and gfx10.

Signed-off-by: Marek Olšák 
---
 drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c   | 1 +
 drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c | 4 ++--
 2 files changed, 3 insertions(+), 2 deletions(-)

diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c
index df83b1f438b6..ebdb959f4e1f 100644
--- a/drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c
+++ b/drivers/gpu/drm/amd/amdgpu/amdgpu_drv.c
@@ -97,6 +97,7 @@
  * - 3.41.0 - Add video codec query
  * - 3.42.0 - Add 16bpc fixed point display support
  * - 3.43.0 - Add device hot plug/unplug support
+ * - 3.44.0 - DCN3 supports DCC independent block settings: !64B && 128B, 64B && 128B
  */
 #define KMS_DRIVER_MAJOR	3
 #define KMS_DRIVER_MINOR	43
diff --git a/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c b/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
index a399a984b8a6..49be531d68ae 100644
--- a/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
+++ b/drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c
@@ -5105,11 +5105,11 @@ fill_gfx9_plane_attributes_from_modifiers(struct amdgpu_device *adev,
 		dcc->independent_64b_blks = independent_64b_blks;
 		if (AMD_FMT_MOD_GET(TILE_VERSION, modifier) == AMD_FMT_MOD_TILE_VER_GFX10_RBPLUS) {
 			if (independent_64b_blks && independent_128b_blks)
-dcc->dcc_ind_blk = hubp_ind_block_64b;
+dcc->dcc_ind_blk = hubp_ind_block_64b_no_128bcl;
 			else if (independent_128b_blks)
 dcc->dcc_ind_blk = hubp_ind_block_128b;
 			else if (independent_64b_blks && !independent_128b_blks)
-dcc->dcc_ind_blk = hubp_ind_block_64b_no_128bcl;
+dcc->dcc_ind_blk = hubp_ind_block_64b;
 			else
 dcc->dcc_ind_blk = hubp_ind_block_unconstrained;
 		} else {
-- 
2.25.1