Method Naming Convention

2008-10-28 Thread tobi_one

Hi,

this probably is a super easy question to answer, but somehow I'm
stuck.
In the Cookbook it says on

http://book.cakephp.org/view/559/URL-Considerations-for-Controller-Names

However, the convention is that your urls are lowercase and
underscored, therefore /red_apples/go_pick is the correct form to
access the RedApplesController::goPick action

I had my methods named e.g. add_first and - in order to follow
convention - I changed this to addFirst. Now I get the error:

Error: The action add_first is not defined in controller
ExamplesController
Error: Create ExamplesController::add_first() in file: app/controllers/
examples_controller.php.

when trying to access the URL /examples/add_first

Shouldn't cake translate this to addFirst as mentioned above?
What am I missing or are the docs outdated?!

Cheers,
tobi_one

--~--~-~--~~~---~--~~
You received this message because you are subscribed to the Google Groups 
CakePHP group.
To post to this group, send email to cake-php@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/cake-php?hl=en
-~--~~~~--~~--~--~---



Re: Method Naming Convention

2008-10-28 Thread teknoid

it's true for the controller name, but not for the action name.

the docs should be updated ... ehh..

On Oct 28, 5:05 pm, tobi_one [EMAIL PROTECTED] wrote:
 Hi,

 this probably is a super easy question to answer, but somehow I'm
 stuck.
 In the Cookbook it says on

 http://book.cakephp.org/view/559/URL-Considerations-for-Controller-Names

 However, the convention is that your urls are lowercase and
 underscored, therefore /red_apples/go_pick is the correct form to
 access the RedApplesController::goPick action

 I had my methods named e.g. add_first and - in order to follow
 convention - I changed this to addFirst. Now I get the error:

 Error: The action add_first is not defined in controller
 ExamplesController
 Error: Create ExamplesController::add_first() in file: app/controllers/
 examples_controller.php.

 when trying to access the URL /examples/add_first

 Shouldn't cake translate this to addFirst as mentioned above?
 What am I missing or are the docs outdated?!

 Cheers,
 tobi_one
--~--~-~--~~~---~--~~
You received this message because you are subscribed to the Google Groups 
CakePHP group.
To post to this group, send email to cake-php@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/cake-php?hl=en
-~--~~~~--~~--~--~---



Re: Method Naming Convention

2008-10-28 Thread tobi_one

ok, many thanks for pointing this out!

On Oct 28, 10:24 pm, teknoid [EMAIL PROTECTED] wrote:
 it's true for the controller name, but not for the action name.

 the docs should be updated ... ehh..

 On Oct 28, 5:05 pm, tobi_one [EMAIL PROTECTED] wrote:

  Hi,

  this probably is a super easy question to answer, but somehow I'm
  stuck.
  In the Cookbook it says on

 http://book.cakephp.org/view/559/URL-Considerations-for-Controller-Names

  However, the convention is that your urls are lowercase and
  underscored, therefore /red_apples/go_pick is the correct form to
  access the RedApplesController::goPick action

  I had my methods named e.g. add_first and - in order to follow
  convention - I changed this to addFirst. Now I get the error:

  Error: The action add_first is not defined in controller
  ExamplesController
  Error: Create ExamplesController::add_first() in file: app/controllers/
  examples_controller.php.

  when trying to access the URL /examples/add_first

  Shouldn't cake translate this to addFirst as mentioned above?
  What am I missing or are the docs outdated?!

  Cheers,
  tobi_one

--~--~-~--~~~---~--~~
You received this message because you are subscribed to the Google Groups 
CakePHP group.
To post to this group, send email to cake-php@googlegroups.com
To unsubscribe from this group, send email to [EMAIL PROTECTED]
For more options, visit this group at 
http://groups.google.com/group/cake-php?hl=en
-~--~~~~--~~--~--~---