[OSL | CCIE_Voice] lab qos for cue to cucm..

2013-08-17 Thread Amit Sharma
anyone tell me if this is right or need changes?
configure switch 1 with policies on the 3750 switch:

1: ensure cos value 5 is mapped to dscp ef /cue signal with cs3

2: in giga int 1/0/4, make sure all incoming cue signal traffic is amrked
with cs3  and guarantee to 7k bandwidth.
Anything in excess should be first amrked down to dsco value of 8 before
being transmitted.

3. use requirements listed in the cue section to deliver teh list of
protocols to be policed.


On HQ Switch side:
-
mls qos map policed-dscp  24 to 8
mls qos map cos-dscp 0 8 16 24 32 46 48 56
mls qos

class-map match-any SUB_TO_CUE
 match access-group name SUB_TO_CUE

policy-map SUB_TO_CUE
class SUB_TO_CUE
  set ip dscp cs3
  police 8000 8000 exceed-action policed-dscp-transmit
class class-default
  trust dscp

ip access-list extended SUB_TO_CUE
 permit tcp host 142.100.64.12 eq 2748 host 142.1.66.253
 permit tcp host 142.100.64.12 eq smtp host 142.1.66.253
 permit tcp host 142.100.64.12 eq 443 host 142.1.66.253
 permit tcp host 142.100.64.12 eq 8443 host 142.1.66.253
 permit tcp host 142.100.64.12 eq www host 142.1.66.253

interface GigabitEthernet1/0/1
description R1 Trunk
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,100,102,202
switchport mode trunk
mls qos trust dscp
spanning-tree portfast trunk

interface GigabitEthernet1/0/3
description Publisher Port
switchport mode access
mls qos trust dscp
spanning-tree portfast


interface GigabitEthernet1/0/4
description Subscriber Port
service-policy input SUB_TO_CUE
switchport access vlan 100
switchport mode access
spanning-tree portfast

interface GigabitEthernet1/0/13
description *** IP Phones switchports
switchport access vlan 202
switchport mode access
switchport voice vlan 102
mls qos trust device cisco-phone
mls qos trust cos
spanning-tree portfast

interface GigabitEthernet1/0/14
description *** IP Phones switchports
switchport access vlan 202
switchport mode access
switchport voice vlan 102
mls qos trust device cisco-phone
mls qos trust cos
spanning-tree portfast

interface GigabitEthernet1/0/15
description *** IP Phones switchports
switchport access vlan 202
switchport mode access
switchport voice vlan 102
mls qos trust device cisco-phone
mls qos trust cos
spanning-tree portfast
!

=

On R3 router side:
--
-
!
class-map match-any cue_TO_sub
 match access-group name cue_TO_sub
!
policy-map cue_TO_sub
class cue_TO_sub
  set ip dscp cs3
  police 8000 8000 exceed-action policed-dscp-transmit
class class-default
  trust dscp
!
ip access-list extended cue_TO_sub
 permit tcp host 142.1.66.253 eq 2748 host 142.100.64.12
 permit tcp host 142.1.66.253 eq smtp host 142.100.64.12
 permit tcp host 142.1.66.253 eq 443 host 142.100.64.12
 permit tcp host 142.1.66.253 eq 8443 host 142.100.64.12
 permit tcp host 142.1.66.253 eq www host 142.100.64.12
!

interface serial 0/1/0:0.1 point-to-point
description serial port to HQ Router
service-policy output cue_TO_sub
!



-- 
Thanks  Regard's
Amit Sharma
___
For more information regarding industry leading CCIE Lab training, please visit 
www.ipexpert.com

Are you a CCNP or CCIE and looking for a job? Check out 
www.PlatinumPlacement.com

Re: [OSL | CCIE_Voice] CUPC

2013-08-17 Thread LorenzLGRC
Hello,
what if you push two times the '?' key on the 7941 phone?
How many rx/tx packets?



On Thu, Jul 25, 2013 at 3:12 AM, Dharambir kumar varma 
dharambi...@gmail.com wrote:

 Hi Team.

 i have one phone CUPC over internet...and one cisco 7941 phone internal..
 both registered to call manager.

 when i call from cupc to 7941 or viceversa,,ring out happens and when
 call is connected, only dead air/ No audio..
 where can i check...
 ___
 For more information regarding industry leading CCIE Lab training, please
 visit www.ipexpert.com

 Are you a CCNP or CCIE and looking for a job? Check out
 www.PlatinumPlacement.com

___
For more information regarding industry leading CCIE Lab training, please visit 
www.ipexpert.com

Are you a CCNP or CCIE and looking for a job? Check out 
www.PlatinumPlacement.com

Re: [OSL | CCIE_Voice] Transcoding Meeting Place

2013-08-17 Thread LorenzLGRC
Xcoder should be assigned to the resource not supporting G.729 codec


On Tue, Jul 23, 2013 at 7:38 PM, William Bell b...@ucguerrilla.com wrote:

 My take: The MP IP gateway needs the MRGL assigned to it.
 --
 William Bell, CCIE #38914
 blog: http://ucguerrilla.com
 twitter: @ucguerrilla




 On Jul 23, 2013, at 3:11 AM, Schmitz, Daniel wrote:

 Hi all,
 a customer has the following setup.
 ** **
 -   Across the MPLS, G.729 should be used
 -   Meeting Place is just configured for High Capacity (G.711) only***
 *
 -   CUCM has an IOS transcoder with the following configuration
 *dspfarm profile 3 transcode*
 *codec g711ulaw*
 *codec g711alaw*
 *codec g729ar8*
 *codec g729abr8*
 *codec g729r8*
 *codec g729br8*
 *maximum sessions 6*
 *associate application SCCP*
 ** **
 For some reason it is not possible to call from China to the Meeting
 Place, as soon as I allow G.711 via the SIP trunk everything works just
 fine, but with G.729 the call cannot be established.
 Which component needs the correct MRGL for the transcoding?
 ** **
 ** **
 image002.png
 ** **
 Do I miss anything?
 ** **
 Regards
 Daniel
 ** **
 Senior IT-Specialist
 Team leader Network  Communication Services
 Managed  Cloud Services
 ** **
 --

 *DIDAS Business Services GmbH* |* *Bernerstr. 38 | 60437 Frankfurt

 Tel.: +49 69-95022-327 | Fax: +49 69-95022-77327 | Mobil: +49 172-525 2383
 Mail: daniel.schm...@didas.de | Web: www.didas.de  
 AG Düsseldorf HRB 63231 | USt-ID-Nr.: DE811548338 | Geschäftsführer: Dirk
 Kiefer
 * *
 --
 ** **
 Der Inhalt dieser E-Mail ist vertraulich und ausschließlich für den
 bezeichneten Adressaten bestimmt. Wenn Sie nicht der vorgesehene Adressat
 dieser E-Mail oder dessen Vertreter sein sollten, so beachten Sie bitte,
 dass jede Form der Kenntnisnahme, Veröffentlichung, Vervielfältigung oder
 Weitergabe des Inhalts dieser E-Mail unzulässig ist. Wir bitten Sie, sich
 in diesem Fall mit dem Absender der E-Mail in Verbindung zu setzen. Wir
 möchten Sie außerdem darauf hinweisen, dass die Kommunikation per E-Mail
 über das Internet unsicher ist, da für unberechtigte Dritte grundsätzlich
 die Möglichkeit der Kenntnisnahme und Manipulation besteht.

 The information contained in this e-mail is confidential. It is intended
 solely for the addressee. Access to this e-mail by anyone else is
 unauthorized. If you are not the intended recipient, any form of
 disclosure, reproduction, distribution or any action taken or refrained
 from in reliance on it, is prohibited and may be unlawful. Please notify
 the sender immediately. We also like to inform you that communication via
 e-mail over the internet is insecure because third parties may have the
 possibility to access and manipulate e-mails.Hi
 ___
 For more information regarding industry leading CCIE Lab training, please
 visit www.ipexpert.com

 Are you a CCNP or CCIE and looking for a job? Check out
 www.PlatinumPlacement.com



 ___
 For more information regarding industry leading CCIE Lab training, please
 visit www.ipexpert.com

 Are you a CCNP or CCIE and looking for a job? Check out
 www.PlatinumPlacement.com

___
For more information regarding industry leading CCIE Lab training, please visit 
www.ipexpert.com

Are you a CCNP or CCIE and looking for a job? Check out 
www.PlatinumPlacement.com

Re: [OSL | CCIE_Voice] cue register issue with ccm

2013-08-17 Thread LorenzLGRC
if configuration is fine, try to:

disassociate CTIP and CTIRP from the CUE user and reassociate them




On Thu, Aug 8, 2013 at 6:28 PM, Amit Sharma aryan231...@gmail.com wrote:

 guys.,,
 anyone help me as i am using ipx remote racks...and always issue to
 register cue with cucm...


 i am doing all config but it is not registering with cucm...

 please tell me how can fix it?

 --
 Thanks  Regard's
 Amit Sharma


 ___
 For more information regarding industry leading CCIE Lab training, please
 visit www.ipexpert.com

 Are you a CCNP or CCIE and looking for a job? Check out
 www.PlatinumPlacement.com

___
For more information regarding industry leading CCIE Lab training, please visit 
www.ipexpert.com

Are you a CCNP or CCIE and looking for a job? Check out 
www.PlatinumPlacement.com

Re: [OSL | CCIE_Voice] Fwd: RSVP Max Sessions

2013-08-17 Thread Marcelo Augusto
max session software 1 will work with one call.

is not correct the information about two session will be used in a pre call.



On Sat, Aug 17, 2013 at 2:42 AM, IE Target myfrnd...@gmail.com wrote:


 That is something even i am not clear with

 One call = two call leg

 Practically  if we configure
maximum session software 1

 the call works?

 some where i read that two sessions will be used pre call ??

 Any comments






 ___
 For more information regarding industry leading CCIE Lab training, please
 visit www.ipexpert.com

 Are you a CCNP or CCIE and looking for a job? Check out
 www.PlatinumPlacement.com




-- 
.:.::Marcelo Augusto::.:.
MSN: harkonmose...@hotmail.com
SKYPE: harkonmoseley
___
For more information regarding industry leading CCIE Lab training, please visit 
www.ipexpert.com

Are you a CCNP or CCIE and looking for a job? Check out 
www.PlatinumPlacement.com

Re: [OSL | CCIE_Voice] Fwd: RSVP Max Sessions

2013-08-17 Thread Justin Carney
My apologies for guessing about two sessions.  I found through testing what
Marcelo confirmed, sessions 1 will allow a single call.

However, FOR THE LAB the number of software sessions per call is irrelevant
- configure it way higher than you think you'll need (10, 100, 500), UNLESS
the question tells you not to do that.  If the question states don't
configured DSPs that are not needed this does not apply to software MTP,
as it doesn't use DSP resources.  If you want to use a hardware MTP then
yes you should be worried about DSPs (I would recommend using a separate
transcoder and sticking with software MTP).

I wanted to also confirm my prior statement about codec pass-through and
understand when/why you should use it, so I did some further testing and
research today.  The short answer is that FOR THE LAB it does not appear to
matter if you use codec pass-through, I got the same result for both with
and without pass-through.  (Please note, I did yet not test complicated
scenarios such as a remote site phone calling to CCX which would use an MTP
for RSVP then a transcoder to g711 to talk to CCX.)  Either way, the CUCM
region (g729) and location (bw unlimited, rsvp mandatory (with or without
video desired)) must still be set properly.  Personally, I don't use
pass-through because it is one more variable if I need to troubleshoot and
it does not help me in the lab.

For the real world there are many compelling reasons to use codec
pass-through (for example cisco tells you to) including fax/modem calls and
sRTP, however those are not likely in the lab (I haven't seen them in any
IPExpert workbooks).

I expanded testing to see what effect codec pass through had on some other
setups (beyond what we expect to see in a lab).  For example (test 4
below), if CUCM is set to use G711 and IOS MTP has g729r8 and codec
pass-through the call will setup using 96K and connect using 80K (sho ip
rsvp res).  Thus, codec passthrough effectively IGNORES the codec setting
you have on the IOS MTP when the CUCM endpoints negotiate a codec.  If the
CUCM endpoints do not negotiate, then the ios mtp codec setting will kick
in.


Keep reading if you're bored or curious  :-)

---

Here's a show sccp with my config to look as sessions vs streams:

HQ-RTR#sho sccp
SCCP Admin State: UP
Gateway Local Interface: Loopback0
IPv4 Address: 10.10.110.1
Port Number: 2000
IP Precedence: 3
User Masked Codec list: None
Call Manager: 192.168.0.21, Port Number: 2000
Priority: N/A, Version: 5.0.1, Identifier: 2
Trustpoint: N/A
Call Manager: 192.168.0.101, Port Number: 2000
Priority: N/A, Version: 5.0.1, Identifier: 1
Trustpoint: N/A

MTP Oper State: ACTIVE - Cause Code: NONE
Active Call Manager: 192.168.0.101, Port Number: 2000
TCP Link Status: CONNECTED, Profile Identifier: 2
Reported Max Streams: 1000, Reported Max OOS Streams: 0   
max STREAMS 1000 (2 streams per session configured (500), which does
indicate each session is one call with two streams)
Supported Codec: g729r8, Maximum Packetization Period: 60
Supported Codec: rfc2833 dtmf, Maximum Packetization Period: 30
Supported Codec: rfc2833 pass-thru, Maximum Packetization Period: 30
Supported Codec: inband-dtmf to rfc2833 conversion, Maximum Packetization
Period: 30
RSVP : ENABLED

dspfarm profile 2 mtp
 codec g729r8
 rsvp
 maximum sessions software 500
 associate application SCCP
!

The output above max STREAMS 1000 while I configured 500 sessions - this
does indicate each session is one end-to-end call with two streams, one
for each side of the mtp.



See attached (in a follow up email) detailed debugs of 5 test scenarios
(rsvp bandwidth was increased to allow multiple/g711 calls)

*First two test scenarios are relevant to the lab (with and without
pass-through RSVP works as expected)*
*1: region set g711, location set unlimited bw and rsvp mandatory, ios mtp
set g729*
 -RESULT (as expected): rsvp uses *40k during setup, 24K when call
connects*
 -note: show sccp conn shows codec as G729, phones also show G729
in use
*2: same as test 1 but adding ios mtp codec pass-through*
 -RESULT (as expected): rsvp uses *40k during setup, 24K when call
connects*
 -note: show sccp conn shows codec as pass-th,  phones show G729 in
use

*Next two tests show codec pass-through ignores the codec set in IOS MTP*
*3: region set g711, location set unlimited bw and rsvp mandatory, ios mtp *
*no codec set** and pass-through on*
 -RESULT (as expected): rsvp uses *96k during setup, 80K when call
connects*
 -note: show sccp conn shows codec as pass-th,  phones show G711 in
use
*4: region set g711, location set unlimited bw and rsvp mandatory, ios mtp *
*set g729** and pass-through on*
 -RESULT: *rsvp uses 96k during setup, 80K when call connects* (ios mtp
codec setting ignored because both phones negotiate g711)
 -note: show sccp conn shows codec as pass-th,  phones show G711 in
use


*Last test shows how without codec pass-through the 

Re: [OSL | CCIE_Voice] mva

2013-08-17 Thread Ragulan Sathasivan
Hi Karen,

Thanks for the response. I am not sure how to use the translation. Would you 
mind to share in detail ? Because,I suppose, we should use the same number as 
PSTN line for the remote destination number(for exact match), so that when the 
user call from that PSTN line/number it will prompt only to enter the PIN. 

Thanks
Ragu



 From: Karen Johnson karen.johnson...@yahoo.ca
To: Ragulan Sathasivan s_s_ragu...@yahoo.com; 
ccie_voice@onlinestudylist.com ccie_voice@onlinestudylist.com 
Sent: Saturday, 17 August 2013, 0:30
Subject: Re: [OSL | CCIE_Voice] mva
 


hi Ragu,
 
I also confused about this if CIsco want to see use 1 or not. However not to 
conflict it is very easy, u just need to use Translation and change your Remote 
destination#
 
Other who got 100 score on this, can pls advice?
 
K

From: Ragulan Sathasivan s_s_ragu...@yahoo.com
To: ccie_voice@onlinestudylist.com ccie_voice@onlinestudylist.com 
Sent: Thursday, August 15, 2013 8:25:44 PM
Subject: Re: [OSL | CCIE_Voice] mva



Hi Guys, 

What should be the busy trigger set for the MVA IP Phone ? 

If I set 1 for the voicemail/Unity Connection requirement then if i call from 
PSNT phone line which is Remote Destination number then call is not successful. 
If the busy trigger changed to 2 then the call from the Remote Destination PSTN 
line to the MVA IP Phone is success. 

Regards
Ragu
___
For more information regarding industry leading CCIE Lab training, please visit 
www.ipexpert.com

Are you a CCNP or CCIE and looking for a job? Check out 
www.PlatinumPlacement.com___
For more information regarding industry leading CCIE Lab training, please visit 
www.ipexpert.com

Are you a CCNP or CCIE and looking for a job? Check out 
www.PlatinumPlacement.com