RE: QOS on 2621xm [7:61353]

2003-01-21 Thread mjans001
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1

Nope, 

The only engineering you can do is at the cpe, where your traffic
goes out and comes in.

Thais makes that you at best can configure QOS at the BOTTLENECK,
that may be your remote office router.
If not applicable, than the agregation point (HQ) will be the next
best.

I still would say that you carefully analyse the traffic patterns and
look at the bottlenecks. That is the no 1 point to do business.

Martijn

- -Oorspronkelijk bericht-
Van: Julian Pentermann [mailto:[EMAIL PROTECTED]] 
Verzonden: dinsdag 21 januari 2003 6:58
Aan: mjans001
Onderwerp: Re: QOS on 2621xm [7:61353]


would the isp have to do anything or would i just impliment the qos
on my router?

Thanks for the help
- - Original Message -
From: mjans001 
Newsgroups: groupstudy.cisco
Sent: Tuesday, January 21, 2003 12:53 AM
Subject: RE: QOS on 2621xm [7:61353]


 -BEGIN PGP SIGNED MESSAGE-
 Hash: SHA1

 You may need to use Priority Queueing, and hardcode telnet High prio 
 based on an access-list.

 Normal traffic despools after telnet queue is empty. If you are sure 
 that there will always be bandwitfh left for other traffic, PQ will do 
 fine.

 That is one way of using it.

 
 During transmission, PQ gives priority queues absolute preferential 
 treatment over low priority queues; important traffic, given the 
 highest priority, always takes precedence over less important traffic. 
 Packets are classified based on user-specified criteria and placed 
 into one of the
four
 output queues-high, medium, normal, and low-based on the assigned
priority.
 Packets that are not classified by priority fall into the normal 
 queue. Figure 7 illustrates this process.

 Congestion Management Overview

http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/12cgcr/qos_c
/qcpart2/qcconman.htm


 Why Use Priority Queueing?
 PQ provides absolute preferential treatment to high priority traffic, 
 ensuring that mission-critical traffic traversing various WAN links 
 gets priority treatment. In addition, PQ provides a faster response 
 time than
do
 other methods of queueing.

 Although you can enable priority output queueing for any interface, it 
 is best used for low-bandwidth, congested serial interfaces.

 Considerations
 When choosing to use PQ, consider that because lower priority traffic 
 is often denied bandwidth in favor of higher priority traffic, use of 
 PQ
could,
 in the worst case, result in lower priority traffic never being
transmitted.
 To avoid inflicting these conditions on lower priority traffic, you 
 can
use
 traffic shaping or CAR to rate-limit the higher priority traffic.

 PQ introduces extra overhead that is acceptable for slow interfaces, 
 but
may
 not be acceptable for higher speed interfaces such as Ethernet. With 
 PQ enabled, the system takes longer to switch packets because the 
 packets are classified by the processor card.

 PQ uses a static configuration and does not adapt to changing network 
 conditions.




 

 Martijn

 - -Oorspronkelijk bericht-
 Van: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]] Namens 
 Julian P
 Verzonden: maandag 20 januari 2003 9:02
 Aan: [EMAIL PROTECTED]
 Onderwerp: QOS on 2621xm [7:61353]


 Hi


 We would like to prioritize incoming traffic on our 256k internet link 
 to uunet .We need to give telnet at least 64k incoming bandwidth.

 Any ideas on the best way to do this ?

 Thanks in advance

 Julian
 Version: PGP 8.0

 iQA/AwUBPix7Bndq56XWk+VyEQJ+/ACfS2LZO44i+6Y+cRg37a/ApiovJtgAoLvz
 kS6ZvDnOtSXEqAAi/6u1v+p4
 =nXJB
 -END PGP SIGNATURE-
Version: PGP 8.0

iQA/AwUBPi2VbHdq56XWk+VyEQIPOQCfTguOnPMduMdxWbRuzbadddit3esAn3/6
vmrK61ZimecTbrS2DXPX3Jwo
=FsQK
-END PGP SIGNATURE-




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7i=61482t=61353
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



QOS on 2621xm [7:61353]

2003-01-20 Thread Julian P
Hi


We would like to prioritize incoming traffic on our 256k internet link to
uunet .We need to give telnet at least 64k incoming bandwidth.

Any ideas on the best way to do this ?

Thanks in advance

Julian




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7i=61353t=61353
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



RE: QOS on 2621xm [7:61353]

2003-01-20 Thread Andrew Larkins
You will need to QoS on both sides of the link. Your side should be fine,
but good luck with the ISP side.
I would use the diffserve bits as well as bandwidth allocation using policy
maps.

Andrew

-Original Message-
From: Julian P [mailto:[EMAIL PROTECTED]]
Sent: 20 January 2003 10:02
To: [EMAIL PROTECTED]
Subject: QOS on 2621xm [7:61353]


Hi


We would like to prioritize incoming traffic on our 256k internet link to
uunet .We need to give telnet at least 64k incoming bandwidth.

Any ideas on the best way to do this ?

Thanks in advance

Julian




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7i=61357t=61353
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



RE: QOS on 2621xm [7:61353]

2003-01-20 Thread Andrew Larkins
In QoS now, there is more than just setting the bandwidth allocated to each
class. What you need to do is combine this with  the diffserv bit. This is
basically the newer version of the TOS bit in the IP header that defines
what sort of service happens to the packet. In a nut shell, this means which
packets gets sent first in the output queue.
As telnet is very delay sensitive, you should give it a higher diffserv bit.

What you basically do is create class maps for each traffic type and apply
it to the Ethernet interface so that the router modifies the packets as it
enters the router. As the packet leaves the interface, you use normal
service policies.

Sample config below:

class-map match-all Gold
  match access-group 170
class-map match-all Bronze
  match access-group 172
class-map match-all Telnet_SSH
  match access-group 131
class-map match-all Silver
  match access-group 171
!
policy-map SET_DIFFSERV
   class Telnet_SSH
   set ip dscp cs5
policy-map 
  class Gold
   bandwidth percent (%)
  class Bronze
   bandwidth percent (%)
! 
interface FastEthernet0/0
 description Link to LAN
 ip address x.x.x.x y.y.y.y
 speed 100
 full-duplex
 service-policy input SET_DIFFSERV
!
interface Serial0/0
 bandwidth 512
 ip address a.a.a.a b.b.b.b
 service-policy output 

access-list 131 remark Prioritise Telnet and SSH
access-list 131 permit tcp any any eq telnet
access-list 131 permit tcp any any eq 22
access-list 170 remark Gold Class QoS
access-list 170 permit ip host xx host xxx
access-list 170 permit ip host xxx host xxx
access-list 170 permit tcp host  eq 443 any
access-list 170 permit tcp host  eq www any
access-list 170 permit udp any any eq domain
access-list 172 remark Bronze Class QoS
access-list 172 permit ip host  host x





 -Original Message-
 From: Julian P [mailto:[EMAIL PROTECTED]]
 Sent: 20 January 2003 10:02
 To: [EMAIL PROTECTED]
 Subject: QOS on 2621xm [7:61353]


 Hi


 We would like to prioritize incoming traffic on our 256k internet link to
 uunet .We need to give telnet at least 64k incoming bandwidth.

 Any ideas on the best way to do this ?

 Thanks in advance

 Julian




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7i=61365t=61353
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



RE: QOS on 2621xm [7:61353]

2003-01-20 Thread mjans001
-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1

You may need to use Priority Queueing, and hardcode telnet High prio based
on an access-list.

Normal traffic despools after telnet queue is empty. If you are sure that
there will always be bandwitfh left for other traffic, PQ will do fine.

That is one way of using it.


During transmission, PQ gives priority queues absolute preferential
treatment over low priority queues; important traffic, given the highest
priority, always takes precedence over less important traffic. Packets are
classified based on user-specified criteria and placed into one of the four
output queues-high, medium, normal, and low-based on the assigned priority.
Packets that are not classified by priority fall into the normal queue.
Figure 7 illustrates this process.

Congestion Management Overview
http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/12cgcr/qos_c/qcpart2/qcconman.htm


Why Use Priority Queueing?
PQ provides absolute preferential treatment to high priority traffic,
ensuring that mission-critical traffic traversing various WAN links gets
priority treatment. In addition, PQ provides a faster response time than do
other methods of queueing.

Although you can enable priority output queueing for any interface, it is
best used for low-bandwidth, congested serial interfaces.

Considerations
When choosing to use PQ, consider that because lower priority traffic is
often denied bandwidth in favor of higher priority traffic, use of PQ could,
in the worst case, result in lower priority traffic never being transmitted.
To avoid inflicting these conditions on lower priority traffic, you can use
traffic shaping or CAR to rate-limit the higher priority traffic.

PQ introduces extra overhead that is acceptable for slow interfaces, but may
not be acceptable for higher speed interfaces such as Ethernet. With PQ
enabled, the system takes longer to switch packets because the packets are
classified by the processor card.

PQ uses a static configuration and does not adapt to changing network
conditions.






Martijn

- -Oorspronkelijk bericht-
Van: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]] Namens Julian P
Verzonden: maandag 20 januari 2003 9:02
Aan: [EMAIL PROTECTED]
Onderwerp: QOS on 2621xm [7:61353]


Hi


We would like to prioritize incoming traffic on our 256k internet link to
uunet .We need to give telnet at least 64k incoming bandwidth.

Any ideas on the best way to do this ?

Thanks in advance

Julian
Version: PGP 8.0

iQA/AwUBPix7Bndq56XWk+VyEQJ+/ACfS2LZO44i+6Y+cRg37a/ApiovJtgAoLvz
kS6ZvDnOtSXEqAAi/6u1v+p4
=nXJB
-END PGP SIGNATURE-




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7i=61420t=61353
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



RE: QOS on 2621xm [7:61353]

2003-01-20 Thread Larkin, Richard
What would he do if he had a FR link to a remote site and he wanted to
ensure his high priority traffic was sent without DE, whilst low priority
traffic can burst and be sent as DE - does FRTS (for Telnet only) solve this
problem (if that can be done)?

Rik

-Original Message-
From: mjans001 [mailto:[EMAIL PROTECTED]] 
Sent: Tuesday, 21 January 2003 6:54 AM
To: [EMAIL PROTECTED]
Subject: RE: QOS on 2621xm [7:61353]


-BEGIN PGP SIGNED MESSAGE-
Hash: SHA1

You may need to use Priority Queueing, and hardcode telnet High prio based
on an access-list.

Normal traffic despools after telnet queue is empty. If you are sure that
there will always be bandwitfh left for other traffic, PQ will do fine.

That is one way of using it.


During transmission, PQ gives priority queues absolute preferential
treatment over low priority queues; important traffic, given the highest
priority, always takes precedence over less important traffic. Packets are
classified based on user-specified criteria and placed into one of the four
output queues-high, medium, normal, and low-based on the assigned priority.
Packets that are not classified by priority fall into the normal queue.
Figure 7 illustrates this process.

Congestion Management Overview
http://www.cisco.com/univercd/cc/td/doc/product/software/ios120/12cgcr/qos_c
/qcpart2/qcconman.htm


Why Use Priority Queueing?
PQ provides absolute preferential treatment to high priority traffic,
ensuring that mission-critical traffic traversing various WAN links gets
priority treatment. In addition, PQ provides a faster response time than do
other methods of queueing.

Although you can enable priority output queueing for any interface, it is
best used for low-bandwidth, congested serial interfaces.

Considerations
When choosing to use PQ, consider that because lower priority traffic is
often denied bandwidth in favor of higher priority traffic, use of PQ could,
in the worst case, result in lower priority traffic never being transmitted.
To avoid inflicting these conditions on lower priority traffic, you can use
traffic shaping or CAR to rate-limit the higher priority traffic.

PQ introduces extra overhead that is acceptable for slow interfaces, but may
not be acceptable for higher speed interfaces such as Ethernet. With PQ
enabled, the system takes longer to switch packets because the packets are
classified by the processor card.

PQ uses a static configuration and does not adapt to changing network
conditions.






Martijn

- -Oorspronkelijk bericht-
Van: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]] Namens Julian P
Verzonden: maandag 20 januari 2003 9:02
Aan: [EMAIL PROTECTED]
Onderwerp: QOS on 2621xm [7:61353]


Hi


We would like to prioritize incoming traffic on our 256k internet link to
uunet .We need to give telnet at least 64k incoming bandwidth.

Any ideas on the best way to do this ?

Thanks in advance

Julian
Version: PGP 8.0

iQA/AwUBPix7Bndq56XWk+VyEQJ+/ACfS2LZO44i+6Y+cRg37a/ApiovJtgAoLvz
kS6ZvDnOtSXEqAAi/6u1v+p4
=nXJB
-END PGP SIGNATURE-




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7i=61425t=61353
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]