Re: NAT question? [7:55043]

2002-10-07 Thread Robert Edmonds

Ok, consider this.  You have a server behind a router and you want others on
the Internet to be able to use the services on this server.  The server's IP
address is 172.16.1.10.  You have a block of IP address given to you by your
ISP.  The addresses are 192.1.1.1 - 192.1.1.14 (this implies a subnet mask
of 255.255.255.240).  Now, you want the users on the Internet to use the IP
address 192.1.1.2 to connect to your internal router.  Your router is on
interface Ethernet1 and your internet connection is on interface Serial0.1.
The point to point link between you and your ISP uses the address
192.1.1.16/30.  Your end is 192.1.1.17 and theirs is 192.1.1.18.  Your
config would look something like this.

interface Ethernet1

 description Ethernet Connection to WEBSERVER

 ip address 172.16.1.1 255.255.255.0

 ip nat inside

defines the Ethernet 1 interface as an inside address



interface Serial0.1 point-to-point

 description Full T-1 to ISP

 ip address 192.1.1.17 255.255.255.252

 no ip directed-broadcast

 ip nat outside

-defines Serial0.1 as outside



ip nat inside source static 172.16.1.10 192.1.1.2

-assigns the outside address of 192.1.1.2 to the server at 172.16.1.10



ip route 0.0.0.0 0.0.0.0 192.1.1.18

-default route, using ISP's router



ip route 192.1.1.2 255.255.255.255 Ethernet1

-if the server is directly connected to Ethernet1, route it this way



I hope this helps.


""Karl West""  wrote in message
[EMAIL PROTECTED]">news:[EMAIL PROTECTED]...
> Can some one give me an example of using  "ip nat inside destination" ?
> I know it enables NAT of the inside destination address. But I would
> like to see an
> example of how it is used. I check the cisco site but it doesn't go into
> detail or maybe
> I just didn't find it.
>
> Thanks
> Karl




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=55051&t=55043
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



RE: NAT question? [7:55043]

2002-10-07 Thread Lupi, Guy

The following link has a configuration example of TCP load distribution
using NAT, that command is there: 

http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/ip_c
/ipcprt1/1cdipadr.htm#xtocid2215662




-Original Message-
From: Karl West [mailto:[EMAIL PROTECTED]]
Sent: Monday, October 07, 2002 3:12 PM
To: [EMAIL PROTECTED]
Subject: NAT question? [7:55043]


Can some one give me an example of using  "ip nat inside destination" ?
I know it enables NAT of the inside destination address. But I would
like to see an
example of how it is used. I check the cisco site but it doesn't go into
detail or maybe
I just didn't find it.

Thanks
Karl




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=55056&t=55043
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



Re: NAT question? [7:55043]

2002-10-07 Thread Karl West

Thanks Guy...that was the information I was looking for...

Karl

"Lupi, Guy" wrote:

> The following link has a configuration example of TCP load distribution
> using NAT, that command is there:
>
>
http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121cgcr/ip_c
> /ipcprt1/1cdipadr.htm#xtocid2215662
>
> -Original Message-
> From: Karl West [mailto:[EMAIL PROTECTED]]
> Sent: Monday, October 07, 2002 3:12 PM
> To: [EMAIL PROTECTED]
> Subject: NAT question? [7:55043]
>
> Can some one give me an example of using  "ip nat inside destination" ?
> I know it enables NAT of the inside destination address. But I would
> like to see an
> example of how it is used. I check the cisco site but it doesn't go into
> detail or maybe
> I just didn't find it.
>
> Thanks
> Karl




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=55059&t=55043
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]