Under your 2 loopback put " Ip ospf network point-to-point"
That will cause ospf to see them as /24 not /32's as they are now.
Since rip is using the same mask as the loopbacks, your redistribution
should work without a summary.


Thanks

Larry
 

-----Original Message-----
From: Timothy Ouellette [mailto:[EMAIL PROTECTED]] 
Sent: Thursday, July 18, 2002 4:16 AM
To: [EMAIL PROTECTED]; [EMAIL PROTECTED]
Subject: OSPF/RIP w/ Summary address.


Serial connection between r2 and r1 is hdlc on the 141.108.1.0/24 network
with RIP running on it for both r2 and r1.  R1-->R3 and R1--> R4 are running
OSPF in area 0.  Generating the 141.108.3.0/24 from lo0 on r4 and
141.108.4.0/24 from r3.



r2 ---141.108.1.0/24 ---r1 ------ 141.108.255.0/30-----r3
                                        \_______ 141.108.255.4/30 ---- r4


What i'm trying to do is get the 141.108.3.0/24 and 141.108.4.0/24 to show
up on r2 as rip routes heard from r1. I'm redistributing ospf 1
into rip with a metric of 5.   Since r1 is considered a border router
because it's connected to another protcol I figured I could use the
"summary-address 141.108.3.0 255.255.255.0" command to generate a
summary address to r2.   This did not work until a put a static route to
null0 for that particular network and then it showed up.

r2#r
     141.108.0.0/24 is subnetted, 3 subnets
C       141.108.1.0 is directly connected, Serial0
R       141.108.3.0 [120/1] via 141.108.1.4, 00:00:22, Serial0
R       141.108.4.0 [120/1] via 141.108.1.4, 00:00:22, Serial0
     150.150.0.0/24 is subnetted, 1 subnets
C       150.150.150.0 is directly connected, Loopback0

My understanding of the summary-address command is to normally take external
routes and summarize them into OSPF but maybe I'm using it backwards in this
case to solve the my issue.  I would have also though that there would be
the same /24 route installed in the rest of the OSPF routers but it is not
there (atleast not as a /24) or in the ospf database.

r4#r
Gateway of last resort is not set

     141.108.0.0/16 is variably subnetted, 5 subnets, 3 masks
C       141.108.255.4/30 is directly connected, Serial0
O       141.108.255.0/30 [110/128] via 141.108.255.5, 00:09:10, Serial0
C       141.108.3.0/29 is directly connected, Loopback0
O       141.108.5.0/28 [110/129] via 141.108.255.5, 00:09:10, Serial0
O       141.108.4.0/28 [110/129] via 141.108.255.5, 00:09:10, Serial0
r4#

I would have thought it would show up on R4 and R3 but only the /28's are.
Below is the config of the router with the redistribution and the
summary-addresses.  Is there another way to do this with multiple ospf
processes too or any other tricks you folks may know?

r1#sr
Building configuration...

Current configuration : 2950 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug datetime localtime
service timestamps log datetime localtime
no service password-encryption
!
hostname r1
!
logging rate-limit console 10 except errors
enable secret 5 $1$eE3Z$08gdpU0xizpkuKkrvzmr0.
!
clock timezone est -5
clock summer-time est recurring
ip subnet-zero
no ip finger
ip tcp synwait-time 5
no ip domain-lookup
!
no ip dhcp-client network-discovery
frame-relay switching
!
!
!
interface Loopback0
 ip address 141.108.2.1 255.255.255.128
 ip ospf network point-to-point
!
interface Serial0
 no ip address
 encapsulation frame-relay
 no fair-queue
 no frame-relay inverse-arp
!
interface Serial0.1 point-to-point
 ip address 141.108.255.1 255.255.255.252
 ip ospf network non-broadcast
 frame-relay interface-dlci 103
!
interface Serial0.2 point-to-point
 ip address 141.108.255.5 255.255.255.252
 ip ospf network non-broadcast
 frame-relay interface-dlci 104
!
interface Serial1
 no ip address
 shutdown
!
interface Serial2
 no ip address
 encapsulation frame-relay
 clockrate 64000
 frame-relay intf-type dce
 frame-relay route 103 interface Serial4 301
 frame-relay route 104 interface Serial5 401
!
interface Serial3
 no ip address
 shutdown
!
interface Serial4
 no ip address
 encapsulation frame-relay
 clockrate 64000
 frame-relay intf-type dce
 frame-relay route 301 interface Serial2 103
!
interface Serial5
 no ip address
 encapsulation frame-relay
 clockrate 64000
 frame-relay intf-type dce
 frame-relay route 401 interface Serial2 104
!
interface Serial6
 no ip address
 shutdown
!
interface Serial7
 no ip address
 shutdown
!
interface Serial8
 no ip address
 shutdown
!
interface Serial9
 ip address 141.108.1.4 255.255.255.0
 clockrate 64000
!
interface TokenRing0
 no ip address
 shutdown
!
interface BRI0
 no ip address
 shutdown
 cdapi buffers regular 0
 cdapi buffers raw 0
 cdapi buffers large 0
!
router ospf 1
 router-id 141.108.255.5
 log-adjacency-changes
 summary-address 141.108.3.0 255.255.255.0
 summary-address 141.108.4.0 255.255.255.0
 passive-interface Loopback0
 network 141.108.255.1 0.0.0.0 area 0
 network 141.108.255.5 0.0.0.0 area 0
 neighbor 141.108.255.6 priority 1
 neighbor 141.108.255.2 priority 1
!
router rip
 redistribute ospf 1 metric 2
 network 141.108.0.0
!
ip kerberos source-interface any
ip classless
ip route 141.108.3.0 255.255.255.0 Null0
ip route 141.108.4.0 255.255.255.0 Null0
ip http server
!
alias exec ib sh ip int brief
alias exec c config terminal
alias exec sr sh run
alias exec r sh ip route
alias exec bs sh ip bgp summary
alias exec b sh ip bgp
alias exec cb clear ip bgp *
alias exec on sh ip ospf neigh
!
l

end

r1# _________________________________________________________________
Commercial lab list: http://www.groupstudy.com/list/commercial.html
Please discuss commercial lab solutions on this list.




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=49122&t=49122
--------------------------------------------------
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]

Reply via email to