Re: BGP question [7:27879]

2001-11-30 Thread Stephane LITKOWSKI

You need to announce all your local subnets :
- by using the network command, u can announce all subnets already placed in
the routing table by an IGP
- by redistributing your IGP on BGP using the redistribute 
command in router bgp config mode

I see some OSPF routes in your routing table, so you can use network command
to announce all subnets :

(config)# router bgp 200
(config-router)# network 192.168.1.0 mask 255.255.255.0
(config-router)# network 192.168.2.0 mask 255.255.255.0
(config-router)# network 192.168.3.0 mask 255.255.255.0

u don't need to announce the peering link ...

or use redistribution (not recommended by Cisco in BSCN book, but it works)
:

(config)# router bgp 200
(config-router)# redistribute ospf 


hope it helps


--
Stephane LITKOWSKI
Student in a french computer science school
EPITA Telecom  Network specialization
CCNA + BCMSN
EMail : [EMAIL PROTECTED]


Stephen C  a icrit dans le message news:
[EMAIL PROTECTED]
 When configuring BGP on a singlehome net, everything I read says the
basic
 config commands are ... for S 0\0 to S 0\0  (200.200.1.1 to 200.200.1.2)
 wire 200.200.1.0
 Router-A(config)#router bgp [as#]
 Router-A(config-router)#network [subnet#]
 Router-A(config-router)#neighbor [subnet#] remote-as [as#]
 now filling in the blanks
 Router-A(config)#router bgp [200]
 Router-A(config-router)#network [200.200.1.0]
 Router-A(config-router)#neighbor [200.200.1.1] remote-as [100]
 unless I configure RIP on the same wire I get nothing.  No mention of RIP
in
 any
 of the books I reference.  I config RIP and get a from show ip route
this
 C200.200.1.0/24 is directly connected, Serial1
 R200.200.100.0/24 [120/1] via 200.200.1.1, 00:00:14, Serial1
   [120/1] via 200.200.2.1, 00:00:14, Serial0
 C200.200.2.0/24 is directly connected, Serial0
 C192.168.1.0/24 is directly connected, Ethernet0
 O192.168.2.0/24 [110/74] via 192.168.1.2, 01:54:20, Ethernet0
 O E2 192.168.3.0/24 [110/20] via 192.168.1.2, 01:54:20, Ethernet0
 Not showing bgp on the connections

 the Show ip bgp yields .
 Router-A#show ip bgp
 BGP table version is 3, local router ID is 200.200.2.2
 Status codes: s suppressed, d damped, h history, * valid,  best, i -
 internal
 Origin codes: i - IGP, e - EGP, ? - incomplete

Network  Next HopMetric LocPrf Weight Path
 *  200.200.1.0  200.200.2.1  0 0 100 i
 *   200.200.1.1  0 0 100 i

 *  0.0.0.0  0 32768 i  Where
 did I pick up the Static/Default paths from

 *  200.200.2.0  200.200.2.1  0 0 100 i
 *   200.200.1.1  0 0 100 i
 *  0.0.0.0  0 32768 i  Where
 did I pick up the Static/Default paths from




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7i=27881t=27879
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



RE: BGP question [7:27879]

2001-11-30 Thread Bill Carter

You have to have IP connectivity to your neighbor before BGP will work.
Static routes will get you the same thing as RIP.

-Original Message-
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]On Behalf Of
Stephen C
Sent: Friday, November 30, 2001 2:37 PM
To: [EMAIL PROTECTED]
Subject: BGP question [7:27879]


When configuring BGP on a singlehome net, everything I read says the basic
config commands are ... for S 0\0 to S 0\0  (200.200.1.1 to 200.200.1.2)
wire 200.200.1.0
Router-A(config)#router bgp [as#]
Router-A(config-router)#network [subnet#]
Router-A(config-router)#neighbor [subnet#] remote-as [as#]
now filling in the blanks
Router-A(config)#router bgp [200]
Router-A(config-router)#network [200.200.1.0]
Router-A(config-router)#neighbor [200.200.1.1] remote-as [100]
unless I configure RIP on the same wire I get nothing.  No mention of RIP in
any
of the books I reference.  I config RIP and get a from show ip route this
C200.200.1.0/24 is directly connected, Serial1
R200.200.100.0/24 [120/1] via 200.200.1.1, 00:00:14, Serial1
  [120/1] via 200.200.2.1, 00:00:14, Serial0
C200.200.2.0/24 is directly connected, Serial0
C192.168.1.0/24 is directly connected, Ethernet0
O192.168.2.0/24 [110/74] via 192.168.1.2, 01:54:20, Ethernet0
O E2 192.168.3.0/24 [110/20] via 192.168.1.2, 01:54:20, Ethernet0
Not showing bgp on the connections

the Show ip bgp yields .
Router-A#show ip bgp
BGP table version is 3, local router ID is 200.200.2.2
Status codes: s suppressed, d damped, h history, * valid,  best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network  Next HopMetric LocPrf Weight Path
*  200.200.1.0  200.200.2.1  0 0 100 i
*   200.200.1.1  0 0 100 i

*  0.0.0.0  0 32768 i  Where
did I pick up the Static/Default paths from

*  200.200.2.0  200.200.2.1  0 0 100 i
*   200.200.1.1  0 0 100 i
*  0.0.0.0  0 32768 i  Where
did I pick up the Static/Default paths from




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7i=27883t=27879
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



RE: BGP question [7:27879]

2001-11-30 Thread Stephen C

by entering these commands di I inject a static route?  I can't figure out
where
they came from.  Are they a normal consequence of BGP or ???

-Original Message-
From: Bill Carter [mailto:[EMAIL PROTECTED]]
Sent: Friday, November 30, 2001 2:45 PM
To: Stephen C; [EMAIL PROTECTED]
Subject: RE: BGP question [7:27879]


You have to have IP connectivity to your neighbor before BGP will work.
Static routes will get you the same thing as RIP.

-Original Message-
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]On Behalf Of
Stephen C
Sent: Friday, November 30, 2001 2:37 PM
To: [EMAIL PROTECTED]
Subject: BGP question [7:27879]


When configuring BGP on a singlehome net, everything I read says the basic
config commands are ... for S 0\0 to S 0\0  (200.200.1.1 to 200.200.1.2)
wire 200.200.1.0
Router-A(config)#router bgp [as#]
Router-A(config-router)#network [subnet#]
Router-A(config-router)#neighbor [subnet#] remote-as [as#]
now filling in the blanks
Router-A(config)#router bgp [200]
Router-A(config-router)#network [200.200.1.0]
Router-A(config-router)#neighbor [200.200.1.1] remote-as [100]
unless I configure RIP on the same wire I get nothing.  No mention of RIP in
any
of the books I reference.  I config RIP and get a from show ip route this
C200.200.1.0/24 is directly connected, Serial1
R200.200.100.0/24 [120/1] via 200.200.1.1, 00:00:14, Serial1
  [120/1] via 200.200.2.1, 00:00:14, Serial0
C200.200.2.0/24 is directly connected, Serial0
C192.168.1.0/24 is directly connected, Ethernet0
O192.168.2.0/24 [110/74] via 192.168.1.2, 01:54:20, Ethernet0
O E2 192.168.3.0/24 [110/20] via 192.168.1.2, 01:54:20, Ethernet0
Not showing bgp on the connections

the Show ip bgp yields .
Router-A#show ip bgp
BGP table version is 3, local router ID is 200.200.2.2
Status codes: s suppressed, d damped, h history, * valid,  best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network  Next HopMetric LocPrf Weight Path
*  200.200.1.0  200.200.2.1  0 0 100 i
*   200.200.1.1  0 0 100 i

*  0.0.0.0  0 32768 i  Where
did I pick up the Static/Default paths from

*  200.200.2.0  200.200.2.1  0 0 100 i
*   200.200.1.1  0 0 100 i
*  0.0.0.0  0 32768 i  Where
did I pick up the Static/Default paths from




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7i=27884t=27879
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



RE: BGP question [7:27879]

2001-11-30 Thread Logan, Harold

That's normal. BGP doesn't actually route data like an IGP does, it only
handles routing information. You don't have to use RIP, you can use an
IGP or (preferably) static routes.

Hal Logan
Network Specialist / Adjunct Faculty
Computing and Engineering Technology
Manatee Community College


 -Original Message-
 From: Stephen C [mailto:[EMAIL PROTECTED]]
 Sent: Friday, November 30, 2001 3:37 PM
 To: [EMAIL PROTECTED]
 Subject: BGP question [7:27879]
 
 
 When configuring BGP on a singlehome net, everything I read 
 says the basic
 config commands are ... for S 0\0 to S 0\0  (200.200.1.1 to 
 200.200.1.2)
 wire 200.200.1.0
   Router-A(config)#router bgp [as#]
   Router-A(config-router)#network [subnet#]
   Router-A(config-router)#neighbor [subnet#] remote-as [as#]
 now filling in the blanks
   Router-A(config)#router bgp [200]
   Router-A(config-router)#network [200.200.1.0]
   Router-A(config-router)#neighbor [200.200.1.1] remote-as [100]
 unless I configure RIP on the same wire I get nothing.  No 
 mention of RIP in
 any
 of the books I reference.  I config RIP and get a from show 
 ip route this
   C200.200.1.0/24 is directly connected, Serial1
   R200.200.100.0/24 [120/1] via 200.200.1.1, 00:00:14, Serial1
   [120/1] via 200.200.2.1, 00:00:14, Serial0
   C200.200.2.0/24 is directly connected, Serial0
   C192.168.1.0/24 is directly connected, Ethernet0
   O192.168.2.0/24 [110/74] via 192.168.1.2, 01:54:20, 
 Ethernet0
   O E2 192.168.3.0/24 [110/20] via 192.168.1.2, 01:54:20, 
 Ethernet0
 Not showing bgp on the connections
 
 the Show ip bgp yields .
   Router-A#show ip bgp
   BGP table version is 3, local router ID is 200.200.2.2
   Status codes: s suppressed, d damped, h history, * 
 valid,  best, i -
 internal
   Origin codes: i - IGP, e - EGP, ? - incomplete
 
  Network  Next HopMetric LocPrf 
 Weight Path
   *  200.200.1.0  200.200.2.1  0  
0 100 i
   *   200.200.1.1  0  
0 100 i
 
   *  0.0.0.0  0 
 32768 i  Where
 did I pick up the Static/Default paths from
 
   *  200.200.2.0  200.200.2.1  0  
0 100 i
   *   200.200.1.1  0  
0 100 i
   *  0.0.0.0  0 
 32768 i  Where
 did I pick up the Static/Default paths from




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7i=27885t=27879
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



RE: BGP question [7:27879]

2001-11-30 Thread Bill Carter

It may work, but in real world redistributing from IGP to BGP is very bad
practice.

-Original Message-
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]On Behalf Of
Stephane LITKOWSKI
Sent: Friday, November 30, 2001 3:23 PM
To: [EMAIL PROTECTED]
Subject: Re: BGP question [7:27879]


You need to announce all your local subnets :
- by using the network command, u can announce all subnets already placed in
the routing table by an IGP
- by redistributing your IGP on BGP using the redistribute 
command in router bgp config mode

I see some OSPF routes in your routing table, so you can use network command
to announce all subnets :

(config)# router bgp 200
(config-router)# network 192.168.1.0 mask 255.255.255.0
(config-router)# network 192.168.2.0 mask 255.255.255.0
(config-router)# network 192.168.3.0 mask 255.255.255.0

u don't need to announce the peering link ...

or use redistribution (not recommended by Cisco in BSCN book, but it works)
:

(config)# router bgp 200
(config-router)# redistribute ospf


hope it helps


--
Stephane LITKOWSKI
Student in a french computer science school
EPITA Telecom  Network specialization
CCNA + BCMSN
EMail : [EMAIL PROTECTED]


Stephen C  a icrit dans le message news:
[EMAIL PROTECTED]
 When configuring BGP on a singlehome net, everything I read says the
basic
 config commands are ... for S 0\0 to S 0\0  (200.200.1.1 to 200.200.1.2)
 wire 200.200.1.0
 Router-A(config)#router bgp [as#]
 Router-A(config-router)#network [subnet#]
 Router-A(config-router)#neighbor [subnet#] remote-as [as#]
 now filling in the blanks
 Router-A(config)#router bgp [200]
 Router-A(config-router)#network [200.200.1.0]
 Router-A(config-router)#neighbor [200.200.1.1] remote-as [100]
 unless I configure RIP on the same wire I get nothing.  No mention of RIP
in
 any
 of the books I reference.  I config RIP and get a from show ip route
this
 C200.200.1.0/24 is directly connected, Serial1
 R200.200.100.0/24 [120/1] via 200.200.1.1, 00:00:14, Serial1
   [120/1] via 200.200.2.1, 00:00:14, Serial0
 C200.200.2.0/24 is directly connected, Serial0
 C192.168.1.0/24 is directly connected, Ethernet0
 O192.168.2.0/24 [110/74] via 192.168.1.2, 01:54:20, Ethernet0
 O E2 192.168.3.0/24 [110/20] via 192.168.1.2, 01:54:20, Ethernet0
 Not showing bgp on the connections

 the Show ip bgp yields .
 Router-A#show ip bgp
 BGP table version is 3, local router ID is 200.200.2.2
 Status codes: s suppressed, d damped, h history, * valid,  best, i -
 internal
 Origin codes: i - IGP, e - EGP, ? - incomplete

Network  Next HopMetric LocPrf Weight Path
 *  200.200.1.0  200.200.2.1  0 0 100 i
 *   200.200.1.1  0 0 100 i

 *  0.0.0.0  0 32768 i  Where
 did I pick up the Static/Default paths from

 *  200.200.2.0  200.200.2.1  0 0 100 i
 *   200.200.1.1  0 0 100 i
 *  0.0.0.0  0 32768 i  Where
 did I pick up the Static/Default paths from




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7i=27887t=27879
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



RE: BGP question [7:27879]

2001-11-30 Thread Andy Hoang

Stephen,

BGP is not like other routing protocol where you use the network command to
run bgp on that interface.  The network command is used to announce networks
that the router know about to its neighbor.  This means that you must
already have a route on your router either via Static, IGRP, RIP, etc before
BGP will announce this route to its neighbor.  I think that's what happen
when you turn on RIP.

Try using the network command for your other directly connected network then
you will see BGP announce it to its neighbor.

router bgp 200
 network ethernet network

or
router bgp 200
 redistribute connected subnet

Not having the whole configs, I'm not sure where you pick up the default
route.

-Original Message-
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]On Behalf Of
Stephen C
Sent: Friday, November 30, 2001 12:37 PM
To: [EMAIL PROTECTED]
Subject: BGP question [7:27879]


When configuring BGP on a singlehome net, everything I read says the basic
config commands are ... for S 0\0 to S 0\0  (200.200.1.1 to 200.200.1.2)
wire 200.200.1.0
Router-A(config)#router bgp [as#]
Router-A(config-router)#network [subnet#]
Router-A(config-router)#neighbor [subnet#] remote-as [as#]
now filling in the blanks
Router-A(config)#router bgp [200]
Router-A(config-router)#network [200.200.1.0]
Router-A(config-router)#neighbor [200.200.1.1] remote-as [100]
unless I configure RIP on the same wire I get nothing.  No mention of RIP in
any
of the books I reference.  I config RIP and get a from show ip route this
C200.200.1.0/24 is directly connected, Serial1
R200.200.100.0/24 [120/1] via 200.200.1.1, 00:00:14, Serial1
  [120/1] via 200.200.2.1, 00:00:14, Serial0
C200.200.2.0/24 is directly connected, Serial0
C192.168.1.0/24 is directly connected, Ethernet0
O192.168.2.0/24 [110/74] via 192.168.1.2, 01:54:20, Ethernet0
O E2 192.168.3.0/24 [110/20] via 192.168.1.2, 01:54:20, Ethernet0
Not showing bgp on the connections

the Show ip bgp yields .
Router-A#show ip bgp
BGP table version is 3, local router ID is 200.200.2.2
Status codes: s suppressed, d damped, h history, * valid,  best, i -
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network  Next HopMetric LocPrf Weight Path
*  200.200.1.0  200.200.2.1  0 0 100 i
*   200.200.1.1  0 0 100 i

*  0.0.0.0  0 32768 i  Where
did I pick up the Static/Default paths from

*  200.200.2.0  200.200.2.1  0 0 100 i
*   200.200.1.1  0 0 100 i
*  0.0.0.0  0 32768 i  Where
did I pick up the Static/Default paths from




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7i=27886t=27879
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



RE: BGP question [7:27879]

2001-11-30 Thread Mcfadden, Chuck

Can we see your whole config?
ccie1ab

-Original Message-
From: Bill Carter [mailto:[EMAIL PROTECTED]]
Sent: Friday, November 30, 2001 4:44 PM
To: [EMAIL PROTECTED]
Subject: RE: BGP question [7:27879]


You have to have IP connectivity to your neighbor before BGP will work.
Static routes will get you the same thing as RIP.

-Original Message-
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]On Behalf Of
Stephen C
Sent: Friday, November 30, 2001 2:37 PM
To: [EMAIL PROTECTED]
Subject: BGP question [7:27879]


When configuring BGP on a singlehome net, everything I read says the basic
config commands are ... for S 0\0 to S 0\0  (200.200.1.1 to 200.200.1.2)
wire 200.200.1.0
Router-A(config)#router bgp [as#]
Router-A(config-router)#network [subnet#]
Router-A(config-router)#neighbor [subnet#] remote-as [as#]
now filling in the blanks
Router-A(config)#router bgp [200]
Router-A(config-router)#network [200.200.1.0]
Router-A(config-router)#neighbor [200.200.1.1] remote-as [100]
unless I configure RIP on the same wire I get nothing.  No mention of RIP in
any
of the books I reference.  I config RIP and get a from show ip route this
C200.200.1.0/24 is directly connected, Serial1
R200.200.100.0/24 [120/1] via 200.200.1.1, 00:00:14, Serial1
  [120/1] via 200.200.2.1, 00:00:14, Serial0
C200.200.2.0/24 is directly connected, Serial0
C192.168.1.0/24 is directly connected, Ethernet0
O192.168.2.0/24 [110/74] via 192.168.1.2, 01:54:20, Ethernet0
O E2 192.168.3.0/24 [110/20] via 192.168.1.2, 01:54:20, Ethernet0
Not showing bgp on the connections

the Show ip bgp yields .
Router-A#show ip bgp
BGP table version is 3, local router ID is 200.200.2.2
Status codes: s suppressed, d damped, h history, * valid,  best, i
-
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network  Next HopMetric LocPrf Weight Path
*  200.200.1.0  200.200.2.1  0 0 100 i
*   200.200.1.1  0 0 100 i

*  0.0.0.0  0 32768 i
Where
did I pick up the Static/Default paths from

*  200.200.2.0  200.200.2.1  0 0 100 i
*   200.200.1.1  0 0 100 i
*  0.0.0.0  0 32768 i
Where
did I pick up the Static/Default paths from




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7i=27888t=27879
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



RE: BGP question [7:27879]

2001-11-30 Thread Stephen C

Ask and you shall recieve ... cisco 2503 ... not on Internet, no passwords,
my own rack

Router-A#show runn
Building configuration...

Current configuration : 1209 bytes
!
version 12.2
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router-A
!
logging rate-limit console 10 except errors
!
ip subnet-zero
no ip finger
!
no ip dhcp-client network-discovery
!
!
!
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0  
!  
interface Serial0
 ip address 200.200.2.2 255.255.255.0
 no fair-queue
 clockrate 56000
!
interface Serial1
 ip address 200.200.1.2 255.255.255.0
!
interface BRI0
 no ip address
 shutdown
 isdn x25 static-tei 0
 cdapi buffers regular 0
 cdapi buffers raw 0
 cdapi buffers large 0
!
router ospf 1
 log-adjacency-changes
 network 192.168.1.0 0.0.0.255 area 0
!
router bgp 200
 no synchronization
 bgp log-neighbor-changes
 network 200.200.1.0
 network 200.200.2.0
 neighbor 200.200.1.1 remote-as 100
 neighbor 200.200.2.1 remote-as 100
!
ip kerberos source-interface any
ip classless
ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 login
!
end

-Original Message-
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]On Behalf Of
Mcfadden, Chuck
Sent: Friday, November 30, 2001 3:21 PM
To: [EMAIL PROTECTED]
Subject: RE: BGP question [7:27879]


Can we see your whole config?
ccie1ab

-Original Message-
From: Bill Carter [mailto:[EMAIL PROTECTED]]
Sent: Friday, November 30, 2001 4:44 PM
To: [EMAIL PROTECTED]
Subject: RE: BGP question [7:27879]


You have to have IP connectivity to your neighbor before BGP will work.
Static routes will get you the same thing as RIP.

-Original Message-
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]]On Behalf Of
Stephen C
Sent: Friday, November 30, 2001 2:37 PM
To: [EMAIL PROTECTED]
Subject: BGP question [7:27879]


When configuring BGP on a singlehome net, everything I read says the basic
config commands are ... for S 0\0 to S 0\0  (200.200.1.1 to 200.200.1.2)
wire 200.200.1.0
Router-A(config)#router bgp [as#]
Router-A(config-router)#network [subnet#]
Router-A(config-router)#neighbor [subnet#] remote-as [as#]
now filling in the blanks
Router-A(config)#router bgp [200]
Router-A(config-router)#network [200.200.1.0]
Router-A(config-router)#neighbor [200.200.1.1] remote-as [100]
unless I configure RIP on the same wire I get nothing.  No mention of RIP in
any
of the books I reference.  I config RIP and get a from show ip route this
C200.200.1.0/24 is directly connected, Serial1
R200.200.100.0/24 [120/1] via 200.200.1.1, 00:00:14, Serial1
  [120/1] via 200.200.2.1, 00:00:14, Serial0
C200.200.2.0/24 is directly connected, Serial0
C192.168.1.0/24 is directly connected, Ethernet0
O192.168.2.0/24 [110/74] via 192.168.1.2, 01:54:20, Ethernet0
O E2 192.168.3.0/24 [110/20] via 192.168.1.2, 01:54:20, Ethernet0
Not showing bgp on the connections

the Show ip bgp yields .
Router-A#show ip bgp
BGP table version is 3, local router ID is 200.200.2.2
Status codes: s suppressed, d damped, h history, * valid,  best, i
-
internal
Origin codes: i - IGP, e - EGP, ? - incomplete

   Network  Next HopMetric LocPrf Weight Path
*  200.200.1.0  200.200.2.1  0 0 100 i
*   200.200.1.1  0 0 100 i

*  0.0.0.0  0 32768 i
Where
did I pick up the Static/Default paths from

*  200.200.2.0  200.200.2.1  0 0 100 i
*   200.200.1.1  0 0 100 i
*  0.0.0.0  0 32768 i
Where
did I pick up the Static/Default paths from




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7i=27890t=27879
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



RE: BGP question [7:27879]

2001-11-30 Thread Jesse Loggins

I am supprised that no one has explained this in normal terms to you so far.
Here goes. Under normal operation (in your case) BGP will not advertise a 
network unless it learns it from an IGP first (in BGP's case it will
consider a static route an IGP route). You can make BGP advertise a network
not learned by an IGP but this is only sugested to be done when all internal
routers are running IBGP. Then you would use the no-synchronization command
to allow BGP to advertise these networks. THe other alternative is to set a
static route pointing to null0 (ip route 192.168.1.0 255.255.255.0 null0)
and have BGP advertise that network to its EBGP neighbor. OR run an IGP like
RIP. That is why it works when you add rip routing. Hope this helps.


Message Posted at:
http://www.groupstudy.com/form/read.php?f=7i=27903t=27879
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]