Re: tunnel interfaces [7:32953]

2002-01-24 Thread Router Man

5.5.5.5  6.6.6.6
   e0IP cloud e0
R1-R2-R3-R4-R5-R6R7
t0  t0
1.1.1.1  1.1.1.2
Lets say that you have two routers (R1&R7) each with a tunnel interface.
Also there are about 5 routers in between them(R2-R6).  The 5 routers in the
middle will only know the How to reach the E0 interfaces (or ip addresses),
NOT the tunnel interface (or tunnel ip address).  Anytime you send a packet
destined for a tunnel interface, the source/destination addressess will be
the ip address of the E0 interfaces.  The tunnel information is seen as data
to the outgoing/incoming IP packet.  If sending from R1 to R7, R1 will use
the source address of E0 then add the tunnel info as the payload. When R7
sees the data in the packet he will see a GRE header which tells him that
there is tunnel information which follows.  R7 will strip off the GRE header
then see the source ip address of the tunnell interface on R1.

The only traffic that will be tunneled will be traffic that has a next hop
of the tunnel interface

 wrote in message
news:[EMAIL PROTECTED]...
> I am kinda confused on the details of how tunneling
> works...
>
> questions:
>
> 1> what will the source and destination ip addresses
> of the gre encapsulated packets be? (posible answers
> include the address of the tunnels, or the e0
> interfaces, etc...)
>
> 2>what traffic will be tunneled? (all traffic inbound
> to e0, or all traffic detined to the local tunnel
> interface?)
>
> hope that makes sense
>
> r1:
> interface Tunnel0
>  ip address 192.168.20.1 255.255.255.0
>  tunnel source Ethernet0
>  tunnel destination 11.11.11.11
> r2:
> interface Tunnel0
>  ip address 192.168.20.2 255.255.255.0
>  tunnel source Ethernet0
>  tunnel destination 9.9.9.9
>
>
> __
> Do You Yahoo!?
> Send FREE video emails in Yahoo! Mail!
> http://promo.yahoo.com/videomail/




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=33101&t=32953
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



Re: tunnel interfaces [7:32953]

2002-01-24 Thread na

if the tunnel was created to create a discontiguous subnet.. say:

network: 10.10.10.x
R1 t0 ip address: 10.10.10.1
R7 t0 ip address 10.10.10.2

well if a host hanging off of R1 with a default gateway of 10.10.10.1 were
to ping 10.10.10.100 (server hanging off R7) it would not use its default
gateway since the address is local so how does it get passed through the
tunnel?


""Router Man""  wrote in message
[EMAIL PROTECTED]">news:[EMAIL PROTECTED]...
> 5.5.5.5  6.6.6.6
>e0IP cloud e0
> R1-R2-R3-R4-R5-R6R7
> t0  t0
> 1.1.1.1  1.1.1.2
> Lets say that you have two routers (R1&R7) each with a tunnel interface.
> Also there are about 5 routers in between them(R2-R6).  The 5 routers in
the
> middle will only know the How to reach the E0 interfaces (or ip
addresses),
> NOT the tunnel interface (or tunnel ip address).  Anytime you send a
packet
> destined for a tunnel interface, the source/destination addressess will be
> the ip address of the E0 interfaces.  The tunnel information is seen as
data
> to the outgoing/incoming IP packet.  If sending from R1 to R7, R1 will use
> the source address of E0 then add the tunnel info as the payload. When R7
> sees the data in the packet he will see a GRE header which tells him that
> there is tunnel information which follows.  R7 will strip off the GRE
header
> then see the source ip address of the tunnell interface on R1.
>
> The only traffic that will be tunneled will be traffic that has a next hop
> of the tunnel interface
>
>  wrote in message
> news:[EMAIL PROTECTED]...
> > I am kinda confused on the details of how tunneling
> > works...
> >
> > questions:
> >
> > 1> what will the source and destination ip addresses
> > of the gre encapsulated packets be? (posible answers
> > include the address of the tunnels, or the e0
> > interfaces, etc...)
> >
> > 2>what traffic will be tunneled? (all traffic inbound
> > to e0, or all traffic detined to the local tunnel
> > interface?)
> >
> > hope that makes sense
> >
> > r1:
> > interface Tunnel0
> >  ip address 192.168.20.1 255.255.255.0
> >  tunnel source Ethernet0
> >  tunnel destination 11.11.11.11
> > r2:
> > interface Tunnel0
> >  ip address 192.168.20.2 255.255.255.0
> >  tunnel source Ethernet0
> >  tunnel destination 9.9.9.9
> >
> >
> > __
> > Do You Yahoo!?
> > Send FREE video emails in Yahoo! Mail!
> > http://promo.yahoo.com/videomail/




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=33149&t=32953
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



Re: tunnel interfaces [7:32953]

2002-01-24 Thread tsiwut

if the tunnel was created to create a discontiguous subnet.. say:

network: 10.10.10.x
R1 t0 ip address: 10.10.10.1
R7 t0 ip address 10.10.10.2

well if a host hanging off of R1 with a default gateway of 10.10.10.1 were
to ping 10.10.10.100 (server hanging off R7) it would not use its default
gateway since the address is local so how does it get passed through the
tunnel?


""Router Man""  wrote in message
[EMAIL PROTECTED]">news:[EMAIL PROTECTED]...
> 5.5.5.5  6.6.6.6
>e0IP cloud e0
> R1-R2-R3-R4-R5-R6R7
> t0  t0
> 1.1.1.1  1.1.1.2
> Lets say that you have two routers (R1&R7) each with a tunnel interface.
> Also there are about 5 routers in between them(R2-R6).  The 5 routers in
the
> middle will only know the How to reach the E0 interfaces (or ip
addresses),
> NOT the tunnel interface (or tunnel ip address).  Anytime you send a
packet
> destined for a tunnel interface, the source/destination addressess will be
> the ip address of the E0 interfaces.  The tunnel information is seen as
data
> to the outgoing/incoming IP packet.  If sending from R1 to R7, R1 will use
> the source address of E0 then add the tunnel info as the payload. When R7
> sees the data in the packet he will see a GRE header which tells him that
> there is tunnel information which follows.  R7 will strip off the GRE
header
> then see the source ip address of the tunnell interface on R1.
>
> The only traffic that will be tunneled will be traffic that has a next hop
> of the tunnel interface
>
>  wrote in message
> news:[EMAIL PROTECTED]...
> > I am kinda confused on the details of how tunneling
> > works...
> >
> > questions:
> >
> > 1> what will the source and destination ip addresses
> > of the gre encapsulated packets be? (posible answers
> > include the address of the tunnels, or the e0
> > interfaces, etc...)
> >
> > 2>what traffic will be tunneled? (all traffic inbound
> > to e0, or all traffic detined to the local tunnel
> > interface?)
> >
> > hope that makes sense
> >
> > r1:
> > interface Tunnel0
> >  ip address 192.168.20.1 255.255.255.0
> >  tunnel source Ethernet0
> >  tunnel destination 11.11.11.11
> > r2:
> > interface Tunnel0
> >  ip address 192.168.20.2 255.255.255.0
> >  tunnel source Ethernet0
> >  tunnel destination 9.9.9.9
> >
> >
> > __
> > Do You Yahoo!?
> > Send FREE video emails in Yahoo! Mail!
> > http://promo.yahoo.com/videomail/
_
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=33150&t=32953
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]