ip classless and default route [7:53231]

2002-09-12 Thread YI Zhou

according to many books, ip classless should be used to be able to use
default route.

but I just found my internet router, actually has no ip classless.

which means I am using classful route lookup.

And this is working fine,who can explain why

note that ip address here is not real one.

!
hostname xxx
!
enable secret xxx
!
ip subnet-zero
no ip domain-lookup
ip name-server x.x.x.x

!
interface FastEthernet0/0
 ip address 210.210.210.62 255.255.255.240
 no ip directed-broadcast
!
interface Serial0/0
 bandwidth 64
 ip unnumbered FastEthernet0/0
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
!
no ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0


Gateway of last resort is 0.0.0.0 to network 0.0.0.0

 210.210.210.0/28 is subnetted, 1 subnets
C   210.210.210.48 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 is directly connected, Serial0/0
xxx#

xxx#sh flash

System flash directory:
File  Length   Name/status
  1   3612344  c2600-i-mz.120-3.T3
[3612408 bytes used, 4776200 available, 8388608 total]
8192K bytes of processor board System flash (Read/Write)


Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=53231&t=53231
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



RE: ip classless and default route [7:53231]

2002-09-12 Thread Priscilla Oppenheimer

You don't need the "ip classless" command because your default route points
to an unnumbered serial interface. If instead it pointed to an IP address
that was in the same class as your local Ethernet, then you would have a
problem. Here's the classic example:

e0 RouterA s0 -- s0 RouterB -->Internet

routerA
int e0
172.16.10.1 255.255.255.0
int s0
172.16.20.1 255.255.255.0
ip route 0.0.0.0 0.0.0.0 172.16.20.2

routerB
int s0
172.16.20.2 255.255.255.0

That confuses Router A. Without "ip classless," it thinks 172.16.0.0/16 is
local. But that causes it not to be able to forward traffic to 172.16.20.2,
the router on the other end of the serial link that has access to the rest
of the world. Try it in a lab, if you get a chance. You'll see that in this
situation, you need "ip classless."

Priscilla


YI Zhou wrote:
> 
> according to many books, ip classless should be used to be able
> to use default route.
> 
> but I just found my internet router, actually has no ip
> classless.
> 
> which means I am using classful route lookup.
> 
> And this is working fine,who can explain why
> 
> note that ip address here is not real one.
> 
> !
> hostname xxx
> !
> enable secret xxx
> !
> ip subnet-zero
> no ip domain-lookup
> ip name-server x.x.x.x
> 
> !
> interface FastEthernet0/0
>  ip address 210.210.210.62 255.255.255.240
>  no ip directed-broadcast
> !
> interface Serial0/0
>  bandwidth 64
>  ip unnumbered FastEthernet0/0
>  no ip directed-broadcast
>  no ip mroute-cache
>  no fair-queue
> !
> no ip classless
> ip route 0.0.0.0 0.0.0.0 Serial0/0
> 
> 
> Gateway of last resort is 0.0.0.0 to network 0.0.0.0
> 
>  210.210.210.0/28 is subnetted, 1 subnets
> C   210.210.210.48 is directly connected, FastEthernet0/0
> S*   0.0.0.0/0 is directly connected, Serial0/0
> xxx#
> 
> xxx#sh flash
> 
> System flash directory:
> File  Length   Name/status
>   1   3612344  c2600-i-mz.120-3.T3
> [3612408 bytes used, 4776200 available, 8388608 total]
> 8192K bytes of processor board System flash (Read/Write)




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=53235&t=53231
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



Re: ip classless and default route [7:53231]

2002-09-12 Thread Erick B.

It will work fine for any destination other then
210.210.210.x/24 which is the classful network for
your IP subnet. 

A better real-world internet example with no ip
classless and internet connections would be, if you
had a 64.x.x.x subnet on the serial and similar on LAN
side. In this case, 64.0.0.0/8 is the classful range.
There are many other customers that have a subnet in
this classful range out there. With 'no ip classless'
and a default route with nexthop of 64.x.x.x any
traffic destined to a 64.x.x.x site would fail, but
traffic to 210.x.x.x, 65.x.x.x, etc would work.

Erick

--- YI Zhou  wrote:
> according to many books, ip classless should be used
> to be able to use
> default route.
> 
> but I just found my internet router, actually has no
> ip classless.
> 
> which means I am using classful route lookup.
> 
> And this is working fine,who can explain why
> 
> note that ip address here is not real one.
> 
> !
> hostname xxx
> !
> enable secret xxx
> !
> ip subnet-zero
> no ip domain-lookup
> ip name-server x.x.x.x
> 
> !
> interface FastEthernet0/0
>  ip address 210.210.210.62 255.255.255.240
>  no ip directed-broadcast
> !
> interface Serial0/0
>  bandwidth 64
>  ip unnumbered FastEthernet0/0
>  no ip directed-broadcast
>  no ip mroute-cache
>  no fair-queue
> !
> no ip classless
> ip route 0.0.0.0 0.0.0.0 Serial0/0
> 
> 
> Gateway of last resort is 0.0.0.0 to network 0.0.0.0
> 
>  210.210.210.0/28 is subnetted, 1 subnets
> C   210.210.210.48 is directly connected,
> FastEthernet0/0
> S*   0.0.0.0/0 is directly connected, Serial0/0
> xxx#
> 
> xxx#sh flash
> 
> System flash directory:
> File  Length   Name/status
>   1   3612344  c2600-i-mz.120-3.T3
> [3612408 bytes used, 4776200 available, 8388608
> total]
> 8192K bytes of processor board System flash
> (Read/Write)
[EMAIL PROTECTED]


__
Do you Yahoo!?
Yahoo! News - Today's headlines
http://news.yahoo.com




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=53238&t=53231
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]



RE: ip classless and default route [7:53231]

2002-09-12 Thread cebuano

Hmm,
Try removing your static 0.0.0.0 and you'll see why.

-Original Message-
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]] 
Sent: Thursday, September 12, 2002 8:57 PM
To: [EMAIL PROTECTED]
Subject: ip classless and default route [7:53231]

according to many books, ip classless should be used to be able to use
default route.

but I just found my internet router, actually has no ip classless.

which means I am using classful route lookup.

And this is working fine,who can explain why

note that ip address here is not real one.

!
hostname xxx
!
enable secret xxx
!
ip subnet-zero
no ip domain-lookup
ip name-server x.x.x.x

!
interface FastEthernet0/0
 ip address 210.210.210.62 255.255.255.240
 no ip directed-broadcast
!
interface Serial0/0
 bandwidth 64
 ip unnumbered FastEthernet0/0
 no ip directed-broadcast
 no ip mroute-cache
 no fair-queue
!
no ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0


Gateway of last resort is 0.0.0.0 to network 0.0.0.0

 210.210.210.0/28 is subnetted, 1 subnets
C   210.210.210.48 is directly connected, FastEthernet0/0
S*   0.0.0.0/0 is directly connected, Serial0/0
xxx#

xxx#sh flash

System flash directory:
File  Length   Name/status
  1   3612344  c2600-i-mz.120-3.T3
[3612408 bytes used, 4776200 available, 8388608 total]
8192K bytes of processor board System flash (Read/Write)




Message Posted at:
http://www.groupstudy.com/form/read.php?f=7&i=53240&t=53231
--
FAQ, list archives, and subscription info: http://www.groupstudy.com/list/cisco.html
Report misconduct and Nondisclosure violations to [EMAIL PROTECTED]