[Cluster-devel] [PATCH 0/6] list: introduce list_last_entry_or_null()

2013-11-15 Thread Jeff Liu
Hi Folks,

This patch is trying to introduce a new list helper to retrieve the
last entry or return NULL if the list is empty corresponding to it,
which is inspired by Jiri Pirko's list_first_entry_or_null().

With this trivial helper, we could get a little benefit to simplify
the code logic of xfs_ail_max() and make the code looks a bit more
consistent with xfs_ail_min() which has already been simplified
via list_first_entry_or_null().

Moreover, as a per simple grep against fs as well as driver's tree,
I think there are some other places could make use of it for similar
purpose, here I spread this helper over some file systems as well.

Any comments are welcome!

Thanks,
-Jeff



Re: [Cluster-devel] [PATCH 0/6] list: introduce list_last_entry_or_null()

2013-11-15 Thread Christoph Hellwig
On Fri, Nov 15, 2013 at 12:29:48PM +0800, Jeff Liu wrote:
 Hi Folks,
 
 This patch is trying to introduce a new list helper to retrieve the
 last entry or return NULL if the list is empty corresponding to it,
 which is inspired by Jiri Pirko's list_first_entry_or_null().

How did we end up with the stupid _or_null prefix there?  I think the
functionality is useful, but the naming is way to verbose, especially
given that a list_first_entry or list_last_entry that optimizes away
that one check doesn't seem useful.

Instead of encoding detailed semantics in the name a good kerneldoc
comment is way better.



Re: [Cluster-devel] [PATCH 0/6] list: introduce list_last_entry_or_null()

2013-11-15 Thread Steven Whitehouse
Hi,

On Fri, 2013-11-15 at 06:11 -0800, Christoph Hellwig wrote:
 On Fri, Nov 15, 2013 at 12:29:48PM +0800, Jeff Liu wrote:
  Hi Folks,
  
  This patch is trying to introduce a new list helper to retrieve the
  last entry or return NULL if the list is empty corresponding to it,
  which is inspired by Jiri Pirko's list_first_entry_or_null().
 
 How did we end up with the stupid _or_null prefix there?  I think the
 functionality is useful, but the naming is way to verbose, especially
 given that a list_first_entry or list_last_entry that optimizes away
 that one check doesn't seem useful.
 
 Instead of encoding detailed semantics in the name a good kerneldoc
 comment is way better.
 

Also, in two of the cases (patch 3 and patch 6) we don't want NULL in
the case that the list is empty, and instead want another pointer which,
after the patches, requires an extra if. Now I suspect that the
optimizer will sort that out (I've not checked) so its probably not too
big an issue. However, if instead of returning NULL for list empty, we
had an extra argument to the function, then it could return whatever
pointer was required for each case, whether NULL or otherwise,

Steve.




Re: [Cluster-devel] [PATCH 0/6] list: introduce list_last_entry_or_null()

2013-11-15 Thread Jeff Liu

On 11/15 2013 22:11, Christoph Hellwig wrote:
 On Fri, Nov 15, 2013 at 12:29:48PM +0800, Jeff Liu wrote:
 Hi Folks,

 This patch is trying to introduce a new list helper to retrieve the
 last entry or return NULL if the list is empty corresponding to it,
 which is inspired by Jiri Pirko's list_first_entry_or_null().
 
 How did we end up with the stupid _or_null prefix there?  I think the
 functionality is useful, but the naming is way to verbose, especially
 given that a list_first_entry or list_last_entry that optimizes away
 that one check doesn't seem useful.
 Instead of encoding detailed semantics in the name a good kerneldoc
 comment is way better.
When it comes to this point, looks the name is really a bit verbose.
And yes, they have the same kernel doc to list_first_entry/list_last_entry.

But at rculist.h, we have another similar routine with this suffix, i.e,
list_fist_or_null_rcu().

Maybe we can figure out a better name and replace the existing code with it
as list_first_entry_or_null() has not yet been widely used, it mainly being
used in drivers code as per a grep against linux-next tree.
 
$ grep list_first_entry_or_null -r linux-next

./drivers/acpi/acpi_ipmi.c: driver_data.selected_smi = 
list_first_entry_or_null(
./drivers/base/regmap/regmap.c: async = 
list_first_entry_or_null(map-async_free,
./drivers/base/regmap/regmap.c: async = 
list_first_entry_or_null(map-async_free,
./drivers/net/team/team.c:  port = 
list_first_entry_or_null(team-port_list,
./drivers/net/ethernet/sfc/mcdi.c:  async = 
list_first_entry_or_null(
./drivers/net/ethernet/intel/i40e/i40e_main.c:  return 
list_first_entry_or_null(vsi-mac_filter_list,
./drivers/net/vxlan.c:  rd = list_first_entry_or_null(f-remotes, struct 
vxlan_rdst, list);
./drivers/of/irq.c: desc = 
list_first_entry_or_null(intc_parent_list,
./fs/xfs/xfs_trans_priv.h:  return list_first_entry_or_null(ailp-xa_ail, 
struct xfs_log_item,
./net/nfc/digital_core.c:   cmd = 
list_first_entry_or_null(ddev-cmd_queue, struct digital_cmd,
./net/nfc/digital_core.c:   cmd = 
list_first_entry_or_null(ddev-cmd_queue, struct digital_cmd,


Thanks,
-Jeff