[jira] [Commented] (ACE-513) Improve workspace API
[ https://issues.apache.org/jira/browse/ACE-513?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14369571#comment-14369571 ] Marcel Offermans commented on ACE-513: -- I think that would also be a worthwhile refactoring, [~bramk]. Perhaps we should make a separate issue for it? > Improve workspace API > - > > Key: ACE-513 > URL: https://issues.apache.org/jira/browse/ACE-513 > Project: ACE > Issue Type: Improvement > Components: Client Repository >Affects Versions: 2.0.1 >Reporter: J.W. Janssen > > The current workspace API has a couple of drawbacks that makes it less > efficient when used in scripts. For example, the create methods ({{c*}}) do > not all return the created repository object, needing a lookup if you want to > do other stuff with that repository object after creation. > A list of proposed changes: > * let the create methods return the created object; > * the {{da}} method should accept an {{ArtifactObject}} instead of an > {{RepositoryObject}} (conform the other delete methods); > * {{lr}} and {{lrp}} both do the same thing: list resource processors. Remove > {{lr}} in favour of {{lrp}}; > * expose the {{createArtifact}}, {{createFeature}}, etc from > {{WorkspaceImpl}} as this makes it easier to read in scripts (the shorthand > versions are useful when working directly in gogo shell). > Any thoughts, remarks? -- This message was sent by Atlassian JIRA (v6.3.4#6332)
[jira] [Commented] (ACE-513) Improve workspace API
[ https://issues.apache.org/jira/browse/ACE-513?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14369542#comment-14369542 ] Bram de Kruijff commented on ACE-513: - Given that gogo has alias support and it is just one client.. would it not be best to remove all gogo registration and command short-hands from the ace.client.workspace bundle altogether? I think we should prefer meaningful names on the core interfaces and move gogo support into the ace.gogo bundle. > Improve workspace API > - > > Key: ACE-513 > URL: https://issues.apache.org/jira/browse/ACE-513 > Project: ACE > Issue Type: Improvement > Components: Client Repository >Affects Versions: 2.0.1 >Reporter: J.W. Janssen > > The current workspace API has a couple of drawbacks that makes it less > efficient when used in scripts. For example, the create methods ({{c*}}) do > not all return the created repository object, needing a lookup if you want to > do other stuff with that repository object after creation. > A list of proposed changes: > * let the create methods return the created object; > * the {{da}} method should accept an {{ArtifactObject}} instead of an > {{RepositoryObject}} (conform the other delete methods); > * {{lr}} and {{lrp}} both do the same thing: list resource processors. Remove > {{lr}} in favour of {{lrp}}; > * expose the {{createArtifact}}, {{createFeature}}, etc from > {{WorkspaceImpl}} as this makes it easier to read in scripts (the shorthand > versions are useful when working directly in gogo shell). > Any thoughts, remarks? -- This message was sent by Atlassian JIRA (v6.3.4#6332)
[jira] [Commented] (ACE-513) Improve workspace API
[ https://issues.apache.org/jira/browse/ACE-513?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14369439#comment-14369439 ] J.W. Janssen commented on ACE-513: -- {quote}I am not a big fan of creating multiple commands for the same things. Especially since the Gogo shell already provides an alias command that you can use if you don't like the default command names.{quote} didn't know about the alias support in Gogo, and it would make this change not really necessary. The only thing is that we now always have to declare these aliases in scripts. > Improve workspace API > - > > Key: ACE-513 > URL: https://issues.apache.org/jira/browse/ACE-513 > Project: ACE > Issue Type: Improvement > Components: Client Repository >Affects Versions: 2.0.1 >Reporter: J.W. Janssen > > The current workspace API has a couple of drawbacks that makes it less > efficient when used in scripts. For example, the create methods ({{c*}}) do > not all return the created repository object, needing a lookup if you want to > do other stuff with that repository object after creation. > A list of proposed changes: > * let the create methods return the created object; > * the {{da}} method should accept an {{ArtifactObject}} instead of an > {{RepositoryObject}} (conform the other delete methods); > * {{lr}} and {{lrp}} both do the same thing: list resource processors. Remove > {{lr}} in favour of {{lrp}}; > * expose the {{createArtifact}}, {{createFeature}}, etc from > {{WorkspaceImpl}} as this makes it easier to read in scripts (the shorthand > versions are useful when working directly in gogo shell). > Any thoughts, remarks? -- This message was sent by Atlassian JIRA (v6.3.4#6332)
[jira] [Commented] (ACE-513) Improve workspace API
[ https://issues.apache.org/jira/browse/ACE-513?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14369432#comment-14369432 ] Marcel Offermans commented on ACE-513: -- I agree completely with the first three bullets. I am not a big fan of creating multiple commands for the same things. Especially since the Gogo shell already provides an alias command that you can use if you don't like the default command names. > Improve workspace API > - > > Key: ACE-513 > URL: https://issues.apache.org/jira/browse/ACE-513 > Project: ACE > Issue Type: Improvement > Components: Client Repository >Affects Versions: 2.0.1 >Reporter: J.W. Janssen > > The current workspace API has a couple of drawbacks that makes it less > efficient when used in scripts. For example, the create methods ({{c*}}) do > not all return the created repository object, needing a lookup if you want to > do other stuff with that repository object after creation. > A list of proposed changes: > * let the create methods return the created object; > * the {{da}} method should accept an {{ArtifactObject}} instead of an > {{RepositoryObject}} (conform the other delete methods); > * {{lr}} and {{lrp}} both do the same thing: list resource processors. Remove > {{lr}} in favour of {{lrp}}; > * expose the {{createArtifact}}, {{createFeature}}, etc from > {{WorkspaceImpl}} as this makes it easier to read in scripts (the shorthand > versions are useful when working directly in gogo shell). > Any thoughts, remarks? -- This message was sent by Atlassian JIRA (v6.3.4#6332)
[jira] [Created] (ACE-513) Improve workspace API
J.W. Janssen created ACE-513: Summary: Improve workspace API Key: ACE-513 URL: https://issues.apache.org/jira/browse/ACE-513 Project: ACE Issue Type: Improvement Components: Client Repository Affects Versions: 2.0.1 Reporter: J.W. Janssen The current workspace API has a couple of drawbacks that makes it less efficient when used in scripts. For example, the create methods ({{c*}}) do not all return the created repository object, needing a lookup if you want to do other stuff with that repository object after creation. A list of proposed changes: * let the create methods return the created object; * the {{da}} method should accept an {{ArtifactObject}} instead of an {{RepositoryObject}} (conform the other delete methods); * {{lr}} and {{lrp}} both do the same thing: list resource processors. Remove {{lr}} in favour of {{lrp}}; * expose the {{createArtifact}}, {{createFeature}}, etc from {{WorkspaceImpl}} as this makes it easier to read in scripts (the shorthand versions are useful when working directly in gogo shell). Any thoughts, remarks? -- This message was sent by Atlassian JIRA (v6.3.4#6332)