[jira] [Commented] (CASSANDRA-8612) Read metrics should be updated on all types of reads
[ https://issues.apache.org/jira/browse/CASSANDRA-8612?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17135194#comment-17135194 ] Dean Z commented on CASSANDRA-8612: --- Hi [~cnlwsu] , uploaded another patch to add more metrics. Actually added all metrics I found in the SinglePartitionReadCommand, could you check if there's anything else missing? > Read metrics should be updated on all types of reads > > > Key: CASSANDRA-8612 > URL: https://issues.apache.org/jira/browse/CASSANDRA-8612 > Project: Cassandra > Issue Type: Improvement > Components: Observability/Metrics >Reporter: Chris Lohfink >Assignee: Dean Z >Priority: Low > Labels: lhf, metrics > Attachments: 0001-Update-read-metrics-on-all-types-of-reads.patch, > 0002-Add-more-read-metrics-into-PartitionRangeReadCommand.patch > > > Metrics like "sstables per read" are not updated on a range slice. Although > separating things out for each type of read could make sense like we do for > latencies, only exposing the metrics for one type can be a little confusing > when people do a query and see nothing increases. I think its sufficient to > use the same metrics for all reads. -- This message was sent by Atlassian Jira (v8.3.4#803005) - To unsubscribe, e-mail: commits-unsubscr...@cassandra.apache.org For additional commands, e-mail: commits-h...@cassandra.apache.org
[jira] [Updated] (CASSANDRA-8612) Read metrics should be updated on all types of reads
[ https://issues.apache.org/jira/browse/CASSANDRA-8612?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Dean Z updated CASSANDRA-8612: -- Attachment: 0002-Add-more-read-metrics-into-PartitionRangeReadCommand.patch > Read metrics should be updated on all types of reads > > > Key: CASSANDRA-8612 > URL: https://issues.apache.org/jira/browse/CASSANDRA-8612 > Project: Cassandra > Issue Type: Improvement > Components: Observability/Metrics >Reporter: Chris Lohfink >Assignee: Dean Z >Priority: Low > Labels: lhf, metrics > Attachments: 0001-Update-read-metrics-on-all-types-of-reads.patch, > 0002-Add-more-read-metrics-into-PartitionRangeReadCommand.patch > > > Metrics like "sstables per read" are not updated on a range slice. Although > separating things out for each type of read could make sense like we do for > latencies, only exposing the metrics for one type can be a little confusing > when people do a query and see nothing increases. I think its sufficient to > use the same metrics for all reads. -- This message was sent by Atlassian Jira (v8.3.4#803005) - To unsubscribe, e-mail: commits-unsubscr...@cassandra.apache.org For additional commands, e-mail: commits-h...@cassandra.apache.org
[jira] [Commented] (CASSANDRA-15715) [CQL help] URL for help topic CREATE_KEYSPACE is leading to page that does not exist
[ https://issues.apache.org/jira/browse/CASSANDRA-15715?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17127571#comment-17127571 ] Dean Z commented on CASSANDRA-15715: [^0001-Fix-URL-for-help-topic-CREATE_KEYSPACE.patch] Hi [~widkets] , here's a patch, I think this solves this issue > [CQL help] URL for help topic CREATE_KEYSPACE is leading to page that does > not exist > > > Key: CASSANDRA-15715 > URL: https://issues.apache.org/jira/browse/CASSANDRA-15715 > Project: Cassandra > Issue Type: Bug > Components: Documentation/Blog >Reporter: Andrey Andreev >Priority: Normal > Attachments: 0001-Fix-URL-for-help-topic-CREATE_KEYSPACE.patch, > Screenshot from 2020-04-11 12-13-32.png > > > URL for help topic CREATE_KEYSPACE is leading to page that does not exist > {code:java} > cqlsh> SHOW VERSION; > [cqlsh 5.0.1 | Cassandra 3.11.6 | CQL spec 3.4.4 | Native protocol v4] > cqlsh> HELP CREATE_KEYSPACE; > *** No browser to display CQL help. URL for help topic CREATE_KEYSPACE : > https://cassandra.apache.org/doc/cql3/CQL-3.2.html#createKeyspaceStmt > {code} > Page "https://cassandra.apache.org/doc/cql3/CQL-3.2.html#createKeyspaceStmt"; > is showing 404 "Not Found". (see screenshot attachment) > How did I install C* (From the book "Cassandra The Definitive Guide, Third > Edition, page 53") > {code:java} > docker pull cassandra > docker run --name c-seed cassandra > docker exec -it c-seed cqlsh > HELP CREATE_KEYSPACE; > {code} > It is probably related to this part of code: > [https://github.com/apache/cassandra/blob/d069fd235f3553ef6e3267efc9cf3b9b2fe4e70e/bin/cqlsh.py#L76] > Probably we need to replace: > CASSANDRA_CQL_HTML_FALLBACK = > 'https://cassandra.apache.org/doc/cql3/CQL-3.2.html' > with > CASSANDRA_CQL_HTML_FALLBACK = > 'https://cassandra.apache.org/doc/old/CQL-3.0.html' > -- This message was sent by Atlassian Jira (v8.3.4#803005) - To unsubscribe, e-mail: commits-unsubscr...@cassandra.apache.org For additional commands, e-mail: commits-h...@cassandra.apache.org
[jira] [Assigned] (CASSANDRA-15715) [CQL help] URL for help topic CREATE_KEYSPACE is leading to page that does not exist
[ https://issues.apache.org/jira/browse/CASSANDRA-15715?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Dean Z reassigned CASSANDRA-15715: -- Assignee: Dean Z > [CQL help] URL for help topic CREATE_KEYSPACE is leading to page that does > not exist > > > Key: CASSANDRA-15715 > URL: https://issues.apache.org/jira/browse/CASSANDRA-15715 > Project: Cassandra > Issue Type: Bug > Components: Documentation/Blog >Reporter: Andrey Andreev >Assignee: Dean Z >Priority: Normal > Attachments: 0001-Fix-URL-for-help-topic-CREATE_KEYSPACE.patch, > Screenshot from 2020-04-11 12-13-32.png > > > URL for help topic CREATE_KEYSPACE is leading to page that does not exist > {code:java} > cqlsh> SHOW VERSION; > [cqlsh 5.0.1 | Cassandra 3.11.6 | CQL spec 3.4.4 | Native protocol v4] > cqlsh> HELP CREATE_KEYSPACE; > *** No browser to display CQL help. URL for help topic CREATE_KEYSPACE : > https://cassandra.apache.org/doc/cql3/CQL-3.2.html#createKeyspaceStmt > {code} > Page "https://cassandra.apache.org/doc/cql3/CQL-3.2.html#createKeyspaceStmt"; > is showing 404 "Not Found". (see screenshot attachment) > How did I install C* (From the book "Cassandra The Definitive Guide, Third > Edition, page 53") > {code:java} > docker pull cassandra > docker run --name c-seed cassandra > docker exec -it c-seed cqlsh > HELP CREATE_KEYSPACE; > {code} > It is probably related to this part of code: > [https://github.com/apache/cassandra/blob/d069fd235f3553ef6e3267efc9cf3b9b2fe4e70e/bin/cqlsh.py#L76] > Probably we need to replace: > CASSANDRA_CQL_HTML_FALLBACK = > 'https://cassandra.apache.org/doc/cql3/CQL-3.2.html' > with > CASSANDRA_CQL_HTML_FALLBACK = > 'https://cassandra.apache.org/doc/old/CQL-3.0.html' > -- This message was sent by Atlassian Jira (v8.3.4#803005) - To unsubscribe, e-mail: commits-unsubscr...@cassandra.apache.org For additional commands, e-mail: commits-h...@cassandra.apache.org
[jira] [Updated] (CASSANDRA-15715) [CQL help] URL for help topic CREATE_KEYSPACE is leading to page that does not exist
[ https://issues.apache.org/jira/browse/CASSANDRA-15715?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Dean Z updated CASSANDRA-15715: --- Attachment: 0001-Fix-URL-for-help-topic-CREATE_KEYSPACE.patch > [CQL help] URL for help topic CREATE_KEYSPACE is leading to page that does > not exist > > > Key: CASSANDRA-15715 > URL: https://issues.apache.org/jira/browse/CASSANDRA-15715 > Project: Cassandra > Issue Type: Bug > Components: Documentation/Blog >Reporter: Andrey Andreev >Priority: Normal > Attachments: 0001-Fix-URL-for-help-topic-CREATE_KEYSPACE.patch, > Screenshot from 2020-04-11 12-13-32.png > > > URL for help topic CREATE_KEYSPACE is leading to page that does not exist > {code:java} > cqlsh> SHOW VERSION; > [cqlsh 5.0.1 | Cassandra 3.11.6 | CQL spec 3.4.4 | Native protocol v4] > cqlsh> HELP CREATE_KEYSPACE; > *** No browser to display CQL help. URL for help topic CREATE_KEYSPACE : > https://cassandra.apache.org/doc/cql3/CQL-3.2.html#createKeyspaceStmt > {code} > Page "https://cassandra.apache.org/doc/cql3/CQL-3.2.html#createKeyspaceStmt"; > is showing 404 "Not Found". (see screenshot attachment) > How did I install C* (From the book "Cassandra The Definitive Guide, Third > Edition, page 53") > {code:java} > docker pull cassandra > docker run --name c-seed cassandra > docker exec -it c-seed cqlsh > HELP CREATE_KEYSPACE; > {code} > It is probably related to this part of code: > [https://github.com/apache/cassandra/blob/d069fd235f3553ef6e3267efc9cf3b9b2fe4e70e/bin/cqlsh.py#L76] > Probably we need to replace: > CASSANDRA_CQL_HTML_FALLBACK = > 'https://cassandra.apache.org/doc/cql3/CQL-3.2.html' > with > CASSANDRA_CQL_HTML_FALLBACK = > 'https://cassandra.apache.org/doc/old/CQL-3.0.html' > -- This message was sent by Atlassian Jira (v8.3.4#803005) - To unsubscribe, e-mail: commits-unsubscr...@cassandra.apache.org For additional commands, e-mail: commits-h...@cassandra.apache.org
[jira] [Commented] (CASSANDRA-8612) Read metrics should be updated on all types of reads
[ https://issues.apache.org/jira/browse/CASSANDRA-8612?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17126840#comment-17126840 ] Dean Z commented on CASSANDRA-8612: --- Hi [~cnlwsu] , you mean this ticket is resolved and nothing else need to be done right? > Read metrics should be updated on all types of reads > > > Key: CASSANDRA-8612 > URL: https://issues.apache.org/jira/browse/CASSANDRA-8612 > Project: Cassandra > Issue Type: Improvement > Components: Observability/Metrics >Reporter: Chris Lohfink >Assignee: Dean Z >Priority: Low > Labels: lhf, metrics > Attachments: 0001-Update-read-metrics-on-all-types-of-reads.patch > > > Metrics like "sstables per read" are not updated on a range slice. Although > separating things out for each type of read could make sense like we do for > latencies, only exposing the metrics for one type can be a little confusing > when people do a query and see nothing increases. I think its sufficient to > use the same metrics for all reads. -- This message was sent by Atlassian Jira (v8.3.4#803005) - To unsubscribe, e-mail: commits-unsubscr...@cassandra.apache.org For additional commands, e-mail: commits-h...@cassandra.apache.org
[jira] [Assigned] (CASSANDRA-8612) Read metrics should be updated on all types of reads
[ https://issues.apache.org/jira/browse/CASSANDRA-8612?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Dean Z reassigned CASSANDRA-8612: - Assignee: Dean Z > Read metrics should be updated on all types of reads > > > Key: CASSANDRA-8612 > URL: https://issues.apache.org/jira/browse/CASSANDRA-8612 > Project: Cassandra > Issue Type: Improvement > Components: Observability/Metrics >Reporter: Chris Lohfink >Assignee: Dean Z >Priority: Low > Labels: lhf, metrics > Attachments: 0001-Update-read-metrics-on-all-types-of-reads.patch > > > Metrics like "sstables per read" are not updated on a range slice. Although > separating things out for each type of read could make sense like we do for > latencies, only exposing the metrics for one type can be a little confusing > when people do a query and see nothing increases. I think its sufficient to > use the same metrics for all reads. -- This message was sent by Atlassian Jira (v8.3.4#803005) - To unsubscribe, e-mail: commits-unsubscr...@cassandra.apache.org For additional commands, e-mail: commits-h...@cassandra.apache.org
[jira] [Commented] (CASSANDRA-8612) Read metrics should be updated on all types of reads
[ https://issues.apache.org/jira/browse/CASSANDRA-8612?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17120541#comment-17120541 ] Dean Z commented on CASSANDRA-8612: --- Hi [~cnlwsu] , new to the community, trying to start with easy ones, not sure how this patch looks.[^0001-Update-read-metrics-on-all-types-of-reads.patch] > Read metrics should be updated on all types of reads > > > Key: CASSANDRA-8612 > URL: https://issues.apache.org/jira/browse/CASSANDRA-8612 > Project: Cassandra > Issue Type: Improvement > Components: Observability/Metrics >Reporter: Chris Lohfink >Priority: Low > Labels: lhf, metrics > Attachments: 0001-Update-read-metrics-on-all-types-of-reads.patch > > > Metrics like "sstables per read" are not updated on a range slice. Although > separating things out for each type of read could make sense like we do for > latencies, only exposing the metrics for one type can be a little confusing > when people do a query and see nothing increases. I think its sufficient to > use the same metrics for all reads. -- This message was sent by Atlassian Jira (v8.3.4#803005) - To unsubscribe, e-mail: commits-unsubscr...@cassandra.apache.org For additional commands, e-mail: commits-h...@cassandra.apache.org
[jira] [Updated] (CASSANDRA-8612) Read metrics should be updated on all types of reads
[ https://issues.apache.org/jira/browse/CASSANDRA-8612?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Dean Z updated CASSANDRA-8612: -- Attachment: 0001-Update-read-metrics-on-all-types-of-reads.patch > Read metrics should be updated on all types of reads > > > Key: CASSANDRA-8612 > URL: https://issues.apache.org/jira/browse/CASSANDRA-8612 > Project: Cassandra > Issue Type: Improvement > Components: Observability/Metrics >Reporter: Chris Lohfink >Priority: Low > Labels: lhf, metrics > Attachments: 0001-Update-read-metrics-on-all-types-of-reads.patch > > > Metrics like "sstables per read" are not updated on a range slice. Although > separating things out for each type of read could make sense like we do for > latencies, only exposing the metrics for one type can be a little confusing > when people do a query and see nothing increases. I think its sufficient to > use the same metrics for all reads. -- This message was sent by Atlassian Jira (v8.3.4#803005) - To unsubscribe, e-mail: commits-unsubscr...@cassandra.apache.org For additional commands, e-mail: commits-h...@cassandra.apache.org
[jira] [Commented] (CASSANDRA-15636) Refactor protocol related code to eliminate magic numbers
[ https://issues.apache.org/jira/browse/CASSANDRA-15636?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17109444#comment-17109444 ] Dean Z commented on CASSANDRA-15636: [^patch.diff] Not sure how's this patch looks to you. Also not quite sure about the scope of this ticket. I think I've covered the messages package, is there more? > Refactor protocol related code to eliminate magic numbers > - > > Key: CASSANDRA-15636 > URL: https://issues.apache.org/jira/browse/CASSANDRA-15636 > Project: Cassandra > Issue Type: Improvement > Components: Messaging/Client >Reporter: Dinesh Joshi >Priority: Low > Attachments: patch.diff > > > Parts of Cassandra's codebase has protocol related magic numbers. It makes > the code hard to understand. We should refactor the code to remove magic > numbers and instead replace them with versioned constants. This will help > make the code clearer. Example: > https://github.com/apache/cassandra/blob/trunk/src/java/org/apache/cassandra/transport/messages/ErrorMessage.java#L288 -- This message was sent by Atlassian Jira (v8.3.4#803005) - To unsubscribe, e-mail: commits-unsubscr...@cassandra.apache.org For additional commands, e-mail: commits-h...@cassandra.apache.org
[jira] [Updated] (CASSANDRA-15636) Refactor protocol related code to eliminate magic numbers
[ https://issues.apache.org/jira/browse/CASSANDRA-15636?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel ] Dean Z updated CASSANDRA-15636: --- Attachment: patch.diff > Refactor protocol related code to eliminate magic numbers > - > > Key: CASSANDRA-15636 > URL: https://issues.apache.org/jira/browse/CASSANDRA-15636 > Project: Cassandra > Issue Type: Improvement > Components: Messaging/Client >Reporter: Dinesh Joshi >Priority: Low > Attachments: patch.diff > > > Parts of Cassandra's codebase has protocol related magic numbers. It makes > the code hard to understand. We should refactor the code to remove magic > numbers and instead replace them with versioned constants. This will help > make the code clearer. Example: > https://github.com/apache/cassandra/blob/trunk/src/java/org/apache/cassandra/transport/messages/ErrorMessage.java#L288 -- This message was sent by Atlassian Jira (v8.3.4#803005) - To unsubscribe, e-mail: commits-unsubscr...@cassandra.apache.org For additional commands, e-mail: commits-h...@cassandra.apache.org
[jira] [Commented] (CASSANDRA-15636) Refactor protocol related code to eliminate magic numbers
[ https://issues.apache.org/jira/browse/CASSANDRA-15636?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17099856#comment-17099856 ] Dean Z commented on CASSANDRA-15636: Hi [~djoshi], Seems like a good ticket for starters, let me take this one. I do have a question about this ticket. What did you meant by "versioned constants"? I assume you meant the we shall be able to get the protocol version from the name of the constants' names. But as I see the constants can be applied to either all versions or versions of a certain range like higher than v5. How do you name that? > Refactor protocol related code to eliminate magic numbers > - > > Key: CASSANDRA-15636 > URL: https://issues.apache.org/jira/browse/CASSANDRA-15636 > Project: Cassandra > Issue Type: Improvement > Components: Messaging/Client >Reporter: Dinesh Joshi >Priority: Low > > Parts of Cassandra's codebase has protocol related magic numbers. It makes > the code hard to understand. We should refactor the code to remove magic > numbers and instead replace them with versioned constants. This will help > make the code clearer. Example: > https://github.com/apache/cassandra/blob/trunk/src/java/org/apache/cassandra/transport/messages/ErrorMessage.java#L288 -- This message was sent by Atlassian Jira (v8.3.4#803005) - To unsubscribe, e-mail: commits-unsubscr...@cassandra.apache.org For additional commands, e-mail: commits-h...@cassandra.apache.org