[jira] [Commented] (CASSANDRA-2009) Move relevant methods to ByteBufferUtil (and normalize on names)

2011-07-27 Thread Sylvain Lebresne (JIRA)

[ 
https://issues.apache.org/jira/browse/CASSANDRA-2009?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13071578#comment-13071578
 ] 

Sylvain Lebresne commented on CASSANDRA-2009:
-

Note sure where the problem is. If you do:
{noformat}
update column family User with key_validation_class=ASCIIType and 
comparator=ASCIIType and default_validation_class=ASCIIType;
{noformat}
then you will be able to type:
{noformat}
set User[test_user][age]=32;
{noformat}

 Move relevant methods to ByteBufferUtil (and normalize on names)
 

 Key: CASSANDRA-2009
 URL: https://issues.apache.org/jira/browse/CASSANDRA-2009
 Project: Cassandra
  Issue Type: Improvement
  Components: Core
Reporter: Sylvain Lebresne
Assignee: Sylvain Lebresne
Priority: Trivial
 Fix For: 0.7.1

 Attachments: 
 0001-Move-and-rename-byteBufferToInt-and-toByteBuffer-int.patch, 
 0002-Move-method-to-read-a-BB-in-BBUtil-an-rename-to-matc.patch, 
 0003-Move-inputStream-to-BBUtil-and-change-clone-to-dupli.patch, 
 0004-Move-bytesToHex-BB-to-BBUtil-and-create-BBUtil.hexTo.patch

   Original Estimate: 4h
  Remaining Estimate: 4h

 A number of methods are in FBUtilities while they more naturally belong to
 ByteBufferUtil. Moreover, their naming convention conflict with some of the
 method already moved to ByteBufferUtil.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] [Commented] (CASSANDRA-2009) Move relevant methods to ByteBufferUtil (and normalize on names)

2011-07-27 Thread Martin Lansler (JIRA)

[ 
https://issues.apache.org/jira/browse/CASSANDRA-2009?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13072012#comment-13072012
 ] 

Martin Lansler commented on CASSANDRA-2009:
---

Ahh great, did not know this. I'm just starting to learn Cassandra for a 
project.

 Move relevant methods to ByteBufferUtil (and normalize on names)
 

 Key: CASSANDRA-2009
 URL: https://issues.apache.org/jira/browse/CASSANDRA-2009
 Project: Cassandra
  Issue Type: Improvement
  Components: Core
Reporter: Sylvain Lebresne
Assignee: Sylvain Lebresne
Priority: Trivial
 Fix For: 0.7.1

 Attachments: 
 0001-Move-and-rename-byteBufferToInt-and-toByteBuffer-int.patch, 
 0002-Move-method-to-read-a-BB-in-BBUtil-an-rename-to-matc.patch, 
 0003-Move-inputStream-to-BBUtil-and-change-clone-to-dupli.patch, 
 0004-Move-bytesToHex-BB-to-BBUtil-and-create-BBUtil.hexTo.patch

   Original Estimate: 4h
  Remaining Estimate: 4h

 A number of methods are in FBUtilities while they more naturally belong to
 ByteBufferUtil. Moreover, their naming convention conflict with some of the
 method already moved to ByteBufferUtil.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] [Commented] (CASSANDRA-2009) Move relevant methods to ByteBufferUtil (and normalize on names)

2011-07-26 Thread Martin Lansler (JIRA)

[ 
https://issues.apache.org/jira/browse/CASSANDRA-2009?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13071413#comment-13071413
 ] 

Martin Lansler commented on CASSANDRA-2009:
---

It would be great if the de-marshal order issue could be fixed soon, for POC:s 
and demos using cassandra-cli it becomes a pain to have to type:
set User[ascii('test-user')][ascii('age')]=ascii('32');

#2311 was fixed in 0.8.0-beta1 but it did not resolve this issue, or perhaps I 
misunderstand your comment Sylvian?


 Move relevant methods to ByteBufferUtil (and normalize on names)
 

 Key: CASSANDRA-2009
 URL: https://issues.apache.org/jira/browse/CASSANDRA-2009
 Project: Cassandra
  Issue Type: Improvement
  Components: Core
Reporter: Sylvain Lebresne
Assignee: Sylvain Lebresne
Priority: Trivial
 Fix For: 0.7.1

 Attachments: 
 0001-Move-and-rename-byteBufferToInt-and-toByteBuffer-int.patch, 
 0002-Move-method-to-read-a-BB-in-BBUtil-an-rename-to-matc.patch, 
 0003-Move-inputStream-to-BBUtil-and-change-clone-to-dupli.patch, 
 0004-Move-bytesToHex-BB-to-BBUtil-and-create-BBUtil.hexTo.patch

   Original Estimate: 4h
  Remaining Estimate: 4h

 A number of methods are in FBUtilities while they more naturally belong to
 ByteBufferUtil. Moreover, their naming convention conflict with some of the
 method already moved to ByteBufferUtil.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira




[jira] Commented: (CASSANDRA-2009) Move relevant methods to ByteBufferUtil (and normalize on names)

2011-03-13 Thread Aaron Morton (JIRA)

[ 
https://issues.apache.org/jira/browse/CASSANDRA-2009?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13006162#comment-13006162
 ] 

Aaron Morton commented on CASSANDRA-2009:
-

I just noticed using 0.8 using the FBUtilities.hexToBytes(source) in 
BytesType.fromString() means that in cassandra-cli the statement

set data['foo1']['bar']='baz';

will fail with 
org.apache.cassandra.db.marshal.MarshalException: cannot parse 'foo1' as hex 
bytes

It must now be
set data[ascii('foo1')]['bar']='baz';

Is this an unintended consequence or do we want that behavior in the cli?



 

 Move relevant methods to ByteBufferUtil (and normalize on names)
 

 Key: CASSANDRA-2009
 URL: https://issues.apache.org/jira/browse/CASSANDRA-2009
 Project: Cassandra
  Issue Type: Improvement
  Components: Core
Reporter: Sylvain Lebresne
Assignee: Sylvain Lebresne
Priority: Trivial
 Fix For: 0.7.1

 Attachments: 
 0001-Move-and-rename-byteBufferToInt-and-toByteBuffer-int.patch, 
 0002-Move-method-to-read-a-BB-in-BBUtil-an-rename-to-matc.patch, 
 0003-Move-inputStream-to-BBUtil-and-change-clone-to-dupli.patch, 
 0004-Move-bytesToHex-BB-to-BBUtil-and-create-BBUtil.hexTo.patch

   Original Estimate: 4h
  Remaining Estimate: 4h

 A number of methods are in FBUtilities while they more naturally belong to
 ByteBufferUtil. Moreover, their naming convention conflict with some of the
 method already moved to ByteBufferUtil.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] Commented: (CASSANDRA-2009) Move relevant methods to ByteBufferUtil (and normalize on names)

2011-03-13 Thread Sylvain Lebresne (JIRA)

[ 
https://issues.apache.org/jira/browse/CASSANDRA-2009?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=13006165#comment-13006165
 ] 

Sylvain Lebresne commented on CASSANDRA-2009:
-

This is actually due to CASSANDRA-2262. The best fix to this is probably 
CASSANDRA-2311, since it will also someone to say that the keys are asciiType 
for instance.

 Move relevant methods to ByteBufferUtil (and normalize on names)
 

 Key: CASSANDRA-2009
 URL: https://issues.apache.org/jira/browse/CASSANDRA-2009
 Project: Cassandra
  Issue Type: Improvement
  Components: Core
Reporter: Sylvain Lebresne
Assignee: Sylvain Lebresne
Priority: Trivial
 Fix For: 0.7.1

 Attachments: 
 0001-Move-and-rename-byteBufferToInt-and-toByteBuffer-int.patch, 
 0002-Move-method-to-read-a-BB-in-BBUtil-an-rename-to-matc.patch, 
 0003-Move-inputStream-to-BBUtil-and-change-clone-to-dupli.patch, 
 0004-Move-bytesToHex-BB-to-BBUtil-and-create-BBUtil.hexTo.patch

   Original Estimate: 4h
  Remaining Estimate: 4h

 A number of methods are in FBUtilities while they more naturally belong to
 ByteBufferUtil. Moreover, their naming convention conflict with some of the
 method already moved to ByteBufferUtil.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] Commented: (CASSANDRA-2009) Move relevant methods to ByteBufferUtil (and normalize on names)

2011-01-19 Thread Jonathan Ellis (JIRA)

[ 
https://issues.apache.org/jira/browse/CASSANDRA-2009?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12983801#action_12983801
 ] 

Jonathan Ellis commented on CASSANDRA-2009:
---

(merged to trunk, but did not address all the byte[] methods still used by 
CounterContext there)

 Move relevant methods to ByteBufferUtil (and normalize on names)
 

 Key: CASSANDRA-2009
 URL: https://issues.apache.org/jira/browse/CASSANDRA-2009
 Project: Cassandra
  Issue Type: Improvement
  Components: Core
Reporter: Sylvain Lebresne
Assignee: Sylvain Lebresne
Priority: Trivial
 Fix For: 0.7.1

 Attachments: 
 0001-Move-and-rename-byteBufferToInt-and-toByteBuffer-int.patch, 
 0002-Move-method-to-read-a-BB-in-BBUtil-an-rename-to-matc.patch, 
 0003-Move-inputStream-to-BBUtil-and-change-clone-to-dupli.patch, 
 0004-Move-bytesToHex-BB-to-BBUtil-and-create-BBUtil.hexTo.patch

   Original Estimate: 4h
  Remaining Estimate: 4h

 A number of methods are in FBUtilities while they more naturally belong to
 ByteBufferUtil. Moreover, their naming convention conflict with some of the
 method already moved to ByteBufferUtil.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.



[jira] Commented: (CASSANDRA-2009) Move relevant methods to ByteBufferUtil (and normalize on names)

2011-01-19 Thread Hudson (JIRA)

[ 
https://issues.apache.org/jira/browse/CASSANDRA-2009?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12983811#action_12983811
 ] 

Hudson commented on CASSANDRA-2009:
---

Integrated in Cassandra-0.7 #175 (See 
[https://hudson.apache.org/hudson/job/Cassandra-0.7/175/])
move FBU.hex methods to BBU
patch by slebresne; reviewed by jbellis for CASSANDRA-2009
move FBU.inputStream to BBU
patch by slebresne; reviewed by jbellis for CASSANDRA-2009
move read methods from FBU to BBU
patch by slebresne; reviewed by jbellis for CASSANDRA-2009
move and rename FBU.byteBufferToInt and toByteBuffer to BBU.toInt and BBU.bytes
patch by slebresne; reviewed by jbellis for CASSANDRA-2009


 Move relevant methods to ByteBufferUtil (and normalize on names)
 

 Key: CASSANDRA-2009
 URL: https://issues.apache.org/jira/browse/CASSANDRA-2009
 Project: Cassandra
  Issue Type: Improvement
  Components: Core
Reporter: Sylvain Lebresne
Assignee: Sylvain Lebresne
Priority: Trivial
 Fix For: 0.7.1

 Attachments: 
 0001-Move-and-rename-byteBufferToInt-and-toByteBuffer-int.patch, 
 0002-Move-method-to-read-a-BB-in-BBUtil-an-rename-to-matc.patch, 
 0003-Move-inputStream-to-BBUtil-and-change-clone-to-dupli.patch, 
 0004-Move-bytesToHex-BB-to-BBUtil-and-create-BBUtil.hexTo.patch

   Original Estimate: 4h
  Remaining Estimate: 4h

 A number of methods are in FBUtilities while they more naturally belong to
 ByteBufferUtil. Moreover, their naming convention conflict with some of the
 method already moved to ByteBufferUtil.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.



[jira] Commented: (CASSANDRA-2009) Move relevant methods to ByteBufferUtil (and normalize on names)

2011-01-19 Thread Sylvain Lebresne (JIRA)

[ 
https://issues.apache.org/jira/browse/CASSANDRA-2009?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanelfocusedCommentId=12983892#action_12983892
 ] 

Sylvain Lebresne commented on CASSANDRA-2009:
-

Yeah the last methods on byte[] used by CounterContext will go away with #1936 
(attached patch does remove them)

 Move relevant methods to ByteBufferUtil (and normalize on names)
 

 Key: CASSANDRA-2009
 URL: https://issues.apache.org/jira/browse/CASSANDRA-2009
 Project: Cassandra
  Issue Type: Improvement
  Components: Core
Reporter: Sylvain Lebresne
Assignee: Sylvain Lebresne
Priority: Trivial
 Fix For: 0.7.1

 Attachments: 
 0001-Move-and-rename-byteBufferToInt-and-toByteBuffer-int.patch, 
 0002-Move-method-to-read-a-BB-in-BBUtil-an-rename-to-matc.patch, 
 0003-Move-inputStream-to-BBUtil-and-change-clone-to-dupli.patch, 
 0004-Move-bytesToHex-BB-to-BBUtil-and-create-BBUtil.hexTo.patch

   Original Estimate: 4h
  Remaining Estimate: 4h

 A number of methods are in FBUtilities while they more naturally belong to
 ByteBufferUtil. Moreover, their naming convention conflict with some of the
 method already moved to ByteBufferUtil.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.