[jira] [Commented] (HADOOP-9668) Configuration#iterator method should interpret variables in a property as well as Configuration#get method

2014-09-14 Thread Hadoop QA (JIRA)

[ 
https://issues.apache.org/jira/browse/HADOOP-9668?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14133310#comment-14133310
 ] 

Hadoop QA commented on HADOOP-9668:
---

{color:red}-1 overall{color}.  Here are the results of testing the latest 
attachment 
  http://issues.apache.org/jira/secure/attachment/12594804/HADOOP-9668.patch
  against trunk revision 14e2639.

{color:red}-1 patch{color}.  The patch command could not apply the patch.

Console output: 
https://builds.apache.org/job/PreCommit-HADOOP-Build/4721//console

This message is automatically generated.

> Configuration#iterator method should interpret variables in a property as 
> well as Configuration#get method
> --
>
> Key: HADOOP-9668
> URL: https://issues.apache.org/jira/browse/HADOOP-9668
> Project: Hadoop Common
>  Issue Type: Bug
>  Components: conf
>Affects Versions: 2.1.0-beta, 1.2.1
>Reporter: Kousuke Saruta
>Assignee: Kousuke Saruta
>Priority: Minor
>  Labels: newbie
> Attachments: HADOOP-9668-branch-2.1.0-beta.patch, HADOOP-9668.patch, 
> HADOOP-9668.patch
>
>
> o.a.h.conf.Configuration#get method interpret variables in a property in 
> *-site.xml but Configuration#iterator method doesn't.
> For example, when a property "user.name" is set to "hadoop" and another 
> property "hadoop.tmp.dir" is set to "/tmp/${user.name}", Configuration#get 
> interpret "hadoop.tmp.dir" as "/tmp/hadoop" but Configuration#iterator 
> doesn't interpret.
> I think Configuration#iterator should interpret variables or if there are 
> some reasons, it should be documented that Configuration#iterator doesn't 
> interpret variables.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Commented] (HADOOP-9668) Configuration#iterator method should interpret variables in a property as well as Configuration#get method

2013-07-29 Thread Hadoop QA (JIRA)

[ 
https://issues.apache.org/jira/browse/HADOOP-9668?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13723208#comment-13723208
 ] 

Hadoop QA commented on HADOOP-9668:
---

{color:green}+1 overall{color}.  Here are the results of testing the latest 
attachment 
  http://issues.apache.org/jira/secure/attachment/12594804/HADOOP-9668.patch
  against trunk revision .

{color:green}+1 @author{color}.  The patch does not contain any @author 
tags.

{color:green}+1 tests included{color}.  The patch appears to include 1 new 
or modified test files.

{color:green}+1 javac{color}.  The applied patch does not increase the 
total number of javac compiler warnings.

{color:green}+1 javadoc{color}.  The javadoc tool did not generate any 
warning messages.

{color:green}+1 eclipse:eclipse{color}.  The patch built with 
eclipse:eclipse.

{color:green}+1 findbugs{color}.  The patch does not introduce any new 
Findbugs (version 1.3.9) warnings.

{color:green}+1 release audit{color}.  The applied patch does not increase 
the total number of release audit warnings.

{color:green}+1 core tests{color}.  The patch passed unit tests in 
hadoop-common-project/hadoop-common.

{color:green}+1 contrib tests{color}.  The patch passed contrib unit tests.

Test results: 
https://builds.apache.org/job/PreCommit-HADOOP-Build/2872//testReport/
Console output: 
https://builds.apache.org/job/PreCommit-HADOOP-Build/2872//console

This message is automatically generated.

> Configuration#iterator method should interpret variables in a property as 
> well as Configuration#get method
> --
>
> Key: HADOOP-9668
> URL: https://issues.apache.org/jira/browse/HADOOP-9668
> Project: Hadoop Common
>  Issue Type: Bug
>  Components: conf
>Affects Versions: 2.1.0-beta, 1.2.1
>Reporter: Kousuke Saruta
>Priority: Minor
>  Labels: newbie
> Attachments: HADOOP-9668-branch-2.1.0-beta.patch, HADOOP-9668.patch, 
> HADOOP-9668.patch
>
>
> o.a.h.conf.Configuration#get method interpret variables in a property in 
> *-site.xml but Configuration#iterator method doesn't.
> For example, when a property "user.name" is set to "hadoop" and another 
> property "hadoop.tmp.dir" is set to "/tmp/${user.name}", Configuration#get 
> interpret "hadoop.tmp.dir" as "/tmp/hadoop" but Configuration#iterator 
> doesn't interpret.
> I think Configuration#iterator should interpret variables or if there are 
> some reasons, it should be documented that Configuration#iterator doesn't 
> interpret variables.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (HADOOP-9668) Configuration#iterator method should interpret variables in a property as well as Configuration#get method

2013-07-17 Thread Kousuke Saruta (JIRA)

[ 
https://issues.apache.org/jira/browse/HADOOP-9668?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13710898#comment-13710898
 ] 

Kousuke Saruta commented on HADOOP-9668:


ReconfigurationUtil have a method to get changes between two Configuration 
instances without expanding variables.
So, we should also add a new public method to ReconfigurationUtil class so that 
we can get changes between two Configuration instances with expanding variables.
And I will try to re-write TestReconfigurationUtil to test 
Configuration#iteratorWithVariable ( or iteratorExpandingVariables may be 
better name ) and the new public method in ReconfigurationUtil.

> Configuration#iterator method should interpret variables in a property as 
> well as Configuration#get method
> --
>
> Key: HADOOP-9668
> URL: https://issues.apache.org/jira/browse/HADOOP-9668
> Project: Hadoop Common
>  Issue Type: Bug
>  Components: conf
>Affects Versions: 2.1.0-beta, 1.2.1
>Reporter: Kousuke Saruta
>Priority: Minor
>  Labels: newbie
> Attachments: HADOOP-9668-branch-2.1.0-beta.patch, HADOOP-9668.patch
>
>
> o.a.h.conf.Configuration#get method interpret variables in a property in 
> *-site.xml but Configuration#iterator method doesn't.
> For example, when a property "user.name" is set to "hadoop" and another 
> property "hadoop.tmp.dir" is set to "/tmp/${user.name}", Configuration#get 
> interpret "hadoop.tmp.dir" as "/tmp/hadoop" but Configuration#iterator 
> doesn't interpret.
> I think Configuration#iterator should interpret variables or if there are 
> some reasons, it should be documented that Configuration#iterator doesn't 
> interpret variables.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (HADOOP-9668) Configuration#iterator method should interpret variables in a property as well as Configuration#get method

2013-07-17 Thread Kousuke Saruta (JIRA)

[ 
https://issues.apache.org/jira/browse/HADOOP-9668?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13710815#comment-13710815
 ] 

Kousuke Saruta commented on HADOOP-9668:


I found there is getRaw method in Configuration which get the value of a 
property and TestReconfiguration uses it to compare each properties which have 
same keys without interpreting variables.
So, I suggest adding iteratorWithVariable method instead of modifying iterator 
method.

> Configuration#iterator method should interpret variables in a property as 
> well as Configuration#get method
> --
>
> Key: HADOOP-9668
> URL: https://issues.apache.org/jira/browse/HADOOP-9668
> Project: Hadoop Common
>  Issue Type: Bug
>  Components: conf
>Affects Versions: 2.1.0-beta, 1.2.1
>Reporter: Kousuke Saruta
>Priority: Minor
>  Labels: newbie
> Attachments: HADOOP-9668-branch-2.1.0-beta.patch, HADOOP-9668.patch
>
>
> o.a.h.conf.Configuration#get method interpret variables in a property in 
> *-site.xml but Configuration#iterator method doesn't.
> For example, when a property "user.name" is set to "hadoop" and another 
> property "hadoop.tmp.dir" is set to "/tmp/${user.name}", Configuration#get 
> interpret "hadoop.tmp.dir" as "/tmp/hadoop" but Configuration#iterator 
> doesn't interpret.
> I think Configuration#iterator should interpret variables or if there are 
> some reasons, it should be documented that Configuration#iterator doesn't 
> interpret variables.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (HADOOP-9668) Configuration#iterator method should interpret variables in a property as well as Configuration#get method

2013-07-16 Thread Hadoop QA (JIRA)

[ 
https://issues.apache.org/jira/browse/HADOOP-9668?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13710728#comment-13710728
 ] 

Hadoop QA commented on HADOOP-9668:
---

{color:red}-1 overall{color}.  Here are the results of testing the latest 
attachment 
  http://issues.apache.org/jira/secure/attachment/12592704/HADOOP-9668.patch
  against trunk revision .

{color:green}+1 @author{color}.  The patch does not contain any @author 
tags.

{color:red}-1 tests included{color}.  The patch doesn't appear to include 
any new or modified tests.
Please justify why no new tests are needed for this 
patch.
Also please list what manual steps were performed to 
verify this patch.

{color:green}+1 javac{color}.  The applied patch does not increase the 
total number of javac compiler warnings.

{color:green}+1 javadoc{color}.  The javadoc tool did not generate any 
warning messages.

{color:green}+1 eclipse:eclipse{color}.  The patch built with 
eclipse:eclipse.

{color:green}+1 findbugs{color}.  The patch does not introduce any new 
Findbugs (version 1.3.9) warnings.

{color:green}+1 release audit{color}.  The applied patch does not increase 
the total number of release audit warnings.

{color:red}-1 core tests{color}.  The patch failed these unit tests in 
hadoop-common-project/hadoop-common:

  org.apache.hadoop.conf.TestReconfiguration

{color:green}+1 contrib tests{color}.  The patch passed contrib unit tests.

Test results: 
https://builds.apache.org/job/PreCommit-HADOOP-Build/2794//testReport/
Console output: 
https://builds.apache.org/job/PreCommit-HADOOP-Build/2794//console

This message is automatically generated.

> Configuration#iterator method should interpret variables in a property as 
> well as Configuration#get method
> --
>
> Key: HADOOP-9668
> URL: https://issues.apache.org/jira/browse/HADOOP-9668
> Project: Hadoop Common
>  Issue Type: Bug
>  Components: conf
>Affects Versions: 2.1.0-beta, 1.2.1
>Reporter: Kousuke Saruta
>Priority: Minor
>  Labels: newbie
> Attachments: HADOOP-9668-branch-2.1.0-beta.patch, HADOOP-9668.patch
>
>
> o.a.h.conf.Configuration#get method interpret variables in a property in 
> *-site.xml but Configuration#iterator method doesn't.
> For example, when a property "user.name" is set to "hadoop" and another 
> property "hadoop.tmp.dir" is set to "/tmp/${user.name}", Configuration#get 
> interpret "hadoop.tmp.dir" as "/tmp/hadoop" but Configuration#iterator 
> doesn't interpret.
> I think Configuration#iterator should interpret variables or if there are 
> some reasons, it should be documented that Configuration#iterator doesn't 
> interpret variables.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (HADOOP-9668) Configuration#iterator method should interpret variables in a property as well as Configuration#get method

2013-07-16 Thread Kousuke Saruta (JIRA)

[ 
https://issues.apache.org/jira/browse/HADOOP-9668?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13710577#comment-13710577
 ] 

Kousuke Saruta commented on HADOOP-9668:


Jing, I will try it.

> Configuration#iterator method should interpret variables in a property as 
> well as Configuration#get method
> --
>
> Key: HADOOP-9668
> URL: https://issues.apache.org/jira/browse/HADOOP-9668
> Project: Hadoop Common
>  Issue Type: Bug
>  Components: conf
>Affects Versions: 2.1.0-beta, 1.2.1
>Reporter: Kousuke Saruta
>Priority: Minor
>  Labels: newbie
> Attachments: HADOOP-9668-branch-2.1.0-beta.patch
>
>
> o.a.h.conf.Configuration#get method interpret variables in a property in 
> *-site.xml but Configuration#iterator method doesn't.
> For example, when a property "user.name" is set to "hadoop" and another 
> property "hadoop.tmp.dir" is set to "/tmp/${user.name}", Configuration#get 
> interpret "hadoop.tmp.dir" as "/tmp/hadoop" but Configuration#iterator 
> doesn't interpret.
> I think Configuration#iterator should interpret variables or if there are 
> some reasons, it should be documented that Configuration#iterator doesn't 
> interpret variables.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (HADOOP-9668) Configuration#iterator method should interpret variables in a property as well as Configuration#get method

2013-07-16 Thread Jing Zhao (JIRA)

[ 
https://issues.apache.org/jira/browse/HADOOP-9668?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13710019#comment-13710019
 ] 

Jing Zhao commented on HADOOP-9668:
---

Thanks Kousuke! Looks like the reported issue is also in trunk. Mind also 
uploading a patch for trunk?

> Configuration#iterator method should interpret variables in a property as 
> well as Configuration#get method
> --
>
> Key: HADOOP-9668
> URL: https://issues.apache.org/jira/browse/HADOOP-9668
> Project: Hadoop Common
>  Issue Type: Bug
>  Components: conf
>Affects Versions: 2.1.0-beta, 1.2.1
>Reporter: Kousuke Saruta
>Priority: Minor
>  Labels: newbie
> Attachments: HADOOP-9668-branch-2.1.0-beta.patch
>
>
> o.a.h.conf.Configuration#get method interpret variables in a property in 
> *-site.xml but Configuration#iterator method doesn't.
> For example, when a property "user.name" is set to "hadoop" and another 
> property "hadoop.tmp.dir" is set to "/tmp/${user.name}", Configuration#get 
> interpret "hadoop.tmp.dir" as "/tmp/hadoop" but Configuration#iterator 
> doesn't interpret.
> I think Configuration#iterator should interpret variables or if there are 
> some reasons, it should be documented that Configuration#iterator doesn't 
> interpret variables.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (HADOOP-9668) Configuration#iterator method should interpret variables in a property as well as Configuration#get method

2013-07-14 Thread Kousuke Saruta (JIRA)

[ 
https://issues.apache.org/jira/browse/HADOOP-9668?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13708227#comment-13708227
 ] 

Kousuke Saruta commented on HADOOP-9668:


OK. I agree.

> Configuration#iterator method should interpret variables in a property as 
> well as Configuration#get method
> --
>
> Key: HADOOP-9668
> URL: https://issues.apache.org/jira/browse/HADOOP-9668
> Project: Hadoop Common
>  Issue Type: Bug
>  Components: conf
>Affects Versions: 2.1.0-beta, 1.2.1
>Reporter: Kousuke Saruta
>Priority: Minor
>  Labels: newbie
>
> o.a.h.conf.Configuration#get method interpret variables in a property in 
> *-site.xml but Configuration#iterator method doesn't.
> For example, when a property "user.name" is set to "hadoop" and another 
> property "hadoop.tmp.dir" is set to "/tmp/${user.name}", Configuration#get 
> interpret "hadoop.tmp.dir" as "/tmp/hadoop" but Configuration#iterator 
> doesn't interpret.
> I think Configuration#iterator should interpret variables or if there are 
> some reasons, it should be documented that Configuration#iterator doesn't 
> interpret variables.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (HADOOP-9668) Configuration#iterator method should interpret variables in a property as well as Configuration#get method

2013-07-14 Thread Matt Foley (JIRA)

[ 
https://issues.apache.org/jira/browse/HADOOP-9668?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13708162#comment-13708162
 ] 

Matt Foley commented on HADOOP-9668:


Since work has not yet started, and we are about to produce 1.2.1-rc, deferring 
this to 1.3.0.

> Configuration#iterator method should interpret variables in a property as 
> well as Configuration#get method
> --
>
> Key: HADOOP-9668
> URL: https://issues.apache.org/jira/browse/HADOOP-9668
> Project: Hadoop Common
>  Issue Type: Bug
>  Components: conf
>Affects Versions: 2.1.0-beta, 1.2.1
>Reporter: Kousuke Saruta
>Priority: Minor
>  Labels: newbie
>
> o.a.h.conf.Configuration#get method interpret variables in a property in 
> *-site.xml but Configuration#iterator method doesn't.
> For example, when a property "user.name" is set to "hadoop" and another 
> property "hadoop.tmp.dir" is set to "/tmp/${user.name}", Configuration#get 
> interpret "hadoop.tmp.dir" as "/tmp/hadoop" but Configuration#iterator 
> doesn't interpret.
> I think Configuration#iterator should interpret variables or if there are 
> some reasons, it should be documented that Configuration#iterator doesn't 
> interpret variables.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira