RFR: 8274079: Cleanup unnecessary calls to Throwable.initCause() in java.base module

2021-09-21 Thread Andrey Turbanov
Pass "cause" exception as constructor parameter is shorter and easier to read.

-

Commit messages:
 - [PATCH] Cleanup unnecessary calls to Throwable.initCause() in java.base 
module

Changes: https://git.openjdk.java.net/jdk/pull/5551/files
 Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=5551&range=00
  Issue: https://bugs.openjdk.java.net/browse/JDK-8274079
  Stats: 133 lines in 22 files changed: 0 ins; 77 del; 56 mod
  Patch: https://git.openjdk.java.net/jdk/pull/5551.diff
  Fetch: git fetch https://git.openjdk.java.net/jdk pull/5551/head:pull/5551

PR: https://git.openjdk.java.net/jdk/pull/5551


Re: RFR: 8274079: Cleanup unnecessary calls to Throwable.initCause() in java.base module

2021-09-21 Thread Pavel Rappo
On Thu, 16 Sep 2021 19:03:26 GMT, Andrey Turbanov 
 wrote:

> Pass "cause" exception as constructor parameter is shorter and easier to read.

This will need to be thoroughly tested to make sure there were no implicit 
dependencies on now-removed happens-before edges (`initCause` is synchronized). 
That said, the idea behind this clean-up looks good.

-

PR: https://git.openjdk.java.net/jdk/pull/5551


Re: RFR: 8274079: Cleanup unnecessary calls to Throwable.initCause() in java.base module

2021-09-21 Thread Weijun Wang
On Thu, 16 Sep 2021 19:03:26 GMT, Andrey Turbanov 
 wrote:

> Pass "cause" exception as constructor parameter is shorter and easier to read.

Looks fine. Thanks.

-

Marked as reviewed by weijun (Reviewer).

PR: https://git.openjdk.java.net/jdk/pull/5551