Re: RFR: 8274394: Use Optional.isEmpty instead of !Optional.isPresent in jdk.jlink

2021-09-28 Thread Mandy Chung
On Sun, 26 Sep 2021 13:58:35 GMT, Andrey Turbanov 
 wrote:

> I propose to replace usages of !Optional.isPresent() with Optional.isEmpty 
> method.
> It's makes code a bit easier to read.
> Noticing negation before long chain of method calls is hard.

LGTM

-

Marked as reviewed by mchung (Reviewer).

PR: https://git.openjdk.java.net/jdk/pull/5707


Re: RFR: 8274394: Use Optional.isEmpty instead of !Optional.isPresent in jdk.jlink

2021-09-28 Thread Alan Bateman
On Sun, 26 Sep 2021 13:58:35 GMT, Andrey Turbanov 
 wrote:

> I propose to replace usages of !Optional.isPresent() with Optional.isEmpty 
> method.
> It's makes code a bit easier to read.
> Noticing negation before long chain of method calls is hard.

Looks okay, this code pre-dates the isEmpty method.

-

Marked as reviewed by alanb (Reviewer).

PR: https://git.openjdk.java.net/jdk/pull/5707


RFR: 8274394: Use Optional.isEmpty instead of !Optional.isPresent in jdk.jlink

2021-09-27 Thread Andrey Turbanov
I propose to replace usages of !Optional.isPresent() with Optional.isEmpty 
method.
It's makes code a bit easier to read.
Noticing negation before long chain of method calls is hard.

-

Commit messages:
 - [PATCH] Use Optional.isEmpty instead of !Optional.isPresent in jdk.jlink

Changes: https://git.openjdk.java.net/jdk/pull/5707/files
 Webrev: https://webrevs.openjdk.java.net/?repo=jdk&pr=5707&range=00
  Issue: https://bugs.openjdk.java.net/browse/JDK-8274394
  Stats: 8 lines in 5 files changed: 0 ins; 0 del; 8 mod
  Patch: https://git.openjdk.java.net/jdk/pull/5707.diff
  Fetch: git fetch https://git.openjdk.java.net/jdk pull/5707/head:pull/5707

PR: https://git.openjdk.java.net/jdk/pull/5707