Re: RFR: 8283800: Simplify String.indexOf/lastIndexOf calls

2022-03-28 Thread Leonid Mesnik
On Sun, 20 Mar 2022 12:45:34 GMT, Andrey Turbanov  wrote:

> In a few places String.indexOf/lastIndexOf methods are called with default 
> parameter for index: `0` for `indexOf`, length() for `lastIndexOf`.
> I propose to cleanup such calls. It makes code a bit easier to read. In case 
> of `indexOf` it even could be faster, as there is separate intrinsic for 
> `indexOf` call without index argument.

Marked as reviewed by lmesnik (Reviewer).

-

PR: https://git.openjdk.java.net/jdk/pull/7877


Re: RFR: 8283800: Simplify String.indexOf/lastIndexOf calls

2022-03-28 Thread Xue-Lei Andrew Fan
On Sun, 20 Mar 2022 12:45:34 GMT, Andrey Turbanov  wrote:

> In a few places String.indexOf/lastIndexOf methods are called with default 
> parameter for index: `0` for `indexOf`, length() for `lastIndexOf`.
> I propose to cleanup such calls. It makes code a bit easier to read. In case 
> of `indexOf` it even could be faster, as there is separate intrinsic for 
> `indexOf` call without index argument.

Please add a noreg- label to the bug.  Otherwise, looks good to me.

-

Marked as reviewed by xuelei (Reviewer).

PR: https://git.openjdk.java.net/jdk/pull/7877


Re: RFR: 8283800: Simplify String.indexOf/lastIndexOf calls

2022-03-28 Thread Brian Burkhalter
On Sun, 20 Mar 2022 12:45:34 GMT, Andrey Turbanov  wrote:

> In a few places String.indexOf/lastIndexOf methods are called with default 
> parameter for index: `0` for `indexOf`, length() for `lastIndexOf`.
> I propose to cleanup such calls. It makes code a bit easier to read. In case 
> of `indexOf` it even could be faster, as there is separate intrinsic for 
> `indexOf` call without index argument.

Marked as reviewed by bpb (Reviewer).

-

PR: https://git.openjdk.java.net/jdk/pull/7877


RFR: 8283800: Simplify String.indexOf/lastIndexOf calls

2022-03-28 Thread Andrey Turbanov
In a few places String.indexOf/lastIndexOf methods are called with default 
parameter for index: `0` for `indexOf`, length() for `lastIndexOf`.
I propose to cleanup such calls. It makes code a bit easier to read. In case of 
`indexOf` it even could be faster, as there is separate intrinsic for `indexOf` 
call without index argument.

-

Commit messages:
 - [PATCH] Simplify String.indexOf/lastIndexOf calls

Changes: https://git.openjdk.java.net/jdk/pull/7877/files
 Webrev: https://webrevs.openjdk.java.net/?repo=jdk=7877=00
  Issue: https://bugs.openjdk.java.net/browse/JDK-8283800
  Stats: 14 lines in 6 files changed: 0 ins; 0 del; 14 mod
  Patch: https://git.openjdk.java.net/jdk/pull/7877.diff
  Fetch: git fetch https://git.openjdk.java.net/jdk pull/7877/head:pull/7877

PR: https://git.openjdk.java.net/jdk/pull/7877