Re: name2() solved

1999-09-18 Thread Michael Alan Dorman
Paul Harris <[EMAIL PROTECTED]> writes:
> header files, but what is the "correct" way to code this functionality? if
> its not in the stdc++ headers, how are people supposed to solve similar
> problems that name2() solved? (even tho its pretty damn simple code).

Speaking without having looked at anything but the fragment that you
posted, I'm betting the token pasting (the ##) is being used to try
and simulate something using preprocessor macros that is now a defined
part of ISO C++.

So, unfortunately, I suspect the answer to your last question is "big
rewrite".

Mike.



name2() solved

1999-09-18 Thread Paul Harris
don't go away, i have a "standardising" question for the gurus:

vrweb used a function called name2() that i eventually found in the
libg++2.8.2-dev package in /usr/include/g++-2/generic.h

#define name2(a,b) gEnErIc2(a,b)
#define gEnErIc2(a,b) a ## b

now dselect tells me:

libg++2.8.2-dev - The GNU C++ extension library - development files.
This package contains some GNU classes.
This package is no longer supported upstream (as most of its functionality
is now in the standard C++ library) - do not use this for development of
new software; use libstdc++ instead.


at the moment i just copy pasted the two above lines into one of vrweb's
header files, but what is the "correct" way to code this functionality? if
its not in the stdc++ headers, how are people supposed to solve similar
problems that name2() solved? (even tho its pretty damn simple code).

hope you can help, 
Paul

ps Fabien: i'm just sending this to you so that you don't worry about
answering my last email if you were thinking about it...



name2()

1999-09-17 Thread Paul Harris
hi

the current problem is involving a function called name2() eg:

from tifs.h
Fieldsdeclare(name2(TIOINETFactoriesBase,Base),TIOINETFactoryPtr)
from fields.h
class name2(TIOINETFactoriesBase,Base) {
 

see how its used in #defs and is used as the name for a class? what is
that all about? what could this function be? i searched all my header
files on my entire system and could not find a declaration for it... it
looks like something from the package (vrweb), but i could only find it
used, not declared.

its causing problems like: 
vrweb-1.5/src/common/Dispatch/tifs.h:57: parse error before `,'

where line 57 is that "from tifs.h" line above (i unrolled the #defines).

any ideas? i have no idea what to do about this one (i'm more of a C guy).

thanks
Paul