[jira] [Commented] (HIVE-4025) Add reflect UDF for member method invocation of column

2013-02-22 Thread Hudson (JIRA)

[ 
https://issues.apache.org/jira/browse/HIVE-4025?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13584574#comment-13584574
 ] 

Hudson commented on HIVE-4025:
--

Integrated in Hive-trunk-hadoop2 #134 (See 
[https://builds.apache.org/job/Hive-trunk-hadoop2/134/])
HIVE-4025 Add reflect UDF for member method invocation of column
(Navis via namit) (Revision 1448900)

 Result = FAILURE
namit : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1448900
Files : 
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/FunctionRegistry.java
* 
/hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/udf/generic/AbstractGenericUDFReflect.java
* 
/hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/udf/generic/GenericUDFReflect.java
* 
/hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/udf/generic/GenericUDFReflect2.java
* /hive/trunk/ql/src/test/queries/clientpositive/udf_reflect2.q
* /hive/trunk/ql/src/test/results/clientpositive/show_functions.q.out
* /hive/trunk/ql/src/test/results/clientpositive/udf_reflect2.q.out


> Add reflect UDF for member method invocation of column
> --
>
> Key: HIVE-4025
> URL: https://issues.apache.org/jira/browse/HIVE-4025
> Project: Hive
>  Issue Type: Improvement
>  Components: UDF
>Reporter: Navis
>Assignee: Navis
>Priority: Trivial
> Fix For: 0.11.0
>
> Attachments: HIVE-4025.D8601.1.patch, HIVE-4025.D8601.2.patch
>
>
> There are many useful non-static methods on type of primitive types. But 
> current reflect UDF cannot invoke those. For example,
> select reflect2(value, "replace", "val", "VALUE") from src;
> which replaces 'val' part of value column with 'VALUE'

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (HIVE-4025) Add reflect UDF for member method invocation of column

2013-02-22 Thread Hudson (JIRA)

[ 
https://issues.apache.org/jira/browse/HIVE-4025?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13584355#comment-13584355
 ] 

Hudson commented on HIVE-4025:
--

Integrated in Hive-trunk-h0.21 #1982 (See 
[https://builds.apache.org/job/Hive-trunk-h0.21/1982/])
HIVE-4025 Add reflect UDF for member method invocation of column
(Navis via namit) (Revision 1448900)

 Result = SUCCESS
namit : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1448900
Files : 
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/FunctionRegistry.java
* 
/hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/udf/generic/AbstractGenericUDFReflect.java
* 
/hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/udf/generic/GenericUDFReflect.java
* 
/hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/udf/generic/GenericUDFReflect2.java
* /hive/trunk/ql/src/test/queries/clientpositive/udf_reflect2.q
* /hive/trunk/ql/src/test/results/clientpositive/show_functions.q.out
* /hive/trunk/ql/src/test/results/clientpositive/udf_reflect2.q.out


> Add reflect UDF for member method invocation of column
> --
>
> Key: HIVE-4025
> URL: https://issues.apache.org/jira/browse/HIVE-4025
> Project: Hive
>  Issue Type: Improvement
>  Components: UDF
>Reporter: Navis
>Assignee: Navis
>Priority: Trivial
> Fix For: 0.11.0
>
> Attachments: HIVE-4025.D8601.1.patch, HIVE-4025.D8601.2.patch
>
>
> There are many useful non-static methods on type of primitive types. But 
> current reflect UDF cannot invoke those. For example,
> select reflect2(value, "replace", "val", "VALUE") from src;
> which replaces 'val' part of value column with 'VALUE'

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (HIVE-4025) Add reflect UDF for member method invocation of column

2013-02-22 Thread Hudson (JIRA)

[ 
https://issues.apache.org/jira/browse/HIVE-4025?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13584127#comment-13584127
 ] 

Hudson commented on HIVE-4025:
--

Integrated in hive-trunk-hadoop1 #97 (See 
[https://builds.apache.org/job/hive-trunk-hadoop1/97/])
HIVE-4025 Add reflect UDF for member method invocation of column
(Navis via namit) (Revision 1448900)

 Result = ABORTED
namit : http://svn.apache.org/viewcvs.cgi/?root=Apache-SVN&view=rev&rev=1448900
Files : 
* /hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/exec/FunctionRegistry.java
* 
/hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/udf/generic/AbstractGenericUDFReflect.java
* 
/hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/udf/generic/GenericUDFReflect.java
* 
/hive/trunk/ql/src/java/org/apache/hadoop/hive/ql/udf/generic/GenericUDFReflect2.java
* /hive/trunk/ql/src/test/queries/clientpositive/udf_reflect2.q
* /hive/trunk/ql/src/test/results/clientpositive/show_functions.q.out
* /hive/trunk/ql/src/test/results/clientpositive/udf_reflect2.q.out


> Add reflect UDF for member method invocation of column
> --
>
> Key: HIVE-4025
> URL: https://issues.apache.org/jira/browse/HIVE-4025
> Project: Hive
>  Issue Type: Improvement
>  Components: UDF
>Reporter: Navis
>Assignee: Navis
>Priority: Trivial
> Fix For: 0.11.0
>
> Attachments: HIVE-4025.D8601.1.patch, HIVE-4025.D8601.2.patch
>
>
> There are many useful non-static methods on type of primitive types. But 
> current reflect UDF cannot invoke those. For example,
> select reflect2(value, "replace", "val", "VALUE") from src;
> which replaces 'val' part of value column with 'VALUE'

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (HIVE-4025) Add reflect UDF for member method invocation of column

2013-02-21 Thread Namit Jain (JIRA)

[ 
https://issues.apache.org/jira/browse/HIVE-4025?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13583878#comment-13583878
 ] 

Namit Jain commented on HIVE-4025:
--

+1

> Add reflect UDF for member method invocation of column
> --
>
> Key: HIVE-4025
> URL: https://issues.apache.org/jira/browse/HIVE-4025
> Project: Hive
>  Issue Type: Improvement
>  Components: UDF
>Reporter: Navis
>Assignee: Navis
>Priority: Trivial
> Attachments: HIVE-4025.D8601.1.patch, HIVE-4025.D8601.2.patch
>
>
> There are many useful non-static methods on type of primitive types. But 
> current reflect UDF cannot invoke those. For example,
> select reflect2(value, "replace", "val", "VALUE") from src;
> which replaces 'val' part of value column with 'VALUE'

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (HIVE-4025) Add reflect UDF for member method invocation of column

2013-02-21 Thread Phabricator (JIRA)

[ 
https://issues.apache.org/jira/browse/HIVE-4025?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13583412#comment-13583412
 ] 

Phabricator commented on HIVE-4025:
---

brock has commented on the revision "HIVE-4025 [jira] Add reflect UDF for 
member method invocation of column".

  Agreed, naming is hard. I like the fact that both methods start with reflect. 
Perhaps reflect2 is as good as we can do. It's not likely we'll end up with 
reflect5_1().

REVISION DETAIL
  https://reviews.facebook.net/D8601

To: JIRA, navis
Cc: njain, brock


> Add reflect UDF for member method invocation of column
> --
>
> Key: HIVE-4025
> URL: https://issues.apache.org/jira/browse/HIVE-4025
> Project: Hive
>  Issue Type: Improvement
>  Components: UDF
>Reporter: Navis
>Assignee: Navis
>Priority: Trivial
> Attachments: HIVE-4025.D8601.1.patch
>
>
> There are many useful non-static methods on type of primitive types. But 
> current reflect UDF cannot invoke those. For example,
> select reflect2(value, "replace", "val", "VALUE") from src;
> which replaces 'val' part of value column with 'VALUE'

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (HIVE-4025) Add reflect UDF for member method invocation of column

2013-02-20 Thread Phabricator (JIRA)

[ 
https://issues.apache.org/jira/browse/HIVE-4025?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13582889#comment-13582889
 ] 

Phabricator commented on HIVE-4025:
---

navis has commented on the revision "HIVE-4025 [jira] Add reflect UDF for 
member method invocation of column".

  I've thought the name like "reflect_instance" or something, but found current 
"reflect" can invoke method of instance also(by calling default constructor of 
target class).

  Naming is hard. How about "type_reflect"?

REVISION DETAIL
  https://reviews.facebook.net/D8601

To: JIRA, navis
Cc: njain, brock


> Add reflect UDF for member method invocation of column
> --
>
> Key: HIVE-4025
> URL: https://issues.apache.org/jira/browse/HIVE-4025
> Project: Hive
>  Issue Type: Improvement
>  Components: UDF
>Reporter: Navis
>Assignee: Navis
>Priority: Trivial
> Attachments: HIVE-4025.D8601.1.patch
>
>
> There are many useful non-static methods on type of primitive types. But 
> current reflect UDF cannot invoke those. For example,
> select reflect2(value, "replace", "val", "VALUE") from src;
> which replaces 'val' part of value column with 'VALUE'

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (HIVE-4025) Add reflect UDF for member method invocation of column

2013-02-20 Thread Phabricator (JIRA)

[ 
https://issues.apache.org/jira/browse/HIVE-4025?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13582886#comment-13582886
 ] 

Phabricator commented on HIVE-4025:
---

navis has commented on the revision "HIVE-4025 [jira] Add reflect UDF for 
member method invocation of column".

INLINE COMMENTS
  ql/src/test/results/clientpositive/udf_reflect2.q.out:312 I'll update that.

  bq. The last columns seem to be wrong:
  It's right result for TimeStamp class.

  getYear()
   * Returns a value that is the result of subtracting 1900 from the
   * year that contains or begins with the instant in time represented
   * by this Date object, as interpreted in the local
   * time zone.

  getMonth()
   * Returns a number representing the month that contains or begins
   * with the instant in time represented by this Date object.
   * The value returned is between 0 and 11,
   * with the value 0 representing January.

  getDay()
   * Returns the day of the week represented by this date. The
   * returned value (0 = Sunday, 1 = Monday,
   * 2 = Tuesday, 3 = Wednesday, 4 =
   * Thursday, 5 = Friday, 6 = Saturday)
   * represents the day of the week that contains or begins with
   * the instant in time represented by this Date object,
   * as interpreted in the local time zone.

REVISION DETAIL
  https://reviews.facebook.net/D8601

To: JIRA, navis
Cc: njain, brock


> Add reflect UDF for member method invocation of column
> --
>
> Key: HIVE-4025
> URL: https://issues.apache.org/jira/browse/HIVE-4025
> Project: Hive
>  Issue Type: Improvement
>  Components: UDF
>Reporter: Navis
>Assignee: Navis
>Priority: Trivial
> Attachments: HIVE-4025.D8601.1.patch
>
>
> There are many useful non-static methods on type of primitive types. But 
> current reflect UDF cannot invoke those. For example,
> select reflect2(value, "replace", "val", "VALUE") from src;
> which replaces 'val' part of value column with 'VALUE'

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (HIVE-4025) Add reflect UDF for member method invocation of column

2013-02-19 Thread Phabricator (JIRA)

[ 
https://issues.apache.org/jira/browse/HIVE-4025?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13581378#comment-13581378
 ] 

Phabricator commented on HIVE-4025:
---

brock has commented on the revision "HIVE-4025 [jira] Add reflect UDF for 
member method invocation of column".

  Hi,

  Is there are a better name than reflect2? Perhaps reflect_obj, reflect_inst, 
or something else?

  Brock

REVISION DETAIL
  https://reviews.facebook.net/D8601

To: JIRA, navis
Cc: njain, brock


> Add reflect UDF for member method invocation of column
> --
>
> Key: HIVE-4025
> URL: https://issues.apache.org/jira/browse/HIVE-4025
> Project: Hive
>  Issue Type: Improvement
>  Components: UDF
>Reporter: Navis
>Assignee: Navis
>Priority: Trivial
> Attachments: HIVE-4025.D8601.1.patch
>
>
> There are many useful non-static methods on type of primitive types. But 
> current reflect UDF cannot invoke those. For example,
> select reflect2(value, "replace", "val", "VALUE") from src;
> which replaces 'val' part of value column with 'VALUE'

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira


[jira] [Commented] (HIVE-4025) Add reflect UDF for member method invocation of column

2013-02-18 Thread Phabricator (JIRA)

[ 
https://issues.apache.org/jira/browse/HIVE-4025?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13581015#comment-13581015
 ] 

Phabricator commented on HIVE-4025:
---

njain has commented on the revision "HIVE-4025 [jira] Add reflect UDF for 
member method invocation of column".

INLINE COMMENTS
  ql/src/test/results/clientpositive/udf_reflect2.q.out:312 Have you run all 
tests ?

  I think, show_functions need to be updated.

  The last columns seem to be wrong:

  look at the results for

  getYear
  getMonth
  getDay etc.

REVISION DETAIL
  https://reviews.facebook.net/D8601

To: JIRA, navis
Cc: njain


> Add reflect UDF for member method invocation of column
> --
>
> Key: HIVE-4025
> URL: https://issues.apache.org/jira/browse/HIVE-4025
> Project: Hive
>  Issue Type: Improvement
>  Components: UDF
>Reporter: Navis
>Assignee: Navis
>Priority: Trivial
> Attachments: HIVE-4025.D8601.1.patch
>
>
> There are many useful non-static methods on type of primitive types. But 
> current reflect UDF cannot invoke those. For example,
> select reflect2(value, "replace", "val", "VALUE") from src;
> which replaces 'val' part of value column with 'VALUE'

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira