[jira] [Updated] (LUCENE-5260) Make older Suggesters more accepting of TermFreqPayloadIterator

2013-10-12 Thread Areek Zillur (JIRA)

 [ 
https://issues.apache.org/jira/browse/LUCENE-5260?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Areek Zillur updated LUCENE-5260:
-

Attachment: LUCENE-5260.patch

Thanks for the review, Michael! I fixed the UnsortedTermFreqIteratorWrapper 
issue and added the asserts.

Uploaded patch
  - added support for payloads in SortedTermFreqPayloadIteratorWrapper
  - nuked all termFreqIter and co
  - renamed all the termFreq implementations 
  - added tests

 

 Make older Suggesters more accepting of TermFreqPayloadIterator
 ---

 Key: LUCENE-5260
 URL: https://issues.apache.org/jira/browse/LUCENE-5260
 Project: Lucene - Core
  Issue Type: Improvement
  Components: core/search
Reporter: Areek Zillur
 Attachments: LUCENE-5260.patch, LUCENE-5260.patch


 As discussed in https://issues.apache.org/jira/browse/LUCENE-5251, it would 
 be nice to make the older suggesters accepting of TermFreqPayloadIterator and 
 throw an exception if payload is found (if it cannot be used). 
 This will also allow us to nuke most of the other interfaces for 
 BytesRefIterator. 



--
This message was sent by Atlassian JIRA
(v6.1#6144)

-
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org



[jira] [Updated] (LUCENE-5260) Make older Suggesters more accepting of TermFreqPayloadIterator

2013-10-11 Thread Areek Zillur (JIRA)

 [ 
https://issues.apache.org/jira/browse/LUCENE-5260?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
 ]

Areek Zillur updated LUCENE-5260:
-

Attachment: LUCENE-5260.patch

Uploaded Patch:
  - changed the input to lookup.build to take TermFreqPayloadIterator instead 
of TermFreqPayloadIterator 
  - made all suggesters compatible with termFreqPayloadIterator (but error if 
payload is present but cannot be used)
  - nuked all implementations of TermFreq and made them work with 
termFreqPayload instead (Except for SortedTermFreqIteratorWrapper). 
  - got rid of all the references to termFreqIter

Still todo:
  - actually nuke TermFreqIterator
  - change the names of the implementations to reflect that they are 
implementations of TermFreqPayloadIter
  - add tests to ensure that all the implementations work with payload
  - support payloads in SortedTermFreqIteratorWrapper

 Make older Suggesters more accepting of TermFreqPayloadIterator
 ---

 Key: LUCENE-5260
 URL: https://issues.apache.org/jira/browse/LUCENE-5260
 Project: Lucene - Core
  Issue Type: Improvement
  Components: core/search
Reporter: Areek Zillur
 Attachments: LUCENE-5260.patch


 As discussed in https://issues.apache.org/jira/browse/LUCENE-5251, it would 
 be nice to make the older suggesters accepting of TermFreqPayloadIterator and 
 throw an exception if payload is found (if it cannot be used). 
 This will also allow us to nuke most of the other interfaces for 
 BytesRefIterator. 



--
This message was sent by Atlassian JIRA
(v6.1#6144)

-
To unsubscribe, e-mail: dev-unsubscr...@lucene.apache.org
For additional commands, e-mail: dev-h...@lucene.apache.org