Hey,

Blast from the past :) I had this flagged in my design issues folder (Thanks, mailtags!) and noticed we don't have it in the proposals.

Full thread: http://mail-archives.apache.org/mod_mbox/maven-dev/ 200608.mbox/[EMAIL PROTECTED]

Jason - is this another one to write up, or did this already get addressed in another way? I don't recall seeing it implemented, but I could be wrong.

Cheers,
Brett

Begin forwarded message:

From: Jason van Zyl <[EMAIL PROTECTED]>
Date: 22 August 2006 9:40:53 AM
To: Maven Developers List <dev@maven.apache.org>
Subject: Standards for Plugin Parameters
Reply-To: "Maven Developers List" <dev@maven.apache.org>
List-Id: "Maven Developers List" <dev.maven.apache.org>
Message-Id: <[EMAIL PROTECTED]>

Hi,

While working on MJAR-7, John and I discussed a possible standard for plugin parameters naming conventions. Which basically boil down to:

field/property = noun|verbNoun
expression    = prefix.noun|verbNoun

So for MJAR-7 we have

field             = forceCreation
expression = jar.forceCreation

So we are using camel case to avoid any potential interpolation problems, the noun|verbNoun form to use used within the plugin configuration, and the prefix.noun|verbNoun on the command line to prevent name collisions with other plugins.

So that would be:

<plugin>
  <artifact-id>maven-jar-plugin</artifact-id>
  <configuration>
    <forceCreation>false</forceCreation>
  </configuration>
</plugin>

And on the command line it would be

mvn -Djar.forceCreation=false

I've seen all sorts of format for parameters as with everything the format is arbitrary but it would be good to have a standard guideline to follow.

Anyone else have any thoughts?

Jason van Zyl
[EMAIL PROTECTED]




---------------------------------------------------------------------
To unsubscribe, e-mail: [EMAIL PROTECTED]
For additional commands, e-mail: [EMAIL PROTECTED]

--
Brett Porter - [EMAIL PROTECTED]
Blog: http://www.devzuz.org/blogs/bporter/

Reply via email to