[jira] [Commented] (OFBIZ-7763) Replace bshInterpreter with groovyShell

2016-07-13 Thread Gil Portenseigne (JIRA)

[ 
https://issues.apache.org/jira/browse/OFBIZ-7763?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=15375263#comment-15375263
 ] 

Gil Portenseigne commented on OFBIZ-7763:
-

Yes Jacques, i did hesitated to implement it like that,  i will try and test 
this upgrade next week, if no-one has already done it since.

> Replace bshInterpreter with groovyShell
> ---
>
> Key: OFBIZ-7763
> URL: https://issues.apache.org/jira/browse/OFBIZ-7763
> Project: OFBiz
>  Issue Type: Improvement
>  Components: framework
>Affects Versions: Trunk
>Reporter: Gil Portenseigne
>Assignee: Gil Portenseigne
> Fix For: Upcoming Branch
>
> Attachments: OFBIZ-7763.patch, beanshell-removal-part1.patch
>
>
> To support the migration to gradle, removing bsh.jar dependency from the 
> project, and improve readability and fonctionnalities following 
> [~deepak.dixit] idea expressed here 
> https://issues.apache.org/jira/browse/OFBIZ-7576?focusedCommentId=15347972



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Commented] (OFBIZ-7763) Replace bshInterpreter with groovyShell

2016-07-12 Thread Jacques Le Roux (JIRA)

[ 
https://issues.apache.org/jira/browse/OFBIZ-7763?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=15374400#comment-15374400
 ] 

Jacques Le Roux commented on OFBIZ-7763:


I finally don't think we need to say more about that to users. Variables names 
should simply follow Java syntax (I just learnt that $ is an acceptable 
character in a Java variable name but is not recommended, at least to start 
with http://www.oracle.com/technetwork/java/codeconventions-135099.html#367).

To follow Java syntax, where variables names can contain but not start by 
numbers, I'd simply replace Alpha by Alnum in the regexp. Of course, variables 
names starting by a number and isolated numbers should be removed from the 
variables names list. I see no other issues introduced by replacing Alpha by 
Alnum, but better to think twice ;)


> Replace bshInterpreter with groovyShell
> ---
>
> Key: OFBIZ-7763
> URL: https://issues.apache.org/jira/browse/OFBIZ-7763
> Project: OFBiz
>  Issue Type: Improvement
>  Components: framework
>Affects Versions: Trunk
>Reporter: Gil Portenseigne
>Assignee: Gil Portenseigne
> Fix For: Upcoming Branch
>
> Attachments: OFBIZ-7763.patch, beanshell-removal-part1.patch
>
>
> To support the migration to gradle, removing bsh.jar dependency from the 
> project, and improve readability and fonctionnalities following 
> [~deepak.dixit] idea expressed here 
> https://issues.apache.org/jira/browse/OFBIZ-7576?focusedCommentId=15347972



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Commented] (OFBIZ-7763) Replace bshInterpreter with groovyShell

2016-07-12 Thread Gil Portenseigne (JIRA)

[ 
https://issues.apache.org/jira/browse/OFBIZ-7763?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=15372765#comment-15372765
 ] 

Gil Portenseigne commented on OFBIZ-7763:
-

Yes I tried to be clear enough in code to ease improvement, this trick is there 
to avoid going through the 1600+ use-when in the codebase, adding "context." to 
each variable.

But i do not know where to write it down other than in the code itself. (thanks 
for the review by the way)

> Replace bshInterpreter with groovyShell
> ---
>
> Key: OFBIZ-7763
> URL: https://issues.apache.org/jira/browse/OFBIZ-7763
> Project: OFBiz
>  Issue Type: Improvement
>  Components: framework
>Affects Versions: Trunk
>Reporter: Gil Portenseigne
>Assignee: Gil Portenseigne
> Fix For: Upcoming Branch
>
> Attachments: OFBIZ-7763.patch, beanshell-removal-part1.patch
>
>
> To support the migration to gradle, removing bsh.jar dependency from the 
> project, and improve readability and fonctionnalities following 
> [~deepak.dixit] idea expressed here 
> https://issues.apache.org/jira/browse/OFBIZ-7576?focusedCommentId=15347972



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Commented] (OFBIZ-7763) Replace bshInterpreter with groovyShell

2016-07-12 Thread Jacques Le Roux (JIRA)

[ 
https://issues.apache.org/jira/browse/OFBIZ-7763?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=15372702#comment-15372702
 ] 

Jacques Le Roux commented on OFBIZ-7763:


I read in the commit comment 
bq. Today only alphabetic variable with '_' are detected (i.e. 
my_variable==null).
and in commit this snippet
{code}
+if (UtilValidate.isNotEmpty(expression)) {
+//analyse expression to find variables by split non alpha, 
ignoring "_" to allow my_variable usage
+String [] variables = expression.split("[\\P{Alpha}&&[^_]]+");
+for (String variable: variables)
+if(!vars.containsKey(variable)) vars.put(variable, null);
+}
{code}

Should we not make this clearer somewhere (not sure how, just asking at this 
point)?

> Replace bshInterpreter with groovyShell
> ---
>
> Key: OFBIZ-7763
> URL: https://issues.apache.org/jira/browse/OFBIZ-7763
> Project: OFBiz
>  Issue Type: Improvement
>  Components: framework
>Affects Versions: Trunk
>Reporter: Gil Portenseigne
>Assignee: Gil Portenseigne
> Fix For: Upcoming Branch
>
> Attachments: OFBIZ-7763.patch, beanshell-removal-part1.patch
>
>
> To support the migration to gradle, removing bsh.jar dependency from the 
> project, and improve readability and fonctionnalities following 
> [~deepak.dixit] idea expressed here 
> https://issues.apache.org/jira/browse/OFBIZ-7576?focusedCommentId=15347972



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Commented] (OFBIZ-7763) Replace bshInterpreter with groovyShell

2016-07-11 Thread Rishi Solanki (JIRA)

[ 
https://issues.apache.org/jira/browse/OFBIZ-7763?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=15370508#comment-15370508
 ] 

Rishi Solanki commented on OFBIZ-7763:
--

Reported issue with probable solution on sub-ticket: 
https://issues.apache.org/jira/browse/OFBIZ-7765

> Replace bshInterpreter with groovyShell
> ---
>
> Key: OFBIZ-7763
> URL: https://issues.apache.org/jira/browse/OFBIZ-7763
> Project: OFBiz
>  Issue Type: Improvement
>  Components: framework
>Affects Versions: Trunk
>Reporter: Gil Portenseigne
>Assignee: Gil Portenseigne
> Attachments: OFBIZ-7763.patch, OFBIZ-7763.patch, 
> beanshell-removal-part1.patch
>
>
> To support the migration to gradle, removing bsh.jar dependency from the 
> project, and improve readability and fonctionnalities following 
> [~deepak.dixit] idea expressed here 
> https://issues.apache.org/jira/browse/OFBIZ-7576?focusedCommentId=15347972



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Commented] (OFBIZ-7763) Replace bshInterpreter with groovyShell

2016-07-08 Thread Jacopo Cappellato (JIRA)

[ 
https://issues.apache.org/jira/browse/OFBIZ-7763?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=15368074#comment-15368074
 ] 

Jacopo Cappellato commented on OFBIZ-7763:
--

In revision 1751947 I have committed my patch named patch 
beanshell-removal-part1.patch

To summarize, the remaining tasks are now:

1) replace bshInterpreter with groovyShell
2) remove the jars: bsh-engine-modified.jar and bsh-2.0b4.jar


> Replace bshInterpreter with groovyShell
> ---
>
> Key: OFBIZ-7763
> URL: https://issues.apache.org/jira/browse/OFBIZ-7763
> Project: OFBiz
>  Issue Type: Improvement
>  Components: framework
>Affects Versions: Trunk
>Reporter: Gil Portenseigne
>Assignee: Gil Portenseigne
> Attachments: OFBIZ-7763.patch, beanshell-removal-part1.patch
>
>
> To support the migration to gradle, removing bsh.jar dependency from the 
> project, and improve readability and fonctionnalities following 
> [~deepak.dixit] idea expressed here 
> https://issues.apache.org/jira/browse/OFBIZ-7576?focusedCommentId=15347972



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Commented] (OFBIZ-7763) Replace bshInterpreter with groovyShell

2016-07-08 Thread Jacopo Cappellato (JIRA)

[ 
https://issues.apache.org/jira/browse/OFBIZ-7763?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=15367393#comment-15367393
 ] 

Jacopo Cappellato commented on OFBIZ-7763:
--

There are 143 occurrences of  elements... we may need a call to 
action for the community to convert all of them.

> Replace bshInterpreter with groovyShell
> ---
>
> Key: OFBIZ-7763
> URL: https://issues.apache.org/jira/browse/OFBIZ-7763
> Project: OFBiz
>  Issue Type: Improvement
>  Components: framework
>Affects Versions: Trunk
>Reporter: Gil Portenseigne
>Assignee: Gil Portenseigne
> Attachments: OFBIZ-7763.patch, beanshell-removal-part1.patch
>
>
> To support the migration to gradle, removing bsh.jar dependency from the 
> project, and improve readability and fonctionnalities following 
> [~deepak.dixit] idea expressed here 
> https://issues.apache.org/jira/browse/OFBIZ-7576?focusedCommentId=15347972



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Commented] (OFBIZ-7763) Replace bshInterpreter with groovyShell

2016-07-08 Thread Jacopo Cappellato (JIRA)

[ 
https://issues.apache.org/jira/browse/OFBIZ-7763?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=15367318#comment-15367318
 ] 

Jacopo Cappellato commented on OFBIZ-7763:
--

Similarly, another subtasks very useful in preparation for the removal is the 
conversion af all the minilang calls to 
into calls to 

[jira] [Commented] (OFBIZ-7763) Replace bshInterpreter with groovyShell

2016-07-08 Thread Deepak Dixit (JIRA)

[ 
https://issues.apache.org/jira/browse/OFBIZ-7763?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=15367307#comment-15367307
 ] 

Deepak Dixit commented on OFBIZ-7763:
-

Here is the ticket for this work OFBIZ-7763

> Replace bshInterpreter with groovyShell
> ---
>
> Key: OFBIZ-7763
> URL: https://issues.apache.org/jira/browse/OFBIZ-7763
> Project: OFBiz
>  Issue Type: Improvement
>  Components: framework
>Affects Versions: Trunk
>Reporter: Gil Portenseigne
>Assignee: Gil Portenseigne
> Attachments: OFBIZ-7763.patch
>
>
> To support the migration to gradle, removing bsh.jar dependency from the 
> project, and improve readability and fonctionnalities following 
> [~deepak.dixit] idea expressed here 
> https://issues.apache.org/jira/browse/OFBIZ-7576?focusedCommentId=15347972



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Commented] (OFBIZ-7763) Replace bshInterpreter with groovyShell

2016-07-08 Thread Jacopo Cappellato (JIRA)

[ 
https://issues.apache.org/jira/browse/OFBIZ-7763?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=15367297#comment-15367297
 ] 

Jacopo Cappellato commented on OFBIZ-7763:
--

One subtask that could be useful in preparation for the removal would be that 
of converting the calls to ${bsh: to groovy calls.
There are just few left in the accounting component.
Once they are gone, we can start the removal of some code.

> Replace bshInterpreter with groovyShell
> ---
>
> Key: OFBIZ-7763
> URL: https://issues.apache.org/jira/browse/OFBIZ-7763
> Project: OFBiz
>  Issue Type: Improvement
>  Components: framework
>Affects Versions: Trunk
>Reporter: Gil Portenseigne
>Assignee: Gil Portenseigne
> Attachments: OFBIZ-7763.patch
>
>
> To support the migration to gradle, removing bsh.jar dependency from the 
> project, and improve readability and fonctionnalities following 
> [~deepak.dixit] idea expressed here 
> https://issues.apache.org/jira/browse/OFBIZ-7576?focusedCommentId=15347972



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)


[jira] [Commented] (OFBIZ-7763) Replace bshInterpreter with groovyShell

2016-07-08 Thread Gil Portenseigne (JIRA)

[ 
https://issues.apache.org/jira/browse/OFBIZ-7763?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel=15367290#comment-15367290
 ] 

Gil Portenseigne commented on OFBIZ-7763:
-

[~deepak.dixit] keep in mind thats an unfinished work, do not hesitate to 
comment/improve it :)

> Replace bshInterpreter with groovyShell
> ---
>
> Key: OFBIZ-7763
> URL: https://issues.apache.org/jira/browse/OFBIZ-7763
> Project: OFBiz
>  Issue Type: Improvement
>  Components: framework
>Affects Versions: Trunk
>Reporter: Gil Portenseigne
>Assignee: Gil Portenseigne
> Attachments: OFBIZ-7763.patch
>
>
> To support the migration to gradle, removing bsh.jar dependency from the 
> project, and improve readability and fonctionnalities following 
> [~deepak.dixit] idea expressed here 
> https://issues.apache.org/jira/browse/OFBIZ-7576?focusedCommentId=15347972



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)